summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblinx2021-09-23 02:08:21 +0200
committerblinx2021-09-23 02:08:21 +0200
commite693516cb716d8570dc46d0c9ee2c163c2e62f3f (patch)
tree6fe755b8766f17c1117860d40005a6bda5da2b2a
parentb2194a5f85282bc75fc496e47c0104331be41a89 (diff)
downloadaur-e693516cb716d8570dc46d0c9ee2c163c2e62f3f.tar.gz
updated to 0.2.5.r2.g0233106
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD44
2 files changed, 23 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ee729f23612..c858af3389f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = libwebcam-git
pkgdesc = A library that is designed to simplify the development of webcam applications
- pkgver = 20160427
+ pkgver = 0.2.5.r2.g0233106
pkgrel = 1
url = http://sourceforge.net/projects/libwebcam/
arch = i686
arch = x86_64
- license = GPL
+ license = GPL3
makedepends = cmake
makedepends = linux-headers
+ makedepends = git
depends = libxml2
+ source = libwebcam-git::git+http://git.code.sf.net/p/libwebcam/code
source = fix_path.patch
+ sha512sums = SKIP
sha512sums = bd2c86e5e32a20a85bb36cdcfb47737a6bbf6dfd2b44126de679d7cd241eefcdec8983a54236d0ee574c2439c3deafafba3d02695ce5d8128a6646d7c9395d6e
pkgname = libwebcam-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 9dfe6f0831a4..f5607a054788 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,32 @@
-# Contributor: Trevor Jim
-# Maintainer: Sean Greenslade <aur AT seangreenslade DOT com>
+# Contributor: Trevor Jim, amezin
+# Maintainer: Carlos Bellino <carlosbellino@gmail.com>
pkgname=libwebcam-git
-pkgver=20160427
+pkgver=0.2.5.r2.g0233106
pkgrel=1
pkgdesc="A library that is designed to simplify the development of webcam applications"
arch=(i686 x86_64)
url="http://sourceforge.net/projects/libwebcam/"
-license=('GPL')
+license=('GPL3')
depends=('libxml2')
-makedepends=('cmake' 'linux-headers')
-source=('fix_path.patch')
+makedepends=('cmake' 'linux-headers' 'git')
+source=("$pkgname::git+http://git.code.sf.net/p/libwebcam/code" 'fix_path.patch')
+sha512sums=('SKIP' 'bd2c86e5e32a20a85bb36cdcfb47737a6bbf6dfd2b44126de679d7cd241eefcdec8983a54236d0ee574c2439c3deafafba3d02695ce5d8128a6646d7c9395d6e')
-_gitroot="http://git.code.sf.net/p/libwebcam/code"
-_gitname="libwebcam"
-
-build() {
- cd $srcdir
- msg 'Connecting to GIT server...'
- if [ -d $_gitname ] ; then
- (cd $_gitname; git pull origin)
- msg 'The local files are updated.'
- else
- git clone $_gitroot $_gitname
- fi
- msg "GIT checkout done or server timeout"
-
- patch -p1 < fix_path.patch
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed 's/^v//g' | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
- msg "Starting make..."
+prepare() {
+ cd $pkgname
+ patch -p2 -i ../fix_path.patch
+}
- rm -rf build
- mkdir build
+build() {
+ mkdir -p build
cd build
- cmake ../$_gitname -DCMAKE_INSTALL_PREFIX=/usr -DUVCVIDEO_INCLUDE_PATH=../common/include/
+ cmake ../$pkgname -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib
make
}
@@ -41,4 +34,3 @@ package() {
cd $srcdir/build
make DESTDIR=$pkgdir install
}
-sha512sums=('bd2c86e5e32a20a85bb36cdcfb47737a6bbf6dfd2b44126de679d7cd241eefcdec8983a54236d0ee574c2439c3deafafba3d02695ce5d8128a6646d7c9395d6e')