summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRen2023-01-06 20:05:54 +0800
committerRen2023-01-06 20:05:54 +0800
commit775c2e804347f2069e905a098100ea89662a1832 (patch)
treeee4a99e523f9f3358e638b42e734bdbc9999754f
downloadaur-libwnck3-336.tar.gz
Initial Commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD43
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a9eaba576ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = libwnck3-336
+ pkgdesc = Library to manage X windows and workspaces (via pagers, tasklists, etc.) 3.36 version (Workaround for https://github.com/mate-desktop/mate-panel/issues/1230)
+ pkgver = 3.36.0
+ pkgrel = 1
+ url = https://gitlab.gnome.org/GNOME/libwnck
+ arch = x86_64
+ license = LGPL
+ makedepends = gobject-introspection
+ makedepends = gtk-doc
+ makedepends = git
+ makedepends = meson
+ depends = gtk3
+ depends = startup-notification
+ depends = libxres
+ provides = libwnck3
+ conflicts = libwnck3
+ options = debug
+ source = git+https://gitlab.gnome.org/GNOME/libwnck.git#commit=3c469a0d7e58e36106eea7600ae2f6fd8aaed232
+ b2sums = SKIP
+
+pkgname = libwnck3-336
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ad77b72aa07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: LordDemecrius83 <lorddemecrius83@proton.me>
+# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+
+pkgname=libwnck3-336
+pkgver=3.36.0
+pkgrel=1
+pkgdesc="Library to manage X windows and workspaces (via pagers, tasklists, etc.) 3.36 version (Workaround for https://github.com/mate-desktop/mate-panel/issues/1230)"
+url="https://gitlab.gnome.org/GNOME/libwnck"
+arch=(x86_64)
+license=(LGPL)
+provides=(libwnck3)
+conflicts=(libwnck3)
+depends=(gtk3 startup-notification libxres)
+makedepends=(gobject-introspection gtk-doc git meson)
+options=(debug)
+_commit=3c469a0d7e58e36106eea7600ae2f6fd8aaed232 # tags/3.36.0^0
+source=("git+https://gitlab.gnome.org/GNOME/libwnck.git#commit=$_commit")
+b2sums=('SKIP')
+
+pkgver() {
+ cd libwnck
+ git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
+}
+
+prepare() {
+ cd libwnck
+}
+
+build() {
+ arch-meson libwnck build -D gtk_doc=true
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}
+
+# vim:set sw=2 sts=-1 et: