summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNexAdn2018-09-08 18:20:47 +0200
committerNexAdn2018-09-08 18:20:47 +0200
commitb855e84f4e51e8ac587eceaecb8be85b926c5b14 (patch)
tree77a3419c82b516b9f38d1966f48d837983e231dc
parent822aae32b59c289067edda8c07e2512fb162478a (diff)
downloadaur-libws2801.tar.gz
Version 1.1.0
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f11d6d26c3dd..efe16aa990e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libws2801
pkgdesc = C/C++ libaries for the ws2801 led strip using spidev
- pkgver = 1.0.1
+ pkgver = 1.1.0
pkgrel = 1
url = https://gitlab.com/nexadn/libws2801
arch = i686
@@ -13,6 +13,7 @@ pkgbase = libws2801
makedepends = cmake
makedepends = boost
depends = boost-libs
+ depends = qt5-base
source = git+https://gitlab.com/nexadn/libws2801.git
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 304b19a6ad01..96e0d92a89ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: NexAdn <nexadn@yandex.com>
pkgname="libws2801"
-pkgver=1.0.1
+pkgver=1.1.0
pkgrel=1
pkgdesc="C/C++ libaries for the ws2801 led strip using spidev"
arch=("i686" "x86_64" "armv6h" "armv7h" "aarch64")
url="https://gitlab.com/nexadn/libws2801"
license=("GPL")
-depends=("boost-libs")
+depends=("boost-libs" "qt5-base")
makedepends=("git" "cmake" "boost")
source=("git+https://gitlab.com/nexadn/libws2801.git")
sha512sums=('SKIP')
@@ -14,7 +14,7 @@ sha512sums=('SKIP')
build() {
mkdir -p "$srcdir/libws2801/build"
cd "$srcdir/libws2801/build"
- git checkout v1.0.1
+ git checkout v${pkgver}
cmake -DCMAKE_INSTALL_PREFIX="/usr" -DNOEXAMPLES=true ..
make
}