summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFantix King2015-11-08 00:53:02 +0800
committerFantix King2015-11-08 00:53:02 +0800
commitefbe008c4cf6e56587247e9a44bbcec0e1bd2d22 (patch)
tree854d84c38ad94f33775815440f482da2658a3dbb
parent06ec4b24cda9ee56723681799ed010b34e741074 (diff)
downloadaur-libx32-sqlite.tar.gz
3.9.1-1.1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD37
2 files changed, 29 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71b2cfe1c73a..a688ab3dadbf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libx32-sqlite
pkgdesc = A C library that implements an SQL database engine (x32 ABI)
- pkgver = 3.8.8.2
+ pkgver = 3.9.1
pkgrel = 1.1
url = http://www.sqlite.org/
arch = x86_64
@@ -10,11 +10,12 @@ pkgbase = libx32-sqlite
makedepends = libx32-readline
depends = libx32-glibc
depends = sqlite
- provides = libx32-sqlite3=3.8.8.2
+ provides = libx32-sqlite3=3.9.1
conflicts = libx32-sqlite3
replaces = libx32-sqlite3
- source = http://www.sqlite.org/2015/sqlite-autoconf-3080802.tar.gz
- sha1sums = 1db237523419af7110e1d92c6b766e965f9322e4
+ options = !makeflags
+ source = http://www.sqlite.org/2015/sqlite-src-3090100.zip
+ sha1sums = 7711364f78dae9110a7c8b62eba27c37aacb4205
pkgname = libx32-sqlite
diff --git a/PKGBUILD b/PKGBUILD
index 8fdac5a543d7..bf254ceee959 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 126859 2015-01-31 15:00:35Z lcarlier $
+# $Id: PKGBUILD 144999 2015-10-26 07:27:19Z lcarlier $
# Maintainer: Biru Ionut <ionut@archlinux.ro>
# Contributor: Mikko Seppälä <t-r-a-y@mbnet.fi>
# Contributor: Kaos < gianlucaatlas dot gmail dot com >
@@ -6,10 +6,9 @@
_pkgbasename=sqlite
pkgname=libx32-sqlite
-_amalgamationver=3080802
-_docver=${_amalgamationver}
-#_docver=3080401
-pkgver=3.8.8.2
+_srcver=3090100
+_docver=${_srcver}
+pkgver=3.9.1
pkgrel=1.1
pkgdesc="A C library that implements an SQL database engine (x32 ABI)"
arch=('x86_64')
@@ -17,31 +16,43 @@ license=('custom')
url="http://www.sqlite.org/"
depends=(libx32-glibc $_pkgbasename)
makedepends=('tcl' 'gcc-multilib-x32' 'libx32-readline')
-source=(http://www.sqlite.org/2015/sqlite-autoconf-${_amalgamationver}.tar.gz)
-sha1sums=('1db237523419af7110e1d92c6b766e965f9322e4')
+source=(http://www.sqlite.org/2015/sqlite-src-${_srcver}.zip)
+sha1sums=('7711364f78dae9110a7c8b62eba27c37aacb4205')
+options=('!makeflags')
provides=("libx32-sqlite3=$pkgver")
replaces=("libx32-sqlite3")
conflicts=("libx32-sqlite3")
+prepare() {
+ cd "$srcdir"/sqlite-src-$_srcver
+ autoreconf -vfi
+}
+
build() {
- cd ${srcdir}/sqlite-autoconf-${_amalgamationver}
+ cd "$srcdir"/sqlite-src-$_srcver
export CC="gcc -mx32"
export CXX="g++ -mx32"
export PKG_CONFIG_PATH="/usr/libx32/pkgconfig"
export LTLINK_EXTRAS="-ldl"
- export CFLAGS="$CFLAGS -DSQLITE_ENABLE_FTS3=1 -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_ENABLE_UNLOCK_NOTIFY -DSQLITE_SECURE_DELETE"
-
- ./configure --prefix=/usr --libdir=/usr/libx32 \
+ export CFLAGS="$CFLAGS -DSQLITE_ENABLE_FTS3=1 \
+ -DSQLITE_ENABLE_COLUMN_METADATA=1 \
+ -DSQLITE_ENABLE_UNLOCK_NOTIFY \
+ -DSQLITE_ENABLE_DBSTAT_VTAB=1 \
+ -DSQLITE_ENABLE_RTREE=1 \
+ -DSQLITE_SECURE_DELETE"
+
+ ./configure --prefix=/usr \
+ --libdir=/usr/libx32 \
+ --disable-tcl \
--disable-static
make
}
-
package() {
- cd ${srcdir}/sqlite-autoconf-${_amalgamationver}
+ cd "$srcdir"/sqlite-src-$_srcver
make DESTDIR=${pkgdir} install