summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJashank Jeremy2021-06-26 00:05:08 +1000
committerJashank Jeremy2021-06-26 00:05:08 +1000
commit1d36ae78ffac2a897f58775af82470f659bacde6 (patch)
tree54b39a6553ef26cf60e5db8156c38efce04ae330
parent4f69d1b653a69cfc6b028f4f1dc87691370b00b7 (diff)
downloadaur-libxo.tar.gz
libxo-1.6.0-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
-rw-r--r--patch-libxo__xo_syslog.c14
3 files changed, 29 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef4dd3e5939d..1f6599e8d51c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libxo
pkgdesc = a library for generating text, XML, JSON, and HTML output
- pkgver = 1.4.0
+ pkgver = 1.6.0
pkgrel = 1
url = https://github.com/juniper/libxo
arch = x86_64
@@ -8,8 +8,9 @@ pkgbase = libxo
makedepends = git
provides = libxo
conflicts = libxo-git
- source = git+https://github.com/juniper/libxo.git#tag=1.4.0
+ source = git+https://github.com/juniper/libxo.git#tag=1.6.0
+ source = patch-libxo__xo_syslog.c
md5sums = SKIP
+ md5sums = 6a0431e5a69f2691836af7ef363f90de
pkgname = libxo
-
diff --git a/PKGBUILD b/PKGBUILD
index 740579edadcb..9f874a306215 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jashank Jeremy <arch-aur at jashankj dot space>
pkgname=libxo
-pkgver=1.4.0
+pkgver=1.6.0
pkgrel=1
pkgdesc='a library for generating text, XML, JSON, and HTML output'
arch=('x86_64')
@@ -16,14 +16,22 @@ replaces=()
backup=()
options=()
install=
-source=("git+${url}.git#tag=${pkgver}")
+source=(
+ "git+${url}.git#tag=${pkgver}"
+ "patch-libxo__xo_syslog.c"
+)
noextract=()
-md5sums=('SKIP')
+md5sums=('SKIP' '6a0431e5a69f2691836af7ef363f90de')
pkgver() {
git -C "$srcdir/${pkgname%-git}" describe --tags
}
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ patch --forward --strip=1 --input="${srcdir}/patch-libxo__xo_syslog.c"
+}
+
build() {
cd "$srcdir/${pkgname%-git}"
sh ./bin/setup.sh
diff --git a/patch-libxo__xo_syslog.c b/patch-libxo__xo_syslog.c
new file mode 100644
index 000000000000..365e7f3d346a
--- /dev/null
+++ b/patch-libxo__xo_syslog.c
@@ -0,0 +1,14 @@
+diff --git i/libxo/xo_syslog.c w/libxo/xo_syslog.c
+index 62da181..dbef8cc 100644
+--- i/libxo/xo_syslog.c
++++ w/libxo/xo_syslog.c
+@@ -58,7 +58,9 @@
+ #include <stdarg.h>
+ #include <sys/time.h>
+ #include <sys/types.h>
++#ifdef HAVE_SYS_SYSCTL_H
+ #include <sys/sysctl.h>
++#endif
+
+ #include "xo_config.h"
+ #include "xo.h"