summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre-Yves Ritschard2018-01-04 18:32:50 +0100
committerPierre-Yves Ritschard2018-01-04 18:32:50 +0100
commit26c627e8dd76e2f0426f772eb6ee7b1b5c06da37 (patch)
treee0aaa2f8306d81a67a98f30548cffad418a27126
parent41610fcf4c6a5321f6d61cd26a7d636ef01b1b7b (diff)
downloadaur-libzookeeper.tar.gz
libzookeeper: update to latest version and fix build
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
-rw-r--r--Use-PKG_CHECK_insteadOf-AM_PATH_CPPUNIT.patch12
3 files changed, 32 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45c5a886c24f..a4f2b5acee5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libzookeeper
pkgdesc = libzookeeper
- pkgver = 3.4.7
+ pkgver = 3.4.11
pkgrel = 1
url = https://github.com/apache/zookeeper
arch = i686
@@ -8,9 +8,13 @@ pkgbase = libzookeeper
license = Apache
makedepends = apache-ant
makedepends = autoconf
- makedepends = cppunit
+ makedepends = automake
+ makedepends = cppunit
provides = libzookeper
- source = https://github.com/apache/zookeeper/archive/release-3.4.7.tar.gz
- md5sums = 6c10db76b92b860c7852343ecdc8372e
+ source = https://github.com/apache/zookeeper/archive/release-3.4.11.tar.gz
+ source = Use-PKG_CHECK_insteadOf-AM_PATH_CPPUNIT.patch
+ md5sums = c21ab388088edab98cade3f1308d352c
+ md5sums = 855b95195ae8bf987f6897ce4d175f07
pkgname = libzookeeper
+
diff --git a/PKGBUILD b/PKGBUILD
index e934111747d9..c1a0c416f390 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: <aaron.l.france@gmail.com>
pkgname=libzookeeper
-pkgver=3.4.7
+pkgver=3.4.11
pkgrel=1
pkgdesc="libzookeeper"
arch=('i686' 'x86_64')
url="https://github.com/apache/zookeeper"
license=('Apache')
-makedepends=(apache-ant autoconf cppunit)
+makedepends=(apache-ant autoconf automake cppunit)
checkdepends=()
optdepends=()
provides=(libzookeper)
-source=(https://github.com/apache/zookeeper/archive/release-$pkgver.tar.gz)
-md5sums=('6c10db76b92b860c7852343ecdc8372e')
+source=(https://github.com/apache/zookeeper/archive/release-$pkgver.tar.gz Use-PKG_CHECK_insteadOf-AM_PATH_CPPUNIT.patch)
+md5sums=('c21ab388088edab98cade3f1308d352c' '855b95195ae8bf987f6897ce4d175f07')
build() {
cd "$srcdir/zookeeper-release-$pkgver"
- ant compile_jute
+ ant clean jar
cd src/c
- autoreconf -if
- ./configure --prefix=/usr
+ ACLOCAL="aclocal -I /usr/share/aclocal" autoreconf -if
+ ./configure --prefix=/usr && make
}
package() {
@@ -27,4 +27,9 @@ package() {
make DESTDIR="$pkgdir/" install
}
+prepare() {
+ cd "$srcdir/zookeeper-release-$pkgver/"
+ patch -p1 -i ../Use-PKG_CHECK_insteadOf-AM_PATH_CPPUNIT.patch
+}
+
# vim:set ts=2 sw=2 et:
diff --git a/Use-PKG_CHECK_insteadOf-AM_PATH_CPPUNIT.patch b/Use-PKG_CHECK_insteadOf-AM_PATH_CPPUNIT.patch
new file mode 100644
index 000000000000..e245445c3340
--- /dev/null
+++ b/Use-PKG_CHECK_insteadOf-AM_PATH_CPPUNIT.patch
@@ -0,0 +1,12 @@
+diff -ura --color zookeeper-release-3.4.7/src/c/configure.ac new/src/c/configure.ac
+--- zookeeper-release-3.4.7/src/c/configure.ac 2015-11-21 20:07:24.000000000 +0100
++++ new/src/c/configure.ac 2017-12-18 13:38:33.429573797 +0100
+@@ -37,7 +37,7 @@
+ CPPUNIT_INCLUDE=
+ CPPUNIT_LIBS=
+ else
+- AM_PATH_CPPUNIT(1.10.2)
++ PKG_CHECK_MODULES(CPPUNIT, cppunit >= 1.10.2)
+ fi
+
+ if test "$CALLER" = "ANT" ; then \ No newline at end of file