summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorerdii2025-01-22 09:53:21 +0100
committererdii2025-01-22 09:53:21 +0100
commitc3d463c3522af2ff95f02a140821b8f54aadd213 (patch)
treec38fe3ae2d4a485b5adf05e60b3420d1557a075a
downloadaur-lichen.tar.gz
init 0.1.7
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD23
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38f8152cc7ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = lichen
+ pkgdesc = Go binary license checker. Extracts module usage information from binaries and analyses their licenses.
+ pkgver = 0.1.7
+ pkgrel = 1
+ url = https://github.com/uw-labs/lichen
+ arch = any
+ license = MIT
+ makedepends = go
+ provides = lichen
+ source = lichen-0.1.7::git+https://github.com/uw-labs/lichen#tag=v0.1.7
+ sha256sums = a800f5e6dc11857c3a32226a283dbb449a9960c7a588db307c349da0938f27da
+
+pkgname = lichen
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7751d0fccd7c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+*.tar.zst
+src/
+pkg/
+lichen-*/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22ffd68619e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: erdii <me at erdii dot engineering>
+pkgname=lichen
+pkgver=0.1.7
+pkgrel=1
+pkgdesc="Go binary license checker. Extracts module usage information from binaries and analyses their licenses."
+arch=("any")
+provides=("lichen")
+conflicts=()
+url="https://github.com/uw-labs/lichen"
+license=("MIT")
+depends=()
+makedepends=("go")
+source=("lichen-${pkgver}::git+https://github.com/uw-labs/lichen#tag=v${pkgver}")
+sha256sums=('65af7c79df78471d296cabe5935323748afc57561568dd181f3f46a123e562b6')
+
+build() {
+ cd "${srcdir}/lichen-${pkgver}"
+ go build -o lichen .
+}
+
+package() {
+ install -Dm755 "${srcdir}/lichen-${pkgver}/lichen" "${pkgdir}/usr/bin/lichen"
+}