summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAyrton Sparling2016-12-27 10:33:16 -0800
committerAyrton Sparling2016-12-27 10:33:16 -0800
commit6d17fa3956d7aa05cbbaefdecac1fa72e067370b (patch)
tree432401357bea436537b7375ca073ff6ae043739a
downloadaur-lightdm-webkit2-theme-material2-git.tar.gz
Initial upload
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e9767085094e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lightdm-webkit2-theme-material2-git
+ pkgdesc = A material design LightDM theme for lightdm-webkit2-greeter from the latest git
+ pkgver = r15.2e21881
+ pkgrel = 1
+ url = https://github.com/FallingSnow/lightdm-webkit2-material2
+ arch = any
+ license = WTFPL
+ makedepends = npm
+ makedepends = nodejs
+ depends = lightdm-webkit2-greeter
+ conflicts = lightdm-webkit2-theme-material2
+ source = git+https://github.com/FallingSnow/lightdm-webkit2-material2.git
+ sha512sums = SKIP
+
+pkgname = lightdm-webkit2-theme-material2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a30dba6790d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Ayrton Sparling <ayrton@sparling.us>
+_pkgname=lightdm-webkit2-material2
+pkgname=lightdm-webkit2-theme-material2-git
+pkgdesc="A material design LightDM theme for lightdm-webkit2-greeter from the latest git"
+pkgver=r15.2e21881
+pkgrel=1
+arch=('any')
+url="https://github.com/FallingSnow/${_pkgname}"
+license=('WTFPL')
+depends=('lightdm-webkit2-greeter')
+makedepends=('npm' 'nodejs')
+conflicts=('lightdm-webkit2-theme-material2')
+source=("git+https://github.com/FallingSnow/${_pkgname}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ npm install
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ npm run build
+}
+
+package() {
+ install -dm755 "$pkgdir/usr/share/lightdm-webkit/themes/material2"
+ cp -r "$srcdir/$_pkgname/build/"* \
+ "$pkgdir/usr/share/lightdm-webkit/themes/material2/"
+}