summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2020-12-19 16:13:49 -0500
committerGuillaume Horel2020-12-19 16:13:49 -0500
commit034b42b52c7aec3cafd59c3a522e8f302df563b2 (patch)
tree92b52c6c8965c29db222d9644c71b11e35bb0b72
parent254f0e34a87233e5a9fb3b47901dbd977b1e7d96 (diff)
downloadaur-034b42b52c7aec3cafd59c3a522e8f302df563b2.tar.gz
bump to 4.4.19
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4966af67055e..f4514cec3113 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = lime
pkgdesc = C++ library implementing Open Whisper System Signal protocol
- pkgver = 4.4.13
+ pkgver = 4.4.19
pkgrel = 1
url = http://www.linphone.org/
arch = x86_64
license = GPL
makedepends = cmake
- depends = bctoolbox=4.4.13
+ depends = bctoolbox=4.4.19
depends = soci>=4.0.0
- source = lime-4.4.13.tar.gz::https://github.com/BelledonneCommunications/lime/archive/4.4.13.tar.gz
- sha256sums = fca4b32c82e9fa1c2001c9c3a550a1f690af8d1b944717a8b5b3838e8b88ee5f
+ source = lime-4.4.19.tar.gz::https://github.com/BelledonneCommunications/lime/archive/4.4.19.tar.gz
+ sha256sums = 09a284a495295ad682590346864ab3eabc846389dd341409384ed52dfdfcef0a
pkgname = lime
diff --git a/PKGBUILD b/PKGBUILD
index 2987afb7ed0f..68301b43d666 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=lime
-pkgver=4.4.13
+pkgver=4.4.19
pkgrel=1
pkgdesc="C++ library implementing Open Whisper System Signal protocol"
arch=('x86_64')
@@ -10,19 +10,18 @@ license=('GPL')
depends=("bctoolbox=$pkgver" 'soci>=4.0.0')
makedepends=('cmake')
source=("$pkgname-$pkgver.tar.gz::https://github.com/BelledonneCommunications/$pkgname/archive/$pkgver.tar.gz")
-sha256sums=('fca4b32c82e9fa1c2001c9c3a550a1f690af8d1b944717a8b5b3838e8b88ee5f')
+sha256sums=('09a284a495295ad682590346864ab3eabc846389dd341409384ed52dfdfcef0a')
build() {
- mkdir -p build
- cd build
- cmake -DCMAKE_PREFIX_PATH="/usr" \
- -DCMAKE_INSTALL_PREFIX="/usr" \
- -DENABLE_STATIC="NO" \
- -DENABLE_UNIT_TESTS=NO "../$pkgname-$pkgver"
- make
+ cmake -B build $pkgname-$pkgver \
+ -DCMAKE_PREFIX_PATH="/usr" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DENABLE_STATIC="NO" \
+ -DENABLE_UNIT_TESTS=NO \
+ -Wno-dev
+ make -C build
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}" -C build install
}