summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEggz2024-01-03 10:05:24 +0100
committerEggz2024-01-03 10:05:24 +0100
commit1d2ea11b5fe2937cd356a3a60136f0cb7f76dc66 (patch)
tree0331109a31ed6c390be249b82297af0278c4733a
parentf7fc8702226b29626f8a17578937658cab930ecd (diff)
downloadaur-1d2ea11b5fe2937cd356a3a60136f0cb7f76dc66.tar.gz
remove extra kernelcopy and docs package
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD20
2 files changed, 3 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9bbaac71d6a1..da41f22802c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-amd
pkgver = 6.6.v.9
- pkgrel = 1
+ pkgrel = 2
url = https://www.kernel.org/
arch = x86_64
license = GPL2
@@ -36,6 +36,3 @@ pkgname = linux-amd
pkgname = linux-amd-headers
pkgdesc = Header files and scripts for building modules for Linux kernel aimed at the ZNVER4/MZEN4 AMD CPU based hardware
-
-pkgname = linux-amd-docs
- pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux kernel
diff --git a/PKGBUILD b/PKGBUILD
index 35b5c0450357..f5d9cd260f27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ gitver=v6.6.9
patchver=20230105
patchname=more-uarches-for-kernel-5.17+.patch
pkgver=6.6.v.9
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://www.kernel.org/"
license=('GPL2')
@@ -95,7 +95,6 @@ _package() {
mkdir -p "${pkgdir}"/{lib/modules,lib/firmware,boot}
make LOCALVERSION= INSTALL_MOD_PATH="${pkgdir}" modules_install
- cp arch/$KARCH/boot/bzImage "${pkgdir}/boot/vmlinuz-${pkgbase}"
# install mkinitcpio preset file for kernel
install -D -m644 "${srcdir}/${pkgbase}.preset" "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
@@ -209,22 +208,7 @@ _package-headers() {
}
-_package-docs() {
- pkgdesc="Kernel hackers manual - HTML documentation that comes with the Linux kernel"
-
- cd "${_srcname}"
-
- mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build"
- cp -al Documentation "${pkgdir}/usr/lib/modules/${_kernver}/build"
- find "${pkgdir}" -type f -exec chmod 444 {} \;
- find "${pkgdir}" -type d -exec chmod 755 {} \;
-
- # remove a file already in linux package
- rm -f "${pkgdir}/usr/lib/modules/${_kernver}/build/Documentation/DocBook/Makefile"
-
-}
-
-pkgname=("${pkgbase}" "${pkgbase}-headers" "${pkgbase}-docs")
+pkgname=("${pkgbase}" "${pkgbase}-headers")
for _p in ${pkgname[@]}; do
eval "package_${_p}() {
$(declare -f "_package${_p#${pkgbase}}")