summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoregnappahz2020-03-30 16:30:09 +0200
committeregnappahz2020-03-30 16:30:09 +0200
commit5fba0777d479b65af862ae70b833ed49a985f3b4 (patch)
treee9e1fe6d2fa630b7cdc626a98a1d1e2a54bce3e5
parent212983b1adef4d7c74bd9202aa0a0937d9964d48 (diff)
downloadaur-5fba0777d479b65af862ae70b833ed49a985f3b4.tar.gz
temporarily implemented intel wifi patch
Signed-off-by: egnappahz <egnappah@gmail.com>
-rw-r--r--PKGBUILD9
-rw-r--r--intelwifi.patch15
2 files changed, 22 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ecfc0f1cd691..1651d842c6fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgbase=linux-amd
_srcname=linux
gitver=v5.6
pkgver=5.6.v.0
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://www.kernel.org/"
license=('GPL2')
@@ -23,7 +23,8 @@ source=('git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git'
5012_enable-cpu-optimizations-for-gcc91.patch
# asus WMI patch
asusbat.patch
-
+ # intel WIFI patch
+ intelwifi.patch
)
sha256sums=('SKIP'
#config.x86_64
@@ -34,6 +35,8 @@ sha256sums=('SKIP'
'cc739c9c9f7ce08e6bbc161b8232208bbc00820342a32fb1f69bff6326ae1370'
#Asusbat gitfile
'c0a1604da4e0ae360f0c93a9adf244f9a8cffb5d219c94c0a58e23fb2c007a68'
+ #IntelWifi gitfile
+ 'da0be7c26de891847c0394e670d09ebd8f02c159342d21d8b0f0ec306e4e5599'
)
_kernelname=${pkgbase#linux}
@@ -62,6 +65,8 @@ prepare() {
yes "" | make prepare
# Implement suggested asus_wmi change
git apply ../asusbat.patch
+ # Implement supposed intelwifi patch
+ git apply ../intelwifi.patch
# load configuration
# Configure the kernel. Replace the line below with one of your choice.
diff --git a/intelwifi.patch b/intelwifi.patch
new file mode 100644
index 000000000000..6bfd82258819
--- /dev/null
+++ b/intelwifi.patch
@@ -0,0 +1,15 @@
+1 files changed, 2 insertions, 1 deletions
+diff --git a/net/mac80211/tx.c b/net/mac80211/tx.c
+index d9cca6dbd870..efe4c1fc68e5 100644
+--- a/net/mac80211/tx.c
++++ b/net/mac80211/tx.c
+@@ -3610,7 +3610,8 @@ begin:
+ * Drop unicast frames to unauthorised stations unless they are
+ * EAPOL frames from the local station.
+ */
+- if (unlikely(!ieee80211_vif_is_mesh(&tx.sdata->vif) &&
++ if (unlikely(ieee80211_is_data(hdr->frame_control) &&
++ !ieee80211_vif_is_mesh(&tx.sdata->vif) &&
+ tx.sdata->vif.type != NL80211_IFTYPE_OCB &&
+ !is_multicast_ether_addr(hdr->addr1) &&
+ !test_sta_flag(tx.sta, WLAN_STA_AUTHORIZED) &&