summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEggz2024-01-26 16:03:38 +0100
committerEggz2024-01-26 16:03:38 +0100
commit7ef8297685136614af7955e45fcfa48643485d66 (patch)
tree30a1b8e1e1e796a6e1c268ba32da0621fd044059
parent367d0903c5863ee5831f7eb6e172b166d85ad311 (diff)
downloadaur-7ef8297685136614af7955e45fcfa48643485d66.tar.gz
pulled patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--flushbyasid.patch45
3 files changed, 2 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad8f8f4683e7..fbde3a24065a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-amd
pkgver = 6.7.v.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.kernel.org/
arch = x86_64
license = GPL2
@@ -18,12 +18,10 @@ pkgbase = linux-amd
source = config.x86_64
source = linux-amd.preset
source = https://raw.githubusercontent.com/graysky2/kernel_compiler_patch/20230105/more-uarches-for-kernel-5.17+.patch
- source = flushbyasid.patch
sha256sums = SKIP
sha256sums = 63f7c46e9d4fbbf62e91d1fb5024e5f7043d6c6a09133ce590a0424ea9c89ec6
sha256sums = 60c6ba602443e94a9eba3aeee9d194027d69bffaa428c6d055348ebf03681b5c
sha256sums = 81ad663925a0aa5b5332a69bae7227393664bb81ee2e57a283e7f16e9ff75efe
- sha256sums = 0878a970035793ca761c6f7499fb37cf04e6d9892758ca3fb9b99f846febfaf0
pkgname = linux-amd
pkgdesc = Linux kernel aimed at the ZNVER4/MZEN4 AMD Ryzen CPU based hardware
diff --git a/PKGBUILD b/PKGBUILD
index 10757f56a1e0..2b852ce6c386 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ gitver=v6.7.2
patchver=20230105
patchname=more-uarches-for-kernel-5.17+.patch
pkgver=6.7.v.2
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://www.kernel.org/"
license=('GPL2')
@@ -20,8 +20,6 @@ source=("git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#ta
"${pkgbase}.preset"
# patch from our graysky archlinux colleague
"https://raw.githubusercontent.com/graysky2/kernel_compiler_patch/$patchver/$patchname"
- # nested KVM svm patch
- "flushbyasid.patch"
)
sha256sums=('SKIP'
#config.x86_64
@@ -30,8 +28,6 @@ sha256sums=('SKIP'
'60c6ba602443e94a9eba3aeee9d194027d69bffaa428c6d055348ebf03681b5c'
#grayskypatch
'81ad663925a0aa5b5332a69bae7227393664bb81ee2e57a283e7f16e9ff75efe'
- #flushbyasid.patch
- '0878a970035793ca761c6f7499fb37cf04e6d9892758ca3fb9b99f846febfaf0'
)
_kernelname=${pkgbase#linux}
diff --git a/flushbyasid.patch b/flushbyasid.patch
deleted file mode 100644
index 9926cc5e4218..000000000000
--- a/flushbyasid.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff --git a/arch/x86/kvm/svm/nested.c b/arch/x86/kvm/svm/nested.c
-index 3fea8c47679e..60891b9ce25f 100644
---- a/arch/x86/kvm/svm/nested.c
-+++ b/arch/x86/kvm/svm/nested.c
-@@ -247,18 +247,6 @@ static bool nested_svm_check_bitmap_pa(struct kvm_vcpu *vcpu, u64 pa, u32 size)
- kvm_vcpu_is_legal_gpa(vcpu, addr + size - 1);
- }
-
--static bool nested_svm_check_tlb_ctl(struct kvm_vcpu *vcpu, u8 tlb_ctl)
--{
-- /* Nested FLUSHBYASID is not supported yet. */
-- switch(tlb_ctl) {
-- case TLB_CONTROL_DO_NOTHING:
-- case TLB_CONTROL_FLUSH_ALL_ASID:
-- return true;
-- default:
-- return false;
-- }
--}
--
- static bool __nested_vmcb_check_controls(struct kvm_vcpu *vcpu,
- struct vmcb_ctrl_area_cached *control)
- {
-@@ -278,9 +266,6 @@ static bool __nested_vmcb_check_controls(struct kvm_vcpu *vcpu,
- IOPM_SIZE)))
- return false;
-
-- if (CC(!nested_svm_check_tlb_ctl(vcpu, control->tlb_ctl)))
-- return false;
--
- if (CC((control->int_ctl & V_NMI_ENABLE_MASK) &&
- !vmcb12_is_intercept(control, INTERCEPT_NMI))) {
- return false;
-diff --git a/arch/x86/kvm/svm/svm.c b/arch/x86/kvm/svm/svm.c
-index 1785de7dc98b..9cf7eef161ff 100644
---- a/arch/x86/kvm/svm/svm.c
-+++ b/arch/x86/kvm/svm/svm.c
-@@ -5083,6 +5083,7 @@ static __init void svm_set_cpu_caps(void)
- if (nested) {
- kvm_cpu_cap_set(X86_FEATURE_SVM);
- kvm_cpu_cap_set(X86_FEATURE_VMCBCLEAN);
-+ kvm_cpu_cap_set(X86_FEATURE_FLUSHBYASID);
-
- if (nrips)
- kvm_cpu_cap_set(X86_FEATURE_NRIPS);