summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoregnappahz2020-04-02 09:21:07 +0200
committeregnappahz2020-04-02 09:21:07 +0200
commitdf1894a8916308bc39d6dcd46e6c4d51afff30c1 (patch)
treef40323f3a904e7e993e47cd9b75fbca3efd5f955
parentb6cbc1981f361e2c2f052476c2bd736138a318ca (diff)
downloadaur-df1894a8916308bc39d6dcd46e6c4d51afff30c1.tar.gz
intelwifi patch finally made it to mainline
Signed-off-by: egnappahz <egnappah@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--intelwifi.patch15
3 files changed, 5 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a2a5d2d3240..2c74bbcf9d40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-amd
- pkgver = 5.6.v.1
+ pkgver = 5.6.v.2
pkgrel = 1
url = https://www.kernel.org/
arch = x86_64
@@ -17,13 +17,11 @@ pkgbase = linux-amd
source = linux-amd.preset
source = 5012_enable-cpu-optimizations-for-gcc91.patch
source = asusbat.patch
- source = intelwifi.patch
sha256sums = SKIP
- sha256sums = c3ccd0fa4269b533eb23eaada31b509e55bb21c14d4e1869621e3d3c21301f4d
+ sha256sums = 52234d25537985775a526263e8efe7031d2bff1a3a6a36c636c8d4738a5a928b
sha256sums = 71caf34adf69e9e2567a38cfc951d1c60b13dbe87f58a9acfeb3fe48ffdc9d08
sha256sums = cc739c9c9f7ce08e6bbc161b8232208bbc00820342a32fb1f69bff6326ae1370
sha256sums = c0a1604da4e0ae360f0c93a9adf244f9a8cffb5d219c94c0a58e23fb2c007a68
- sha256sums = da0be7c26de891847c0394e670d09ebd8f02c159342d21d8b0f0ec306e4e5599
pkgname = linux-amd
pkgdesc = Linux kernel for AMD CPU based hardware
diff --git a/PKGBUILD b/PKGBUILD
index 3781606f21bb..414f50cd4337 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgbase=linux-amd
_srcname=linux
-gitver=v5.6.1
-pkgver=5.6.v.1
+gitver=v5.6.2
+pkgver=5.6.v.2
pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
@@ -23,20 +23,16 @@ source=('git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git'
5012_enable-cpu-optimizations-for-gcc91.patch
# asus WMI patch
asusbat.patch
- # intel WIFI patch
- intelwifi.patch
)
sha256sums=('SKIP'
#config.x86_64
- 'c3ccd0fa4269b533eb23eaada31b509e55bb21c14d4e1869621e3d3c21301f4d'
+ '52234d25537985775a526263e8efe7031d2bff1a3a6a36c636c8d4738a5a928b'
#.preset file
'71caf34adf69e9e2567a38cfc951d1c60b13dbe87f58a9acfeb3fe48ffdc9d08'
#patch gentoo
'cc739c9c9f7ce08e6bbc161b8232208bbc00820342a32fb1f69bff6326ae1370'
#Asusbat gitfile
'c0a1604da4e0ae360f0c93a9adf244f9a8cffb5d219c94c0a58e23fb2c007a68'
- #IntelWifi gitfile
- 'da0be7c26de891847c0394e670d09ebd8f02c159342d21d8b0f0ec306e4e5599'
)
_kernelname=${pkgbase#linux}
@@ -65,8 +61,6 @@ prepare() {
yes "" | make prepare
# Implement suggested asus_wmi change
git apply ../asusbat.patch
- # Implement supposed intelwifi patch
- git apply ../intelwifi.patch
# load configuration
# Configure the kernel. Replace the line below with one of your choice.
diff --git a/intelwifi.patch b/intelwifi.patch
deleted file mode 100644
index 6bfd82258819..000000000000
--- a/intelwifi.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-1 files changed, 2 insertions, 1 deletions
-diff --git a/net/mac80211/tx.c b/net/mac80211/tx.c
-index d9cca6dbd870..efe4c1fc68e5 100644
---- a/net/mac80211/tx.c
-+++ b/net/mac80211/tx.c
-@@ -3610,7 +3610,8 @@ begin:
- * Drop unicast frames to unauthorised stations unless they are
- * EAPOL frames from the local station.
- */
-- if (unlikely(!ieee80211_vif_is_mesh(&tx.sdata->vif) &&
-+ if (unlikely(ieee80211_is_data(hdr->frame_control) &&
-+ !ieee80211_vif_is_mesh(&tx.sdata->vif) &&
- tx.sdata->vif.type != NL80211_IFTYPE_OCB &&
- !is_multicast_ether_addr(hdr->addr1) &&
- !test_sta_flag(tx.sta, WLAN_STA_AUTHORIZED) &&