summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoregnappahz2022-05-12 13:42:42 +0200
committeregnappahz2022-05-12 13:42:42 +0200
commit4295cb39ee50d45ae953d8e1df398add8118e037 (patch)
tree2b7ae306d9f8773afbeca22afa57893460a70ad0
parent75e80ddad9ebfd5fda3e1da72596d9e838e6c2d5 (diff)
downloadaur-4295cb39ee50d45ae953d8e1df398add8118e037.tar.gz
Updated
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--config.x86_6417
3 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52a1d89c79e9..e028c1302723 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-amd-znver2
- pkgver = 5.17.v.6
+ pkgver = 5.17.v.7
pkgrel = 1
url = https://www.kernel.org/
arch = x86_64
@@ -14,13 +14,13 @@ pkgbase = linux-amd-znver2
makedepends = lzop
makedepends = gcc>=9.1
options = !strip
- source = git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#tag=v5.17.6
+ source = git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#tag=v5.17.7
source = config.x86_64
source = linux-amd-znver2.preset
source = linux.install
source = https://raw.githubusercontent.com/graysky2/kernel_compiler_patch/20220315/more-uarches-for-kernel-5.17+.patch
sha256sums = SKIP
- sha256sums = c03fcdd07c5d36d19ce169fc080798bd94d0d0b9e163f730aab0c3a4b65affb8
+ sha256sums = 1c4696ff421df4289d0171c94163076440412a9d2a1f599fa635e25316a24393
sha256sums = 60c6ba602443e94a9eba3aeee9d194027d69bffaa428c6d055348ebf03681b5c
sha256sums = d590e751ab4cf424b78fd0d57e53d187f07401a68c8b468d17a5f39a337dacf0
sha256sums = dea86a521603414a8c7bf9cf1f41090d5d6f8035ce31407449e25964befb1e50
diff --git a/PKGBUILD b/PKGBUILD
index 96e8e9d72f7d..4015c256c3c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
pkgbase=linux-amd-znver2
_srcname=linux
-gitver=v5.17.6
+gitver=v5.17.7
patchver=20220315
patchname=more-uarches-for-kernel-5.17+.patch
-pkgver=5.17.v.6
+pkgver=5.17.v.7
pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
@@ -25,7 +25,7 @@ source=("git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#ta
)
sha256sums=('SKIP'
#config.x86_64
- 'c03fcdd07c5d36d19ce169fc080798bd94d0d0b9e163f730aab0c3a4b65affb8'
+ '1c4696ff421df4289d0171c94163076440412a9d2a1f599fa635e25316a24393'
#.preset file
'60c6ba602443e94a9eba3aeee9d194027d69bffaa428c6d055348ebf03681b5c'
#linux install file
@@ -209,7 +209,7 @@ _package-headers() {
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/tools"
cp -a tools/objtool "${pkgdir}/usr/lib/modules/${_kernver}/build/tools"
- chown -R root.root "${pkgdir}/usr/lib/modules/${_kernver}/build"
+ chown -R root:root "${pkgdir}/usr/lib/modules/${_kernver}/build"
find "${pkgdir}/usr/lib/modules/${_kernver}/build" -type d -exec chmod 755 {} \;
# strip scripts directory
diff --git a/config.x86_64 b/config.x86_64
index 23ee6d8ac526..31501aeff2f5 100644
--- a/config.x86_64
+++ b/config.x86_64
@@ -1,10 +1,10 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.17.6 Kernel Configuration
+# Linux/x86 5.17.7 Kernel Configuration
#
-CONFIG_CC_VERSION_TEXT="gcc (GCC) 11.2.0"
+CONFIG_CC_VERSION_TEXT="gcc (GCC) 12.1.0"
CONFIG_CC_IS_GCC=y
-CONFIG_GCC_VERSION=110200
+CONFIG_GCC_VERSION=120100
CONFIG_CLANG_VERSION=0
CONFIG_AS_IS_GNU=y
CONFIG_AS_VERSION=23800
@@ -342,6 +342,8 @@ CONFIG_X86_X2APIC=y
CONFIG_X86_MPPARSE=y
# CONFIG_GOLDFISH is not set
CONFIG_RETPOLINE=y
+CONFIG_CC_HAS_SLS=y
+# CONFIG_SLS is not set
# CONFIG_X86_CPU_RESCTRL is not set
# CONFIG_X86_EXTENDED_PLATFORM is not set
# CONFIG_X86_INTEL_LPSS is not set
@@ -8912,16 +8914,15 @@ CONFIG_LSM="yama,loadpin,safesetid,integrity"
#
# Kernel hardening options
#
-CONFIG_GCC_PLUGIN_STRUCTLEAK=y
#
# Memory initialization
#
+CONFIG_CC_HAS_AUTO_VAR_INIT_PATTERN=y
+CONFIG_CC_HAS_AUTO_VAR_INIT_ZERO=y
# CONFIG_INIT_STACK_NONE is not set
-# CONFIG_GCC_PLUGIN_STRUCTLEAK_USER is not set
-# CONFIG_GCC_PLUGIN_STRUCTLEAK_BYREF is not set
-CONFIG_GCC_PLUGIN_STRUCTLEAK_BYREF_ALL=y
-# CONFIG_GCC_PLUGIN_STRUCTLEAK_VERBOSE is not set
+# CONFIG_INIT_STACK_ALL_PATTERN is not set
+CONFIG_INIT_STACK_ALL_ZERO=y
CONFIG_GCC_PLUGIN_STACKLEAK=y
CONFIG_STACKLEAK_TRACK_MIN_SIZE=100
# CONFIG_STACKLEAK_METRICS is not set