summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEggz2024-01-03 09:51:14 +0100
committerEggz2024-01-03 09:51:14 +0100
commit54f55a5a48d9a2812b38710ecaffcf827688b2b2 (patch)
treea5b8fdb701b2862ffc5c6ae1cc562a57d95c91e0
parent4dfe9810f149b2f511910492b3ae263131e1b4bc (diff)
downloadaur-54f55a5a48d9a2812b38710ecaffcf827688b2b2.tar.gz
Updated
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD20
2 files changed, 3 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b91911bfd7d0..7846ff404492 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-amd-znver2
pkgver = 6.6.v.9
- pkgrel = 1
+ pkgrel = 2
url = https://www.kernel.org/
arch = x86_64
license = GPL2
@@ -36,6 +36,3 @@ pkgname = linux-amd-znver2
pkgname = linux-amd-znver2-headers
pkgdesc = Header files and scripts for building modules for the linux-amd-znver2 kernel
-
-pkgname = linux-amd-znver2-docs
- pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux kernel
diff --git a/PKGBUILD b/PKGBUILD
index b3b5f1cb30c1..838520b15a9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ gitver=v6.6.9
patchver=20230105
patchname=more-uarches-for-kernel-5.17+.patch
pkgver=6.6.v.9
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://www.kernel.org/"
license=('GPL2')
@@ -95,7 +95,6 @@ _package() {
mkdir -p "${pkgdir}"/{lib/modules,lib/firmware,boot}
make LOCALVERSION= INSTALL_MOD_PATH="${pkgdir}" modules_install
- cp arch/$KARCH/boot/bzImage "${pkgdir}/boot/vmlinuz-${pkgbase}"
# install mkinitcpio preset file for kernel
install -D -m644 "${srcdir}/${pkgbase}.preset" "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
@@ -209,22 +208,7 @@ _package-headers() {
}
-_package-docs() {
- pkgdesc="Kernel hackers manual - HTML documentation that comes with the Linux kernel"
-
- cd "${_srcname}"
-
- mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build"
- cp -al Documentation "${pkgdir}/usr/lib/modules/${_kernver}/build"
- find "${pkgdir}" -type f -exec chmod 444 {} \;
- find "${pkgdir}" -type d -exec chmod 755 {} \;
-
- # remove a file already in linux package
- rm -f "${pkgdir}/usr/lib/modules/${_kernver}/build/Documentation/DocBook/Makefile"
-
-}
-
-pkgname=("${pkgbase}" "${pkgbase}-headers" "${pkgbase}-docs")
+pkgname=("${pkgbase}" "${pkgbase}-headers")
for _p in ${pkgname[@]}; do
eval "package_${_p}() {
$(declare -f "_package${_p#${pkgbase}}")