summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle De'Vir2021-07-01 20:22:56 +1000
committerKyle De'Vir2021-07-01 20:22:56 +1000
commit0a6b6458214e8e7d9b89ed4dcfa89ab4cf8198e5 (patch)
tree344f0674e4dc7888aab5f44087b374b85221a89c
parent5213322005499f8ee598ec13d611e2093e0a8dd1 (diff)
downloadaur-0a6b6458214e8e7d9b89ed4dcfa89ab4cf8198e5.tar.gz
Update URLs
-rwxr-xr-x.SRCINFO7
-rwxr-xr-xPKGBUILD33
2 files changed, 27 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc7a1cc454b7..fcd5f19397e2 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -20,11 +20,14 @@ pkgbase = linux-bcachefs-git
makedepends = imagemagick
makedepends = git
options = !strip
- source = linux-bcachefs::git+https://github.com/koverstreet/bcachefs#branch=master
- source = git+https://github.com/graysky2/kernel_compiler_patch
+ source = linux-bcachefs::git+https://github.com/koverstreet/bcachefs.git#branch=master
+ source = linux-archlinux::git+https://github.com/archlinux/linux.git
+ source = git+https://github.com/graysky2/kernel_compiler_patch.git
source = config
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
+ validpgpkeys = A2FF3A36AAA56654109064AB19802F8B0D70FC30
+ sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = 10deb2ce58d84b408c112d2c46f2ddb41e1d79e65fe2efbd5d1727b026bb4a3ae1cb7dd6c1361dc79cf308006383a1fc706dba59d5b277e87468a391c039eb55
diff --git a/PKGBUILD b/PKGBUILD
index 882f8fc1f6de..e88ecb34a05a 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -85,26 +85,37 @@ makedepends=(
)
options=('!strip')
-_reponame="linux-bcachefs"
-_repo_url="https://github.com/koverstreet/bcachefs"
+_reponame_bcachefs="linux-bcachefs"
+_repo_url_bcachefs="https://github.com/koverstreet/bcachefs.git"
+
+_reponame_arch="linux-archlinux"
+_repo_url_arch="https://github.com/archlinux/linux.git"
+
+_reponame_upstream="linux"
+_repo_url_upstream="https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git"
_reponame_kernel_patch="kernel_compiler_patch"
-_repo_url_kernel_patch="https://github.com/graysky2/${_reponame_kernel_patch}"
+_repo_url_kernel_patch="https://github.com/graysky2/${_reponame_kernel_patch}.git"
_kernel_patch_name="more-uarches-for-kernel-5.8+.patch"
_pkgdesc_extra="~ featuring Kent Overstreet's bcachefs filesystem"
source=(
- "${_reponame}::git+${_repo_url}#branch=master"
+ "${_reponame_bcachefs}::git+${_repo_url_bcachefs}#branch=master"
+ "${_reponame_arch}::git+${_repo_url_arch}"
+ #arch_patches.patch
+ #"${_reponame_upstream}::git+${_repo_url_upstream}"
"git+${_repo_url_kernel_patch}"
config # kernel config file
)
validpgpkeys=(
"ABAF11C65A2970B130ABE3C479BE3E4300411886" # Linus Torvalds
"647F28654894E3BD457199BE38DBBDC86092693E" # Greg Kroah-Hartman
+ "A2FF3A36AAA56654109064AB19802F8B0D70FC30" # Jan Alexander Steffens ~ heftig
)
sha512sums=('SKIP'
'SKIP'
+ 'SKIP'
'10deb2ce58d84b408c112d2c46f2ddb41e1d79e65fe2efbd5d1727b026bb4a3ae1cb7dd6c1361dc79cf308006383a1fc706dba59d5b277e87468a391c039eb55')
export KBUILD_BUILD_HOST=archlinux
@@ -112,7 +123,7 @@ export KBUILD_BUILD_USER=$pkgbase
export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"
prepare() {
- cd "$srcdir/$_reponame"
+ cd "$srcdir/$_reponame_bcachefs"
msg2 "Setting version..."
scripts/setlocalversion --save-scmversion
@@ -120,12 +131,12 @@ prepare() {
echo "${pkgbase#linux}" > localversion.20-pkgname
msg2 "Fetch and merge stable tag from Arch vanilla kernel repository..."
- git remote add arch_stable "https://github.com/archlinux/linux.git" || true
+ git remote add arch_stable "${srcdir}/${_reponame_arch}" || true
git fetch arch_stable "${_srcver_tag%.*}-${_srcver_tag##*.}"
git merge --no-edit --no-commit FETCH_HEAD
#msg2 "Fetch and merge tag ${_srcver_tag//.arch*/} from Linux stable upstream repository..."
- #git remote add upstream_stable "https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git" || true
+ #git remote add upstream_stable "${srcdir}/${_reponame_upstream}" || true
#git fetch upstream_stable ${_srcver_tag//.arch*/}
#git merge --no-edit --no-commit FETCH_HEAD
@@ -173,12 +184,12 @@ prepare() {
}
pkgver() {
- cd "$srcdir/$_reponame"
+ cd "$srcdir/$_reponame_bcachefs"
printf "%s.r%s.%s" "${_srcver_tag//-/.}" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd $_reponame
+ cd $_reponame_bcachefs
make all
make htmldocs
}
@@ -204,7 +215,7 @@ _package() {
wireguard-arch
)
- cd $_reponame
+ cd $_reponame_bcachefs
local kernver="$(<version)"
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
@@ -227,7 +238,7 @@ _package-headers() {
pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel $_pkgdesc_extra"
depends=(pahole)
- cd $_reponame
+ cd $_reponame_bcachefs
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
msg2 "Installing build files..."