summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle De'Vir2019-05-24 12:51:20 +1000
committerKyle De'Vir2019-05-24 12:51:20 +1000
commit60c05e5756a62468060ece1ae73ec32634f82138 (patch)
tree240e8b03ab8124c451e6a438d15fa4d145b6c330
parent2dd548824309d78c072317ea042469827ff41445 (diff)
downloadaur-60c05e5756a62468060ece1ae73ec32634f82138.tar.gz
5.0.18
-rwxr-xr-x.SRCINFO10
-rwxr-xr-xPKGBUILD14
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf1067734758..c5c50a3e3f1a 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-bcachefs-git
- pkgver = 5.0.17.arch1
+ pkgver = 5.0.18.arch1
pkgrel = 1
url = https://github.com/koverstreet/bcachefs
arch = x86_64
@@ -39,11 +39,11 @@ pkgname = linux-bcachefs-git
pkgname = linux-bcachefs-git-headers
pkgdesc = Header files and scripts for building modules for Linux-bcachefs-git kernel ~ featuring Kent Overstreet's bcachefs filesystem
- provides = linux-bcachefs-git-headers=5.0.17.arch1
- provides = linux-headers=5.0.17.arch1
+ provides = linux-bcachefs-git-headers=5.0.18.arch1
+ provides = linux-headers=5.0.18.arch1
pkgname = linux-bcachefs-git-docs
pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux-bcachefs-git kernel ~ featuring Kent Overstreet's bcachefs filesystem
- provides = linux-bcachefs-git-docs=5.0.17.arch1
- provides = linux-docs=5.0.17.arch1
+ provides = linux-bcachefs-git-docs=5.0.18.arch1
+ provides = linux-docs=5.0.18.arch1
diff --git a/PKGBUILD b/PKGBUILD
index 6aae2295e656..b0ba10ca875c 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -59,7 +59,7 @@ _subarch=
_localmodcfg=
pkgbase=linux-bcachefs-git
-_srcver_tag=5.0.17
+_srcver_tag=5.0.18
pkgver="${_srcver_tag}.arch1"
pkgrel=1
arch=(x86_64)
@@ -109,6 +109,11 @@ _kernelname=${pkgbase#linux}
prepare() {
cd ${_reponame}
+ msg2 "Setting version..."
+ scripts/setlocalversion --save-scmversion
+ echo "-$pkgrel" > localversion.10-pkgrel
+ echo "$_kernelname" > localversion.20-pkgname
+
msg2 "Adding patches from Linux upstream kernel repository..."
git remote add upstream_stable https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git || true
git pull --no-edit upstream_stable v${_srcver_tag}
@@ -123,12 +128,7 @@ prepare() {
# https://github.com/graysky2/kernel_gcc_patch
msg2 "Patching to enabled additional gcc CPU optimizatons..."
patch -Np1 -i "$srcdir/${_reponame_gcc_patch}/${_gcc_patch_name}"
-
- msg2 "Setting version..."
- scripts/setlocalversion --save-scmversion
- echo "-$pkgrel" > localversion.10-pkgrel
- echo "$_kernelname" > localversion.20-pkgname
-
+
msg2 "Setting config..."
cp ../config .config