summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle De'Vir2020-08-24 00:07:26 +1000
committerKyle De'Vir2020-08-24 00:07:26 +1000
commit6858c4f14289f5bb73f9be473d5e008e8804956e (patch)
treeace5e27b8eb4c2371db0527d733b9cea1dfe245c
parentf8d3379d516387d81608a28a481a46e27d772672 (diff)
downloadaur-6858c4f14289f5bb73f9be473d5e008e8804956e.tar.gz
5.7.17.arch1
-rwxr-xr-x.SRCINFO2
-rwxr-xr-xPKGBUILD23
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17c549fe1d64..4af9b77605b6 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -20,12 +20,14 @@ pkgbase = linux-bcachefs-git
source = git+https://github.com/graysky2/kernel_gcc_patch
source = config
source = sphinx-workaround.patch
+ source = b4e7e8c02782234ce9409719dd781e9b320970ec.patch::https://git.archlinux.org/linux.git/patch/?id=b4e7e8c02782234ce9409719dd781e9b320970ec
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha512sums = SKIP
sha512sums = SKIP
sha512sums = 70a57001d1485eee3feadef435bc4df02b82ff68917f983249c63eaa1e6d6562cac1c9682c4d7d3c73720ac66bf60d97282449448625898e557893435063b421
sha512sums = 98e97155f86bbe837d43f27ec1018b5b6fdc6c372d6f7f2a0fe29da117d53979d9f9c262f886850d92002898682781029b80d4ee923633fc068f979e6c8254be
+ sha512sums = 92618543dc4505ff9b8c1cf86b1b1583f009a2324492dfa7cc0969da1c1144539a73a5bc7f492f87d9343e592a01683b3a1f56b0c558ae74a307180ff2eca7da
pkgname = linux-bcachefs-git
pkgdesc = The Linux kernel and modules ~ featuring Kent Overstreet's bcachefs filesystem
diff --git a/PKGBUILD b/PKGBUILD
index 246122331fe2..86edfd43efb1 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -62,7 +62,7 @@ pkgbase=linux-bcachefs-git
pkgver=v5.7.9.arch1.r918141.2c71b506e567
pkgrel=1
pkgdesc="Linux"
-_srcver_tag=v5.7.12.arch1
+_srcver_tag=v5.7.17.arch1
url="https://github.com/koverstreet/bcachefs"
arch=(x86_64)
license=(GPL2)
@@ -94,6 +94,7 @@ source=(
"git+$_repo_url_gcc_patch"
config # the main kernel config file
sphinx-workaround.patch
+ b4e7e8c02782234ce9409719dd781e9b320970ec.patch::https://git.archlinux.org/linux.git/patch/?id=b4e7e8c02782234ce9409719dd781e9b320970ec
)
validpgpkeys=(
"ABAF11C65A2970B130ABE3C479BE3E4300411886" # Linus Torvalds
@@ -102,7 +103,8 @@ validpgpkeys=(
sha512sums=('SKIP'
'SKIP'
'70a57001d1485eee3feadef435bc4df02b82ff68917f983249c63eaa1e6d6562cac1c9682c4d7d3c73720ac66bf60d97282449448625898e557893435063b421'
- '98e97155f86bbe837d43f27ec1018b5b6fdc6c372d6f7f2a0fe29da117d53979d9f9c262f886850d92002898682781029b80d4ee923633fc068f979e6c8254be')
+ '98e97155f86bbe837d43f27ec1018b5b6fdc6c372d6f7f2a0fe29da117d53979d9f9c262f886850d92002898682781029b80d4ee923633fc068f979e6c8254be'
+ '92618543dc4505ff9b8c1cf86b1b1583f009a2324492dfa7cc0969da1c1144539a73a5bc7f492f87d9343e592a01683b3a1f56b0c558ae74a307180ff2eca7da')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
@@ -116,15 +118,18 @@ prepare() {
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
- msg2 "Fetch and merge stable tag from Arch vanilla kernel repository..."
- git remote add arch_stable "https://git.archlinux.org/linux.git" || true
- git fetch arch_stable "${_srcver_tag%.*}-${_srcver_tag##*.}"
- git merge --no-edit --no-commit FETCH_HEAD
+ #msg2 "Fetch and merge stable tag from Arch vanilla kernel repository..."
+ #git remote add arch_stable "https://git.archlinux.org/linux.git" || true
+ #git fetch arch_stable "${_srcver_tag%.*}-${_srcver_tag##*.}"
+ #git merge --no-edit --no-commit FETCH_HEAD
# msg2 "Fetch and merge tag ${_srcver_tag//.arch*/} from Linux stable upstream repository..."
- # git remote add upstream_stable "https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git" || true
- # git fetch upstream_stable ${_srcver_tag//.arch*/}
- # git merge --no-edit --no-commit FETCH_HEAD
+ git remote add upstream_stable "https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git" || true
+ git fetch upstream_stable ${_srcver_tag//.arch*/}
+ git merge --no-edit --no-commit FETCH_HEAD
+
+ msg2 "Patching with ZEN: Add sysctl and CONFIG to disallow unprivileged CLONE_NEWUSER..."
+ patch -Np1 -i "$srcdir/b4e7e8c02782234ce9409719dd781e9b320970ec.patch"
# https://github.com/graysky2/kernel_gcc_patch
msg2 "Patching with Graysky's additional gcc CPU optimizatons..."