summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle De'Vir2019-05-11 06:07:27 +1000
committerKyle De'Vir2019-05-11 06:07:27 +1000
commit86932d216a5ba5d31136a48fa0fa85f1648c8358 (patch)
tree5a299f993b39181b98e7d67ab6b2d2e1f61b5e1a
parentc41c7f5b713f18c20f315a90d6be56e8516f0798 (diff)
downloadaur-86932d216a5ba5d31136a48fa0fa85f1648c8358.tar.gz
5.0.15
-rwxr-xr-x.SRCINFO10
-rwxr-xr-xPKGBUILD15
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 912407e6a466..8cceaca7dcb0 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-bcachefs-git
- pkgver = 5.0.13.arch1
+ pkgver = 5.0.15.arch1
pkgrel = 1
url = https://github.com/koverstreet/bcachefs
arch = x86_64
@@ -39,11 +39,11 @@ pkgname = linux-bcachefs-git
pkgname = linux-bcachefs-git-headers
pkgdesc = Header files and scripts for building modules for Linux-bcachefs-git kernel
- provides = linux-bcachefs-git-headers=5.0.13.arch1
- provides = linux-headers=5.0.13.arch1
+ provides = linux-bcachefs-git-headers=5.0.15.arch1
+ provides = linux-headers=5.0.15.arch1
pkgname = linux-bcachefs-git-docs
pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux-bcachefs-git kernel
- provides = linux-bcachefs-git-docs=5.0.13.arch1
- provides = linux-docs=5.0.13.arch1
+ provides = linux-bcachefs-git-docs=5.0.15.arch1
+ provides = linux-docs=5.0.15.arch1
diff --git a/PKGBUILD b/PKGBUILD
index c5973bad1e78..d3cfcf763f75 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# Set these variables to ANYTHING that is not null to enable them
# Tweak kernel options prior to a build via nconfig
-_makenconfig=y
+_makenconfig=
# Optionally select a sub architecture by number if building in a clean chroot
# Leaving this entry blank will require user interaction during the build
@@ -59,8 +59,8 @@ _subarch=
_localmodcfg=
pkgbase=linux-bcachefs-git
-_srcver_tag_arch=5.0.13-arch1
-pkgver=${_srcver_tag_arch//-/.}
+_srcver_tag=5.0.15
+pkgver="${_srcver_tag}.arch1"
pkgrel=1
arch=(x86_64)
url="https://github.com/koverstreet/bcachefs"
@@ -105,9 +105,16 @@ _kernelname=${pkgbase#linux}
prepare() {
cd ${_reponame}
+ msg2 "Adding patches from Linux upstream kernel repository..."
+ git remote add upstream_stable https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git
+ git pull --no-edit upstream_stable v${_srcver_tag}
+
msg2 "Adding patches from Arch Linux kernel repository..."
git remote add arch_stable https://git.archlinux.org/linux.git
- git pull --no-edit arch_stable v${_srcver_tag_arch}
+ # git pull --no-edit arch_stable "v${_srcver_tag}-arch1"
+ git fetch arch_stable "v5.0.13-arch1"
+ git cherry-pick 1ce49fc24c97401dda96f916e0aec1be26e480a8
+ sed -i -e "s/^EXTRAVERSION =.*/EXTRAVERSION = -arch1/" Makefile
# https://github.com/graysky2/kernel_gcc_patch
msg2 "Patching to enabled additional gcc CPU optimizatons..."