summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle De'Vir2018-11-24 09:15:25 +1000
committerKyle De'Vir2018-11-24 09:15:25 +1000
commitade9e38b964432f9bc76ce2e2b287d18d9d108e4 (patch)
treee60406a82ee6f6cbe88358a5f49b9a7d9407d52a
parent5744b37f90ee12f354240f10a5094681cde83144 (diff)
downloadaur-ade9e38b964432f9bc76ce2e2b287d18d9d108e4.tar.gz
4.19.4
-rwxr-xr-x.SRCINFO2
-rwxr-xr-xPKGBUILD9
-rw-r--r--config5
3 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56fffe8a04c3..7f61b7f814f8 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-bcachefs-git
- pkgver = 4.19.2.arch1
+ pkgver = 4.19.4.arch1
pkgrel = 1
url = https://evilpiepirate.org/git/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 885afa822b32..a16ba5f3a314 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
_makenconfig=
pkgbase=linux-bcachefs-git
-_srcver=4.19.2-arch1
+_srcver=4.19.4-arch1
pkgver=${_srcver//-/.}
pkgrel=1
arch=(x86_64)
@@ -98,13 +98,18 @@ _package() {
cd $_srcname
msg2 "Installing boot image..."
- install -Dm644 "$(make -s image_name)" "$pkgdir/boot/vmlinuz-$pkgbase"
+ local image="$pkgdir/boot/vmlinuz-$pkgbase"
+ install -Dm644 "$(make -s image_name)" "$image"
msg2 "Installing modules..."
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ ln -sr "$image" "$modulesdir/vmlinuz"
+
# a place for external modules,
# with version file for building modules and running depmod from hook
local extramodules="extramodules$_kernelname"
diff --git a/config b/config
index 369cd16040ce..ae8eb610f408 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.19.2-arch1 Kernel Configuration
+# Linux/x86 4.19.3-arch1 Kernel Configuration
#
#
@@ -1603,6 +1603,7 @@ CONFIG_L2TP_V3=y
CONFIG_L2TP_IP=m
CONFIG_L2TP_ETH=m
CONFIG_STP=m
+CONFIG_GARP=m
CONFIG_MRP=m
CONFIG_BRIDGE=m
CONFIG_BRIDGE_IGMP_SNOOPING=y
@@ -1619,7 +1620,7 @@ CONFIG_NET_DSA_TAG_LAN9303=y
CONFIG_NET_DSA_TAG_MTK=y
CONFIG_NET_DSA_TAG_QCA=y
CONFIG_VLAN_8021Q=m
-# CONFIG_VLAN_8021Q_GVRP is not set
+CONFIG_VLAN_8021Q_GVRP=y
CONFIG_VLAN_8021Q_MVRP=y
# CONFIG_DECNET is not set
CONFIG_LLC=m