summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2022-07-21 10:48:48 +0200
committerPiotr Gorski2022-07-21 10:48:48 +0200
commite227976d6df3a3bb259a0fd5ee97defcba693224 (patch)
tree819f8c2aa1bb010d36c97fecba5b9b05ec6b2fe6
parent01dd31fdca6fc8b5c8971f9995e5cf001d76cd7d (diff)
downloadaur-e227976d6df3a3bb259a0fd5ee97defcba693224.tar.gz
Cleaning, smoothing and adding some comments again
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rwxr-xr-x.SRCINFO5
-rw-r--r--PKGBUILD25
2 files changed, 24 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60cde78bd905..0ade2bdad505 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = linux-cacule-rdb
pkgdesc = Linux cacULE-RDB scheduler Kernel by CachyOS with other patches and improvements
pkgver = 5.18.12
- pkgrel = 2
+ pkgrel = 4
url = https://github.com/CachyOS/linux-cachyos
arch = x86_64
arch = x86_64_v3
license = GPL2
makedepends = bc
- makedepends = texlive-latexextra
makedepends = libelf
makedepends = pahole
makedepends = cpio
@@ -15,8 +14,6 @@ pkgbase = linux-cacule-rdb
makedepends = tar
makedepends = xz
makedepends = zstd
- makedepends = xmlto
- makedepends = git
makedepends = gcc
makedepends = gcc-libs
makedepends = glibc
diff --git a/PKGBUILD b/PKGBUILD
index a37e6295b7a0..c36e77ecb1ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -103,6 +103,7 @@ _disable_debug=y
## Enable zram/zswap ZSTD compression
_zstd_compression=y
+# Enable FULLCONENAT
_nf_cone=y
# Clang LTO mode, only available with the "llvm" compiler - options are "no", "full" or "thin".
@@ -116,6 +117,12 @@ _build_zfs=
# Enable bcachefs
_bcachefs=
+# Enable aufsfs
+_aufs=
+
+# Enable spadefs
+_spadfs=
+
if [ -n "$_use_llvm_lto" ]; then
pkgsuffix=${_cpusched}-lto
pkgbase=linux-$pkgsuffix
@@ -135,13 +142,14 @@ _stable=${_major}.${_minor}
_srcname=linux-${_stable}
#_srcname=linux-${_major}
pkgdesc='Linux cacULE-RDB scheduler Kernel by CachyOS with other patches and improvements'
-pkgrel=2
+pkgrel=4
_kernver=$pkgver-$pkgrel
arch=('x86_64' 'x86_64_v3')
url="https://github.com/CachyOS/linux-cachyos"
license=('GPL2')
options=('!strip')
-makedepends=('bc' 'texlive-latexextra' 'libelf' 'pahole' 'cpio' 'perl' 'tar' 'xz' 'zstd' 'xmlto' 'git' 'gcc' 'gcc-libs' 'glibc' 'binutils' 'make' 'patch')
+makedepends=('bc' 'libelf' 'pahole' 'cpio' 'perl' 'tar' 'xz' 'zstd' 'gcc' 'gcc-libs' 'glibc' 'binutils' 'make' 'patch')
+# LLVM makedepends
if [ -n "$_use_llvm_lto" ]; then
makedepends+=(clang llvm lld python)
BUILD_FLAGS=(
@@ -151,6 +159,11 @@ if [ -n "$_use_llvm_lto" ]; then
LLVM_IAS=1
)
fi
+# ZFS makedepends
+if [ -n "$_build_zfs" ]; then
+ makedepends+=(git)
+
+fi
_patchsource="https://raw.githubusercontent.com/ptr1337/kernel-patches/master/${_major}"
source=(
"https://cdn.kernel.org/pub/linux/kernel/v${pkgver%%.*}.x/${_srcname}.tar.xz"
@@ -189,6 +202,14 @@ if [ -n "$_bcachefs" ]; then
source+=("${_patchsource}/0001-bcachefs-after-lru.patch")
fi
+if [ -n "$_aufs" ]; then
+source+=("${_patchsource}/0001-aufs-20220620.patch")
+fi
+
+if [ -n "$_spadfs" ]; then
+source+=("${_patchsource}/0001-spadfs-5.18-merge-v1.0.16.patch")
+fi
+
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"