summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2022-10-22 05:31:00 -0400
committergraysky2022-10-22 05:31:00 -0400
commit27d3a68884c8e80f3e0e6d4c07b432c36a088fe6 (patch)
treea8cafc7ea3150eb92b0477ab51d3a8991a631057
parent5f848c9ac0786332850ce4876883284945f47bb3 (diff)
downloadaur-27d3a68884c8e80f3e0e6d4c07b432c36a088fe6.tar.gz
Update to 6.0.3-2
-rw-r--r--.SRCINFO4
-rw-r--r--0009-Revert-ALSA-hda-Fix-page-fault-in-snd_hda_codec_shut.patch82
-rw-r--r--PKGBUILD6
3 files changed, 89 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32efe4226742..7ae69b02ef35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-ck
pkgver = 6.0.3
- pkgrel = 1
+ pkgrel = 2
url = https://wiki.archlinux.org/index.php/Linux-ck
arch = x86_64
license = GPL2
@@ -24,6 +24,7 @@ pkgbase = linux-ck
source = 0006-drm-amdgpu-use-DRM_SCHED_FENCE_DONT_PIPELINE-for-VM-.patch
source = 0007-drm-amdgpu-Fix-VRAM-BO-swap-issue.patch
source = 0008-drm-amdgpu-Fix-for-BO-move-issue.patch
+ source = 0009-Revert-ALSA-hda-Fix-page-fault-in-snd_hda_codec_shut.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = b0d522241805794d8af3a67d331ba063a16496c6fb6d365d48f7ed78ee1c3dcf
@@ -39,6 +40,7 @@ pkgbase = linux-ck
sha256sums = 0fa8801cbab408513d740b41e325498dd5468b5055e6e456daa727178d678b97
sha256sums = 530a4b74bc6df917c401a0a0b0c1658a8e9ee361b22b6cd56e1305858c190fb5
sha256sums = 322267bec409b46de82f1ed2b8e37cd5cd26bcd5e935f7f4581d21a48a6894e7
+ sha256sums = 55947d864c380b47a0306b5701c8d1a988dbbbb12515e65159cd14a231b93de2
pkgname = linux-ck
pkgdesc = The Linux kernel and modules with ck's hrtimer patches
diff --git a/0009-Revert-ALSA-hda-Fix-page-fault-in-snd_hda_codec_shut.patch b/0009-Revert-ALSA-hda-Fix-page-fault-in-snd_hda_codec_shut.patch
new file mode 100644
index 000000000000..c1724689a3d1
--- /dev/null
+++ b/0009-Revert-ALSA-hda-Fix-page-fault-in-snd_hda_codec_shut.patch
@@ -0,0 +1,82 @@
+From 41d72c232237c5ea567cf789add1092114f21216 Mon Sep 17 00:00:00 2001
+From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
+Date: Sat, 22 Oct 2022 01:48:17 +0200
+Subject: [PATCH 09/10] Revert "ALSA: hda: Fix page fault in
+ snd_hda_codec_shutdown()"
+
+This reverts commit 7494e2e6c55ed192f2b91c821fd6832744ba8741.
+
+This patch depends on others from its series, which were not
+backported, causing probing to fail due to missing initialization.
+
+See: https://github.com/thesofproject/linux/issues/3764
+---
+ sound/pci/hda/hda_codec.c | 41 ++++++++++++++++++++-------------------
+ 1 file changed, 21 insertions(+), 20 deletions(-)
+
+diff --git a/sound/pci/hda/hda_codec.c b/sound/pci/hda/hda_codec.c
+index 4ae8b9574778..384426d7e9dd 100644
+--- a/sound/pci/hda/hda_codec.c
++++ b/sound/pci/hda/hda_codec.c
+@@ -931,28 +931,8 @@ snd_hda_codec_device_init(struct hda_bus *bus, unsigned int codec_addr,
+ }
+
+ codec->bus = bus;
+- codec->depop_delay = -1;
+- codec->fixup_id = HDA_FIXUP_ID_NOT_SET;
+- codec->core.dev.release = snd_hda_codec_dev_release;
+- codec->core.exec_verb = codec_exec_verb;
+ codec->core.type = HDA_DEV_LEGACY;
+
+- mutex_init(&codec->spdif_mutex);
+- mutex_init(&codec->control_mutex);
+- snd_array_init(&codec->mixers, sizeof(struct hda_nid_item), 32);
+- snd_array_init(&codec->nids, sizeof(struct hda_nid_item), 32);
+- snd_array_init(&codec->init_pins, sizeof(struct hda_pincfg), 16);
+- snd_array_init(&codec->driver_pins, sizeof(struct hda_pincfg), 16);
+- snd_array_init(&codec->cvt_setups, sizeof(struct hda_cvt_setup), 8);
+- snd_array_init(&codec->spdif_out, sizeof(struct hda_spdif_out), 16);
+- snd_array_init(&codec->jacktbl, sizeof(struct hda_jack_tbl), 16);
+- snd_array_init(&codec->verbs, sizeof(struct hda_verb *), 8);
+- INIT_LIST_HEAD(&codec->conn_list);
+- INIT_LIST_HEAD(&codec->pcm_list_head);
+- INIT_DELAYED_WORK(&codec->jackpoll_work, hda_jackpoll_work);
+- refcount_set(&codec->pcm_ref, 1);
+- init_waitqueue_head(&codec->remove_sleep);
+-
+ return codec;
+ }
+ EXPORT_SYMBOL_GPL(snd_hda_codec_device_init);
+@@ -1005,8 +985,29 @@ int snd_hda_codec_device_new(struct hda_bus *bus, struct snd_card *card,
+ if (snd_BUG_ON(codec_addr > HDA_MAX_CODEC_ADDRESS))
+ return -EINVAL;
+
++ codec->core.dev.release = snd_hda_codec_dev_release;
++ codec->core.exec_verb = codec_exec_verb;
++
+ codec->card = card;
+ codec->addr = codec_addr;
++ mutex_init(&codec->spdif_mutex);
++ mutex_init(&codec->control_mutex);
++ snd_array_init(&codec->mixers, sizeof(struct hda_nid_item), 32);
++ snd_array_init(&codec->nids, sizeof(struct hda_nid_item), 32);
++ snd_array_init(&codec->init_pins, sizeof(struct hda_pincfg), 16);
++ snd_array_init(&codec->driver_pins, sizeof(struct hda_pincfg), 16);
++ snd_array_init(&codec->cvt_setups, sizeof(struct hda_cvt_setup), 8);
++ snd_array_init(&codec->spdif_out, sizeof(struct hda_spdif_out), 16);
++ snd_array_init(&codec->jacktbl, sizeof(struct hda_jack_tbl), 16);
++ snd_array_init(&codec->verbs, sizeof(struct hda_verb *), 8);
++ INIT_LIST_HEAD(&codec->conn_list);
++ INIT_LIST_HEAD(&codec->pcm_list_head);
++ refcount_set(&codec->pcm_ref, 1);
++ init_waitqueue_head(&codec->remove_sleep);
++
++ INIT_DELAYED_WORK(&codec->jackpoll_work, hda_jackpoll_work);
++ codec->depop_delay = -1;
++ codec->fixup_id = HDA_FIXUP_ID_NOT_SET;
+
+ #ifdef CONFIG_PM
+ codec->power_jiffies = jiffies;
+--
+2.38.1
+
diff --git a/PKGBUILD b/PKGBUILD
index bef645d9787f..d6427f5dd161 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -69,7 +69,7 @@ _subarch=
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-ck
pkgver=6.0.3
-pkgrel=1
+pkgrel=2
arch=(x86_64)
url="https://wiki.archlinux.org/index.php/Linux-ck"
license=(GPL2)
@@ -98,6 +98,7 @@ source=(
0006-drm-amdgpu-use-DRM_SCHED_FENCE_DONT_PIPELINE-for-VM-.patch
0007-drm-amdgpu-Fix-VRAM-BO-swap-issue.patch
0008-drm-amdgpu-Fix-for-BO-move-issue.patch
+ 0009-Revert-ALSA-hda-Fix-page-fault-in-snd_hda_codec_shut.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -115,7 +116,8 @@ sha256sums=('b0d522241805794d8af3a67d331ba063a16496c6fb6d365d48f7ed78ee1c3dcf'
'22e15d9cc9b59da9febe0ea28c6d862828bb304160d310c83ce21934658fe80a'
'0fa8801cbab408513d740b41e325498dd5468b5055e6e456daa727178d678b97'
'530a4b74bc6df917c401a0a0b0c1658a8e9ee361b22b6cd56e1305858c190fb5'
- '322267bec409b46de82f1ed2b8e37cd5cd26bcd5e935f7f4581d21a48a6894e7')
+ '322267bec409b46de82f1ed2b8e37cd5cd26bcd5e935f7f4581d21a48a6894e7'
+ '55947d864c380b47a0306b5701c8d1a988dbbbb12515e65159cd14a231b93de2')
prepare() {
cd linux-${pkgver}