summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2021-09-18 14:40:04 -0400
committergraysky2021-09-18 14:40:04 -0400
commit7e796cd4418da11e84cf18ee0ec8e6ca40dc7de4 (patch)
tree3b0d44dde62d3c9c8f809581827304f70fdec07e
parente5a1ffac2fe1ab89c016e40ad2850320da243ab3 (diff)
downloadaur-7e796cd4418da11e84cf18ee0ec8e6ca40dc7de4.tar.gz
Update to 5.14.6-1
-rw-r--r--.SRCINFO12
-rw-r--r--0002-SUNRPC-don-t-pause-on-incomplete-allocation.patch59
-rw-r--r--0002-watchdog-iTCO_wdt-Fix-detection-of-SMI-off-case.patch42
-rw-r--r--PKGBUILD8
4 files changed, 69 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4acb208d9887..882c90034455 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-ck
- pkgver = 5.14.5
+ pkgver = 5.14.6
pkgrel = 1
url = https://wiki.archlinux.org/index.php/Linux-ck
arch = x86_64
@@ -12,22 +12,22 @@ pkgbase = linux-ck
makedepends = tar
makedepends = xz
options = !strip
- source = https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.14.5.tar.xz
- source = https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.14.5.tar.sign
+ source = https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.14.6.tar.xz
+ source = https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.14.6.tar.sign
source = config
source = more-uarches-20210914.tar.gz::https://github.com/graysky2/kernel_compiler_patch/archive/20210914.tar.gz
source = xanmod-patches-from-ck-e2d48df5def86f498766b22e836a9c2f1bcb3809.tar.gz::https://github.com/xanmod/linux-patches/archive/e2d48df5def86f498766b22e836a9c2f1bcb3809.tar.gz
source = 0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- source = 0002-watchdog-iTCO_wdt-Fix-detection-of-SMI-off-case.patch
+ source = 0002-SUNRPC-don-t-pause-on-incomplete-allocation.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
- b2sums = 9a647c2d153a11e15bd3b730d6da73bb21777d349b2cbd213986aa76b531cbb3fa4397845d4ad5f69c6c517adf65aa6d36b169f3dce9ea2bea770dbb3628d141
+ b2sums = a60c98265c4e795cb8fad90c57b9237b586423c6c8d6961c2f64db13bc6203925e3e6d79ff8858f32363a45f7f1a463de1014fddf9f4a14216a3d3ba638327d6
b2sums = SKIP
b2sums = a0f4869294fe26b51f88171b235377df3ab8ad7f93824933f98e7706057419bb9cf2adf31422c0fc654dd07376e375545bc06bd1148666bb638f6640ec281e7b
b2sums = d1c083f96f645679c5214e05f906b47f17ac6a8b3dd2faeb219e3ceda3a008e3fe47c4a79b0345978cec5c5e28da9b20727970cf5c788d52c3782dc5b36aa211
b2sums = bd20774ee2c9856601af2c89a3af95c6abc812b71253368090e9c252edcce452f416bfeed54ced0886d401b5a9e1cb72c16ea5f04a72d8ded596c0d083f80e42
b2sums = 7addf1973ad4284c5313da2f78e91f1ec4693c472c1bf892f377dfce051d62ba4d1adf00d70f5f015206f53d55faa589e076a60401defb4e9632ed04d310e2bc
- b2sums = c1bfe16e54181905301bbf6b4334e4ea17f9e81f15455e96890610f4447c7cca405e968801c71544f080d8220a4c02e933da3a36c10b56a8a874725ade83a5c3
+ b2sums = 61e39425d70ec9e4225e21cc10c413c99fc47babe6d6570171f83833ea4b1e51b34050bcf7726db163d78af74eae95a490f6cdd51599769c259230bb96fab901
pkgname = linux-ck
pkgdesc = The Linux-ck kernel and modules with ck's hrtimer patches
diff --git a/0002-SUNRPC-don-t-pause-on-incomplete-allocation.patch b/0002-SUNRPC-don-t-pause-on-incomplete-allocation.patch
new file mode 100644
index 000000000000..731e0867921b
--- /dev/null
+++ b/0002-SUNRPC-don-t-pause-on-incomplete-allocation.patch
@@ -0,0 +1,59 @@
+From 7cf57afbcb7a538a94480ff8546d08d4a264464a Mon Sep 17 00:00:00 2001
+From: NeilBrown <neilb@suse.de>
+Date: Mon, 30 Aug 2021 08:36:34 +1000
+Subject: [PATCH 2/3] SUNRPC: don't pause on incomplete allocation
+
+alloc_pages_bulk_array() attempts to allocate at least one page based on
+the provided pages, and then opportunistically allocates more if that
+can be done without dropping the spinlock.
+
+So if it returns fewer than requested, that could just mean that it
+needed to drop the lock. In that case, try again immediately.
+
+Only pause for a time if no progress could be made.
+
+Reported-and-tested-by: Mike Javorski <mike.javorski@gmail.com>
+Reported-and-tested-by: Lothar Paltins <lopa@mailbox.org>
+Fixes: f6e70aab9dfe ("SUNRPC: refresh rq_pages using a bulk page allocator")
+Signed-off-by: NeilBrown <neilb@suse.de>
+Acked-by: Mel Gorman <mgorman@suse.com>
+Signed-off-by: Chuck Lever <chuck.lever@oracle.com>
+Fixes: https://bugs.archlinux.org/task/71775
+---
+ net/sunrpc/svc_xprt.c | 13 +++++++------
+ 1 file changed, 7 insertions(+), 6 deletions(-)
+
+diff --git a/net/sunrpc/svc_xprt.c b/net/sunrpc/svc_xprt.c
+index dbb41821b1b8..cd5a2b186f0d 100644
+--- a/net/sunrpc/svc_xprt.c
++++ b/net/sunrpc/svc_xprt.c
+@@ -662,7 +662,7 @@ static int svc_alloc_arg(struct svc_rqst *rqstp)
+ {
+ struct svc_serv *serv = rqstp->rq_server;
+ struct xdr_buf *arg = &rqstp->rq_arg;
+- unsigned long pages, filled;
++ unsigned long pages, filled, ret;
+
+ pages = (serv->sv_max_mesg + 2 * PAGE_SIZE) >> PAGE_SHIFT;
+ if (pages > RPCSVC_MAXPAGES) {
+@@ -672,11 +672,12 @@ static int svc_alloc_arg(struct svc_rqst *rqstp)
+ pages = RPCSVC_MAXPAGES;
+ }
+
+- for (;;) {
+- filled = alloc_pages_bulk_array(GFP_KERNEL, pages,
+- rqstp->rq_pages);
+- if (filled == pages)
+- break;
++ for (filled = 0; filled < pages; filled = ret) {
++ ret = alloc_pages_bulk_array(GFP_KERNEL, pages,
++ rqstp->rq_pages);
++ if (ret > filled)
++ /* Made progress, don't sleep yet */
++ continue;
+
+ set_current_state(TASK_INTERRUPTIBLE);
+ if (signalled() || kthread_should_stop()) {
+--
+2.33.0
+
diff --git a/0002-watchdog-iTCO_wdt-Fix-detection-of-SMI-off-case.patch b/0002-watchdog-iTCO_wdt-Fix-detection-of-SMI-off-case.patch
deleted file mode 100644
index 16e7ee3c1ecb..000000000000
--- a/0002-watchdog-iTCO_wdt-Fix-detection-of-SMI-off-case.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From a497875b691e68fd44cdb4110d9bf0e87ff80e98 Mon Sep 17 00:00:00 2001
-From: Jan Kiszka <jan.kiszka@siemens.com>
-Date: Mon, 26 Jul 2021 13:46:13 +0200
-Subject: [PATCH 2/3] watchdog: iTCO_wdt: Fix detection of SMI-off case
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Obviously, the test needs to run against the register content, not its
-address.
-
-Fixes: cb011044e34c ("watchdog: iTCO_wdt: Account for rebooting on second timeout")
-Cc: stable@vger.kernel.org
-Reported-by: Mantas Mikulėnas <grawity@gmail.com>
-Signed-off-by: Jan Kiszka <jan.kiszka@siemens.com>
-Reviewed-by: Paolo Bonzini <pbonzini@redhat.com>
-Reviewed-by: Guenter Roeck <linux@roeck-us.net>
-Tested-by: Mantas Mikulėnas <grawity@gmail.com>
-Link: https://lore.kernel.org/r/d84f8e06-f646-8b43-d063-fb11f4827044@siemens.com
-Signed-off-by: Guenter Roeck <linux@roeck-us.net>
-Signed-off-by: Wim Van Sebroeck <wim@linux-watchdog.org>
-Fixes: https://bugs.archlinux.org/task/72045 (?)
----
- drivers/watchdog/iTCO_wdt.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/drivers/watchdog/iTCO_wdt.c b/drivers/watchdog/iTCO_wdt.c
-index b3f604669e2c..643c6c2d0b72 100644
---- a/drivers/watchdog/iTCO_wdt.c
-+++ b/drivers/watchdog/iTCO_wdt.c
-@@ -362,7 +362,7 @@ static int iTCO_wdt_set_timeout(struct watchdog_device *wd_dev, unsigned int t)
- * Otherwise, the BIOS generally reboots when the SMI triggers.
- */
- if (p->smi_res &&
-- (SMI_EN(p) & (TCO_EN | GBL_SMI_EN)) != (TCO_EN | GBL_SMI_EN))
-+ (inl(SMI_EN(p)) & (TCO_EN | GBL_SMI_EN)) != (TCO_EN | GBL_SMI_EN))
- tmrval /= 2;
-
- /* from the specs: */
---
-2.33.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 2e2d78fefa64..2df3b0e06ff1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -64,7 +64,7 @@ _subarch=
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-ck
-pkgver=5.14.5
+pkgver=5.14.6
pkgrel=1
arch=(x86_64)
url="https://wiki.archlinux.org/index.php/Linux-ck"
@@ -86,19 +86,19 @@ source=(
"more-uarches-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_compiler_patch/archive/$_gcc_more_v.tar.gz"
"xanmod-patches-from-ck-$_commit.tar.gz::https://github.com/xanmod/linux-patches/archive/$_commit.tar.gz"
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- 0002-watchdog-iTCO_wdt-Fix-detection-of-SMI-off-case.patch
+ 0002-SUNRPC-don-t-pause-on-incomplete-allocation.patch
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-b2sums=('9a647c2d153a11e15bd3b730d6da73bb21777d349b2cbd213986aa76b531cbb3fa4397845d4ad5f69c6c517adf65aa6d36b169f3dce9ea2bea770dbb3628d141'
+b2sums=('a60c98265c4e795cb8fad90c57b9237b586423c6c8d6961c2f64db13bc6203925e3e6d79ff8858f32363a45f7f1a463de1014fddf9f4a14216a3d3ba638327d6'
'SKIP'
'a0f4869294fe26b51f88171b235377df3ab8ad7f93824933f98e7706057419bb9cf2adf31422c0fc654dd07376e375545bc06bd1148666bb638f6640ec281e7b'
'd1c083f96f645679c5214e05f906b47f17ac6a8b3dd2faeb219e3ceda3a008e3fe47c4a79b0345978cec5c5e28da9b20727970cf5c788d52c3782dc5b36aa211'
'bd20774ee2c9856601af2c89a3af95c6abc812b71253368090e9c252edcce452f416bfeed54ced0886d401b5a9e1cb72c16ea5f04a72d8ded596c0d083f80e42'
'7addf1973ad4284c5313da2f78e91f1ec4693c472c1bf892f377dfce051d62ba4d1adf00d70f5f015206f53d55faa589e076a60401defb4e9632ed04d310e2bc'
- 'c1bfe16e54181905301bbf6b4334e4ea17f9e81f15455e96890610f4447c7cca405e968801c71544f080d8220a4c02e933da3a36c10b56a8a874725ade83a5c3')
+ '61e39425d70ec9e4225e21cc10c413c99fc47babe6d6570171f83833ea4b1e51b34050bcf7726db163d78af74eae95a490f6cdd51599769c259230bb96fab901')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase