summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2023-07-27 19:18:10 -0400
committergraysky2023-07-27 19:18:10 -0400
commit9a7ad2720c089978b8526ec37257eeb84af43259 (patch)
treef85e5eaffda8cf5ae4f1b086a24012162a2e03fd
parent3b98643de398691b37a13123b55f647f539e7fdf (diff)
downloadaur-9a7ad2720c089978b8526ec37257eeb84af43259.tar.gz
Update to 6.4.7-1
-rw-r--r--.SRCINFO10
-rw-r--r--0002-Bluetooth-btusb-Fix-bluetooth-on-Intel-Macbook-2014.patch43
-rw-r--r--PKGBUILD8
3 files changed, 7 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e5140e8d6a0..e15e3c2a28ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-ck
- pkgver = 6.4.6
+ pkgver = 6.4.7
pkgrel = 1
url = https://wiki.archlinux.org/index.php/Linux-ck
arch = x86_64
@@ -15,22 +15,20 @@ pkgbase = linux-ck
makedepends = tar
makedepends = xz
options = !strip
- source = https://www.kernel.org/pub/linux/kernel/v6.x/linux-6.4.6.tar.xz
- source = https://www.kernel.org/pub/linux/kernel/v6.x/linux-6.4.6.tar.sign
+ source = https://www.kernel.org/pub/linux/kernel/v6.x/linux-6.4.7.tar.xz
+ source = https://www.kernel.org/pub/linux/kernel/v6.x/linux-6.4.7.tar.sign
source = config
source = more-uarches-20221217.tar.gz::https://github.com/graysky2/kernel_compiler_patch/archive/20221217.tar.gz
source = ck-hrtimer-2870d6ac146aa658af60bb18a9c7503efe5992d4.tar.gz::https://github.com/graysky2/linux-patches/archive/2870d6ac146aa658af60bb18a9c7503efe5992d4.tar.gz
source = 0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- source = 0002-Bluetooth-btusb-Fix-bluetooth-on-Intel-Macbook-2014.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
- sha256sums = e1ecc496efc48aaf25a6607a4b8e52d574d6f67a2b0aa1664087d301d3515ea4
+ sha256sums = de143cb61dcaa756c05f56ff35144316d810615819518a33e34754f064c4a7d8
sha256sums = SKIP
sha256sums = f9b4320b074f279d666e86870f950bcea68f9f1912093626036410b8b3152a6d
sha256sums = f1d586e111932890ad5e0df15d092fb9b3f87bae4ea17812aae9b0ec98fe2db0
sha256sums = ed0b8773d66079198edd1ecdbe0564d6ad33c641e82d85375e50a2d9e0275144
sha256sums = 123e9bdc5e28f9cac322c271cf0edd010036d2b2b1fdaba8adecf1be7ed1eb72
- sha256sums = 924d022fb47781873312494674c571d30a64d810590e9cbef6f32fc60eaba4c6
pkgname = linux-ck
pkgdesc = The Linux kernel and modules with ck's hrtimer patches
diff --git a/0002-Bluetooth-btusb-Fix-bluetooth-on-Intel-Macbook-2014.patch b/0002-Bluetooth-btusb-Fix-bluetooth-on-Intel-Macbook-2014.patch
deleted file mode 100644
index 63314c66dc4d..000000000000
--- a/0002-Bluetooth-btusb-Fix-bluetooth-on-Intel-Macbook-2014.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 4dce89f964f32b17bd8c500c6d904e757395e55c Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Tomasz=20Mo=C5=84?= <tomasz.mon@nordicsemi.no>
-Date: Thu, 13 Jul 2023 12:25:14 +0200
-Subject: [PATCH 2/3] Bluetooth: btusb: Fix bluetooth on Intel Macbook 2014
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Commit c13380a55522 ("Bluetooth: btusb: Do not require hardcoded
-interface numbers") inadvertedly broke bluetooth on Intel Macbook 2014.
-The intention was to keep behavior intact when BTUSB_IFNUM_2 is set and
-otherwise allow any interface numbers. The problem is that the new logic
-condition omits the case where bInterfaceNumber is 0.
-
-Fix BTUSB_IFNUM_2 handling by allowing both interface number 0 and 2
-when the flag is set.
-
-Fixes: c13380a55522 ("Bluetooth: btusb: Do not require hardcoded interface numbers")
-Reported-by: John Holland <johnbholland@icloud.com>
-Closes: https://bugzilla.kernel.org/show_bug.cgi?id=217651
-Signed-off-by: Tomasz Moń <tomasz.mon@nordicsemi.no>
-Tested-by: John Holland<johnbholland@icloud.com>
-Signed-off-by: Luiz Augusto von Dentz <luiz.von.dentz@intel.com>
-Cherry-picked-for: https://bugs.archlinux.org/task/78980
----
- drivers/bluetooth/btusb.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/drivers/bluetooth/btusb.c b/drivers/bluetooth/btusb.c
-index 2a8e2bb038f5..50e23762ec5e 100644
---- a/drivers/bluetooth/btusb.c
-+++ b/drivers/bluetooth/btusb.c
-@@ -4099,6 +4099,7 @@ static int btusb_probe(struct usb_interface *intf,
- BT_DBG("intf %p id %p", intf, id);
-
- if ((id->driver_info & BTUSB_IFNUM_2) &&
-+ (intf->cur_altsetting->desc.bInterfaceNumber != 0) &&
- (intf->cur_altsetting->desc.bInterfaceNumber != 2))
- return -ENODEV;
-
---
-2.41.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 62f2c22ac0f4..eac961f86c48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -71,7 +71,7 @@ _subarch=
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-ck
-pkgver=6.4.6
+pkgver=6.4.7
pkgrel=1
arch=(x86_64)
url="https://wiki.archlinux.org/index.php/Linux-ck"
@@ -103,19 +103,17 @@ source=(
"more-uarches-$_gcc_more_v.tar.gz::https://github.com/graysky2/kernel_compiler_patch/archive/$_gcc_more_v.tar.gz"
"ck-hrtimer-$_commit.tar.gz::https://github.com/graysky2/linux-patches/archive/$_commit.tar.gz"
0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
- 0002-Bluetooth-btusb-Fix-bluetooth-on-Intel-Macbook-2014.patch
)
validpgpkeys=(
ABAF11C65A2970B130ABE3C479BE3E4300411886 # Linus Torvalds
647F28654894E3BD457199BE38DBBDC86092693E # Greg Kroah-Hartman
)
-sha256sums=('e1ecc496efc48aaf25a6607a4b8e52d574d6f67a2b0aa1664087d301d3515ea4'
+sha256sums=('de143cb61dcaa756c05f56ff35144316d810615819518a33e34754f064c4a7d8'
'SKIP'
'f9b4320b074f279d666e86870f950bcea68f9f1912093626036410b8b3152a6d'
'f1d586e111932890ad5e0df15d092fb9b3f87bae4ea17812aae9b0ec98fe2db0'
'ed0b8773d66079198edd1ecdbe0564d6ad33c641e82d85375e50a2d9e0275144'
- '123e9bdc5e28f9cac322c271cf0edd010036d2b2b1fdaba8adecf1be7ed1eb72'
- '924d022fb47781873312494674c571d30a64d810590e9cbef6f32fc60eaba4c6')
+ '123e9bdc5e28f9cac322c271cf0edd010036d2b2b1fdaba8adecf1be7ed1eb72')
_make() {
test -s version
make KERNELRELEASE="$(<version)" "$@"