summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2023-06-11 07:16:19 -0400
committergraysky2023-06-11 07:16:19 -0400
commita43fde87af473d84d4ed382c3260fa9ade3279a3 (patch)
treed2f80686583fbc877a2650fdb4382b9e0dfaceb4
parent5a3efa683bec5573a45d06156c5422389a6baec6 (diff)
downloadaur-a43fde87af473d84d4ed382c3260fa9ade3279a3.tar.gz
Update to 6.3.7-1
-rw-r--r--.SRCINFO10
-rw-r--r--0002-drm-amd-display-Have-Payload-Properly-Created-After-.patch50
-rw-r--r--0003-xfs-fix-livelock-in-delayed-allocation-at-ENOSPC.patch54
-rw-r--r--0004-x86-topology-Fix-erroneous-smp_num_siblings-on-Intel.patch91
-rw-r--r--PKGBUILD6
-rw-r--r--config6
6 files changed, 11 insertions, 206 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2fc288b66238..3dbd9460aa95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-ck
- pkgver = 6.3.6
+ pkgver = 6.3.7
pkgrel = 1
url = https://wiki.archlinux.org/index.php/Linux-ck
arch = x86_64
@@ -15,17 +15,17 @@ pkgbase = linux-ck
makedepends = tar
makedepends = xz
options = !strip
- source = https://www.kernel.org/pub/linux/kernel/v6.x/linux-6.3.6.tar.xz
- source = https://www.kernel.org/pub/linux/kernel/v6.x/linux-6.3.6.tar.sign
+ source = https://www.kernel.org/pub/linux/kernel/v6.x/linux-6.3.7.tar.xz
+ source = https://www.kernel.org/pub/linux/kernel/v6.x/linux-6.3.7.tar.sign
source = config
source = more-uarches-20221217.tar.gz::https://github.com/graysky2/kernel_compiler_patch/archive/20221217.tar.gz
source = ck-hrtimer-d09271d382ae852c98e17bd7426fc8021e7b465e.tar.gz::https://github.com/graysky2/linux-patches/archive/d09271d382ae852c98e17bd7426fc8021e7b465e.tar.gz
source = 0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
- sha256sums = 7a6a1f0dfa0bf7f45f9d4a7b409315cf32267850adab4db033a17de0320a24ef
+ sha256sums = fe369743996c522a7b473e99dcf8f88847bd5cc88546fd3b7a41d9fe5a5b97a9
sha256sums = SKIP
- sha256sums = 21b9a9e542f853cdc695648d6ab6219bd2e881a4954277f241e104723c373d42
+ sha256sums = db569afceb0a321554e59564c1838987d8007d4b4247d5ee0d85eda16613591c
sha256sums = f1d586e111932890ad5e0df15d092fb9b3f87bae4ea17812aae9b0ec98fe2db0
sha256sums = f781da5ba492d8912c7d4cddac02f21c1799532182e23374c80c19ff0c617373
sha256sums = 927ea3b7f4fc525a50352464e9623ca9d99044344f30a80b91eb8adf6deb21d2
diff --git a/0002-drm-amd-display-Have-Payload-Properly-Created-After-.patch b/0002-drm-amd-display-Have-Payload-Properly-Created-After-.patch
deleted file mode 100644
index 0d8bc4fc9027..000000000000
--- a/0002-drm-amd-display-Have-Payload-Properly-Created-After-.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From dac3ac92917b844098989bbb1adde630fb54d675 Mon Sep 17 00:00:00 2001
-From: Fangzhi Zuo <jerry.zuo@amd.com>
-Date: Wed, 17 May 2023 19:37:13 +0800
-Subject: [PATCH 2/5] drm/amd/display: Have Payload Properly Created After
- Resume
-
-At drm suspend sequence, MST dc_sink is removed. When commit cached
-MST stream back in drm resume sequence, the MST stream payload is not
-properly created and added into the payload table. After resume, topology
-change is reprobed by removing existing streams first. That leads to
-no payload is found in the existing payload table as below error
-"[drm] ERROR No payload for [MST PORT:] found in mst state"
-
-1. In encoder .atomic_check routine, remove check existance of dc_sink
-2. Bypass MST by checking existence of MST root port. dc_link_type cannot
-differentiate MST port before topology is rediscovered.
-
-Reviewed-by: Wayne Lin <wayne.lin@amd.com>
-Acked-by: Tom Chung <chiahsuan.chung@amd.com>
-Signed-off-by: Fangzhi Zuo <jerry.zuo@amd.com>
-(cherry picked from https://patchwork.freedesktop.org/patch/537553/)
----
- drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c b/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
-index f54d670ab3ab..0695c7c3d489 100644
---- a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
-+++ b/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
-@@ -2813,7 +2813,7 @@ static int dm_resume(void *handle)
- * this is the case when traversing through already created
- * MST connectors, should be skipped
- */
-- if (aconnector->dc_link->type == dc_connection_mst_branch)
-+ if (aconnector && aconnector->mst_root)
- continue;
-
- mutex_lock(&aconnector->hpd_lock);
-@@ -6717,7 +6717,7 @@ static int dm_encoder_helper_atomic_check(struct drm_encoder *encoder,
- int clock, bpp = 0;
- bool is_y420 = false;
-
-- if (!aconnector->mst_output_port || !aconnector->dc_sink)
-+ if (!aconnector->mst_output_port)
- return 0;
-
- mst_port = aconnector->mst_output_port;
---
-2.40.1
-
diff --git a/0003-xfs-fix-livelock-in-delayed-allocation-at-ENOSPC.patch b/0003-xfs-fix-livelock-in-delayed-allocation-at-ENOSPC.patch
deleted file mode 100644
index 28e657809d2e..000000000000
--- a/0003-xfs-fix-livelock-in-delayed-allocation-at-ENOSPC.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From 3e7f00d639ecf9d740cb578e1fc7c8a18b110cfb Mon Sep 17 00:00:00 2001
-From: Dave Chinner <dchinner@redhat.com>
-Date: Thu, 27 Apr 2023 09:02:11 +1000
-Subject: [PATCH 3/5] xfs: fix livelock in delayed allocation at ENOSPC
-
-On a filesystem with a non-zero stripe unit and a large sequential
-write, delayed allocation will set a minimum allocation length of
-the stripe unit. If allocation fails because there are no extents
-long enough for an aligned minlen allocation, it is supposed to
-fall back to unaligned allocation which allows single block extents
-to be allocated.
-
-When the allocator code was rewritting in the 6.3 cycle, this
-fallback was broken - the old code used args->fsbno as the both the
-allocation target and the allocation result, the new code passes the
-target as a separate parameter. The conversion didn't handle the
-aligned->unaligned fallback path correctly - it reset args->fsbno to
-the target fsbno on failure which broke allocation failure detection
-in the high level code and so it never fell back to unaligned
-allocations.
-
-This resulted in a loop in writeback trying to allocate an aligned
-block, getting a false positive success, trying to insert the result
-in the BMBT. This did nothing because the extent already was in the
-BMBT (merge results in an unchanged extent) and so it returned the
-prior extent to the conversion code as the current iomap.
-
-Because the iomap returned didn't cover the offset we tried to map,
-xfs_convert_blocks() then retries the allocation, which fails in the
-same way and now we have a livelock.
-
-Reported-and-tested-by: Brian Foster <bfoster@redhat.com>
-Fixes: 85843327094f ("xfs: factor xfs_bmap_btalloc()")
-Signed-off-by: Dave Chinner <dchinner@redhat.com>
-Reviewed-by: Darrick J. Wong <djwong@kernel.org>
----
- fs/xfs/libxfs/xfs_bmap.c | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/fs/xfs/libxfs/xfs_bmap.c b/fs/xfs/libxfs/xfs_bmap.c
-index 34de6e6898c4..3ce43068daa1 100644
---- a/fs/xfs/libxfs/xfs_bmap.c
-+++ b/fs/xfs/libxfs/xfs_bmap.c
-@@ -3505,7 +3505,6 @@ xfs_bmap_btalloc_at_eof(
- * original non-aligned state so the caller can proceed on allocation
- * failure as if this function was never called.
- */
-- args->fsbno = ap->blkno;
- args->alignment = 1;
- return 0;
- }
---
-2.40.1
-
diff --git a/0004-x86-topology-Fix-erroneous-smp_num_siblings-on-Intel.patch b/0004-x86-topology-Fix-erroneous-smp_num_siblings-on-Intel.patch
deleted file mode 100644
index eedfd6df1003..000000000000
--- a/0004-x86-topology-Fix-erroneous-smp_num_siblings-on-Intel.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-From 30c93a08fd9b5d861c087c5450df981210e87fd1 Mon Sep 17 00:00:00 2001
-From: Zhang Rui <rui.zhang@intel.com>
-Date: Thu, 23 Mar 2023 09:56:40 +0800
-Subject: [PATCH 4/5] x86/topology: Fix erroneous smp_num_siblings on Intel
- Hybrid platforms
-
-Traditionally, all CPUs in a system have identical numbers of SMT
-siblings. That changes with hybrid processors where some logical CPUs
-have a sibling and others have none.
-
-Today, the CPU boot code sets the global variable smp_num_siblings when
-every CPU thread is brought up. The last thread to boot will overwrite
-it with the number of siblings of *that* thread. That last thread to
-boot will "win". If the thread is a Pcore, smp_num_siblings == 2. If it
-is an Ecore, smp_num_siblings == 1.
-
-smp_num_siblings describes if the *system* supports SMT. It should
-specify the maximum number of SMT threads among all cores.
-
-Ensure that smp_num_siblings represents the system-wide maximum number
-of siblings by always increasing its value. Never allow it to decrease.
-
-On MeteorLake-P platform, this fixes a problem that the Ecore CPUs are
-not updated in any cpu sibling map because the system is treated as an
-UP system when probing Ecore CPUs.
-
-Below shows part of the CPU topology information before and after the
-fix, for both Pcore and Ecore CPU (cpu0 is Pcore, cpu 12 is Ecore).
-...
--/sys/devices/system/cpu/cpu0/topology/package_cpus:000fff
--/sys/devices/system/cpu/cpu0/topology/package_cpus_list:0-11
-+/sys/devices/system/cpu/cpu0/topology/package_cpus:3fffff
-+/sys/devices/system/cpu/cpu0/topology/package_cpus_list:0-21
-...
--/sys/devices/system/cpu/cpu12/topology/package_cpus:001000
--/sys/devices/system/cpu/cpu12/topology/package_cpus_list:12
-+/sys/devices/system/cpu/cpu12/topology/package_cpus:3fffff
-+/sys/devices/system/cpu/cpu12/topology/package_cpus_list:0-21
-
-Notice that the "before" 'package_cpus_list' has only one CPU. This
-means that userspace tools like lscpu will see a little laptop like
-an 11-socket system:
-
--Core(s) per socket: 1
--Socket(s): 11
-+Core(s) per socket: 16
-+Socket(s): 1
-
-This is also expected to make the scheduler do rather wonky things
-too.
-
-[ dhansen: remove CPUID detail from changelog, add end user effects ]
-
-CC: stable@kernel.org
-Fixes: bbb65d2d365e ("x86: use cpuid vector 0xb when available for detecting cpu topology")
-Fixes: 95f3d39ccf7a ("x86/cpu/topology: Provide detect_extended_topology_early()")
-Suggested-by: Len Brown <len.brown@intel.com>
-Signed-off-by: Zhang Rui <rui.zhang@intel.com>
-Signed-off-by: Dave Hansen <dave.hansen@linux.intel.com>
-Acked-by: Peter Zijlstra (Intel) <peterz@infradead.org>
-Link: https://lore.kernel.org/all/20230323015640.27906-1-rui.zhang%40intel.com
----
- arch/x86/kernel/cpu/topology.c | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/arch/x86/kernel/cpu/topology.c b/arch/x86/kernel/cpu/topology.c
-index 5e868b62a7c4..0270925fe013 100644
---- a/arch/x86/kernel/cpu/topology.c
-+++ b/arch/x86/kernel/cpu/topology.c
-@@ -79,7 +79,7 @@ int detect_extended_topology_early(struct cpuinfo_x86 *c)
- * initial apic id, which also represents 32-bit extended x2apic id.
- */
- c->initial_apicid = edx;
-- smp_num_siblings = LEVEL_MAX_SIBLINGS(ebx);
-+ smp_num_siblings = max_t(int, smp_num_siblings, LEVEL_MAX_SIBLINGS(ebx));
- #endif
- return 0;
- }
-@@ -109,7 +109,8 @@ int detect_extended_topology(struct cpuinfo_x86 *c)
- */
- cpuid_count(leaf, SMT_LEVEL, &eax, &ebx, &ecx, &edx);
- c->initial_apicid = edx;
-- core_level_siblings = smp_num_siblings = LEVEL_MAX_SIBLINGS(ebx);
-+ core_level_siblings = LEVEL_MAX_SIBLINGS(ebx);
-+ smp_num_siblings = max_t(int, smp_num_siblings, LEVEL_MAX_SIBLINGS(ebx));
- core_plus_mask_width = ht_mask_width = BITS_SHIFT_NEXT_LEVEL(eax);
- die_level_siblings = LEVEL_MAX_SIBLINGS(ebx);
- pkg_mask_width = die_plus_mask_width = BITS_SHIFT_NEXT_LEVEL(eax);
---
-2.40.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 55d279888192..3fa7d0abf28c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -71,7 +71,7 @@ _subarch=
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-ck
-pkgver=6.3.6
+pkgver=6.3.7
pkgrel=1
arch=(x86_64)
url="https://wiki.archlinux.org/index.php/Linux-ck"
@@ -108,9 +108,9 @@ validpgpkeys=(
ABAF11C65A2970B130ABE3C479BE3E4300411886 # Linus Torvalds
647F28654894E3BD457199BE38DBBDC86092693E # Greg Kroah-Hartman
)
-sha256sums=('7a6a1f0dfa0bf7f45f9d4a7b409315cf32267850adab4db033a17de0320a24ef'
+sha256sums=('fe369743996c522a7b473e99dcf8f88847bd5cc88546fd3b7a41d9fe5a5b97a9'
'SKIP'
- '21b9a9e542f853cdc695648d6ab6219bd2e881a4954277f241e104723c373d42'
+ 'db569afceb0a321554e59564c1838987d8007d4b4247d5ee0d85eda16613591c'
'f1d586e111932890ad5e0df15d092fb9b3f87bae4ea17812aae9b0ec98fe2db0'
'f781da5ba492d8912c7d4cddac02f21c1799532182e23374c80c19ff0c617373'
'927ea3b7f4fc525a50352464e9623ca9d99044344f30a80b91eb8adf6deb21d2')
diff --git a/config b/config
index 607fb56a765c..d9fe67b9485b 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 6.3.3-arch1 Kernel Configuration
+# Linux/x86 6.3.7-arch1 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 13.1.1 20230429"
CONFIG_CC_IS_GCC=y
@@ -6976,7 +6976,7 @@ CONFIG_SND_SERIAL_U16550=m
CONFIG_SND_MPU401=m
CONFIG_SND_PORTMAN2X4=m
CONFIG_SND_AC97_POWER_SAVE=y
-CONFIG_SND_AC97_POWER_SAVE_DEFAULT=0
+CONFIG_SND_AC97_POWER_SAVE_DEFAULT=10
CONFIG_SND_SB_COMMON=m
CONFIG_SND_PCI=y
CONFIG_SND_AD1889=m
@@ -7081,7 +7081,7 @@ CONFIG_SND_HDA_CODEC_CA0132_DSP=y
CONFIG_SND_HDA_CODEC_CMEDIA=m
CONFIG_SND_HDA_CODEC_SI3054=m
CONFIG_SND_HDA_GENERIC=m
-CONFIG_SND_HDA_POWER_SAVE_DEFAULT=1
+CONFIG_SND_HDA_POWER_SAVE_DEFAULT=10
CONFIG_SND_HDA_INTEL_HDMI_SILENT_STREAM=y
# CONFIG_SND_HDA_CTL_DEV_ID is not set
# end of HD-Audio