summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2016-01-20 08:07:07 -0500
committergraysky2016-01-20 08:07:07 -0500
commite4ca03589e7bf230f818e21ca0802adafdd45753 (patch)
treefbc7e47993f9871c0500853f4a99ba3decc6b348
parentbb3c97bf3e416d96bf40538d9f0387e0b18770e3 (diff)
downloadaur-e4ca03589e7bf230f818e21ca0802adafdd45753.tar.gz
Update to 4.3.3-3
-rw-r--r--.SRCINFO6
-rw-r--r--CVE-2016-0728.patch78
-rw-r--r--PKGBUILD7
3 files changed, 88 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39ffcce6f682..5b1a151f243c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Dec 24 15:34:57 UTC 2015
+# Wed Jan 20 13:07:06 UTC 2016
pkgbase = linux-ck
pkgver = 4.3.3
- pkgrel = 2
+ pkgrel = 3
url = https://wiki.archlinux.org/index.php/Linux-ck
arch = i686
arch = x86_64
@@ -20,6 +20,7 @@ pkgbase = linux-ck
source = linux-ck.preset
source = change-default-console-loglevel.patch
source = 0001-disabling-primary-plane-in-the-noatomic-case.patch
+ source = CVE-2016-0728.patch
source = http://ck.kolivas.org/patches/4.0/4.3/4.3-ck3/patch-4.3-ck3.xz
source = http://repo-ck.com/source/gcc_patch/enable_additional_cpu_optimizations_for_gcc_v4.9+_kernel_v3.15+.patch.gz
source = http://algo.ing.unimo.it/people/paolo/disk_sched/patches/4.3.0-v7r8/0001-block-cgroups-kconfig-build-bits-for-BFQ-v7r8-4.3.patch
@@ -34,6 +35,7 @@ pkgbase = linux-ck
sha256sums = 2b3ebf5446aa3cac279842ca00bc1f2d6b7ff1766915282c201d763dbf6ca07e
sha256sums = 1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99
sha256sums = abdd04bd6beecb7c961130a68d71e6332bd260462eeaa2f4f8e634de813dcc4d
+ sha256sums = 03bed5b1c6ef34a917e218a46d38cd1347c5ab5693131996113c6cad275dc4e9
sha256sums = 483c12e130285cbcb49648012416323a5cb8dd8a477fa064d96c2f53019f1b31
sha256sums = cf0f984ebfbb8ca8ffee1a12fd791437064b9ebe0712d6f813fd5681d4840791
sha256sums = ebeb62206999b2749ac43bb287a6a2a5db4f6b1b688a90cefa1ceb5db94aa490
diff --git a/CVE-2016-0728.patch b/CVE-2016-0728.patch
new file mode 100644
index 000000000000..e915d8219e1a
--- /dev/null
+++ b/CVE-2016-0728.patch
@@ -0,0 +1,78 @@
+From 23567fd052a9abb6d67fe8e7a9ccdd9800a540f2 Mon Sep 17 00:00:00 2001
+From: Yevgeny Pats <yevgeny@perception-point.io>
+Date: Tue, 19 Jan 2016 22:09:04 +0000
+Subject: [PATCH] KEYS: Fix keyring ref leak in join_session_keyring()
+
+This fixes CVE-2016-0728.
+
+If a thread is asked to join as a session keyring the keyring that's already
+set as its session, we leak a keyring reference.
+
+This can be tested with the following program:
+
+ #include <stddef.h>
+ #include <stdio.h>
+ #include <sys/types.h>
+ #include <keyutils.h>
+
+ int main(int argc, const char *argv[])
+ {
+ int i = 0;
+ key_serial_t serial;
+
+ serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
+ "leaked-keyring");
+ if (serial < 0) {
+ perror("keyctl");
+ return -1;
+ }
+
+ if (keyctl(KEYCTL_SETPERM, serial,
+ KEY_POS_ALL | KEY_USR_ALL) < 0) {
+ perror("keyctl");
+ return -1;
+ }
+
+ for (i = 0; i < 100; i++) {
+ serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
+ "leaked-keyring");
+ if (serial < 0) {
+ perror("keyctl");
+ return -1;
+ }
+ }
+
+ return 0;
+ }
+
+If, after the program has run, there something like the following line in
+/proc/keys:
+
+3f3d898f I--Q--- 100 perm 3f3f0000 0 0 keyring leaked-keyring: empty
+
+with a usage count of 100 * the number of times the program has been run,
+then the kernel is malfunctioning. If leaked-keyring has zero usages or
+has been garbage collected, then the problem is fixed.
+
+Reported-by: Yevgeny Pats <yevgeny@perception-point.io>
+Signed-off-by: David Howells <dhowells@redhat.com>
+Acked-by: Don Zickus <dzickus@redhat.com>
+Acked-by: Prarit Bhargava <prarit@redhat.com>
+Acked-by: Jarod Wilson <jarod@redhat.com>
+Signed-off-by: James Morris <james.l.morris@oracle.com>
+---
+ security/keys/process_keys.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/security/keys/process_keys.c b/security/keys/process_keys.c
+index a3f85d2a..e6d50172 100644
+--- a/security/keys/process_keys.c
++++ b/security/keys/process_keys.c
+@@ -794,6 +794,7 @@ long join_session_keyring(const char *name)
+ ret = PTR_ERR(keyring);
+ goto error2;
+ } else if (keyring == new->session_keyring) {
++ key_put(keyring);
+ ret = 0;
+ goto error2;
+ }
diff --git a/PKGBUILD b/PKGBUILD
index 836c76409e7d..cebebc18d862 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -53,7 +53,7 @@ pkgname=(linux-ck linux-ck-headers)
_kernelname=-ck
_srcname=linux-4.3
pkgver=4.3.3
-pkgrel=2
+pkgrel=3
arch=('i686' 'x86_64')
url="https://wiki.archlinux.org/index.php/Linux-ck"
license=('GPL2')
@@ -71,6 +71,7 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'linux-ck.preset'
'change-default-console-loglevel.patch'
'0001-disabling-primary-plane-in-the-noatomic-case.patch'
+'CVE-2016-0728.patch'
# ck3
"http://ck.kolivas.org/patches/4.0/4.3/4.3-ck${_ckpatchversion}/${_ckpatchname}.xz"
# gcc
@@ -88,6 +89,7 @@ sha256sums=('4a622cc84b8a3c38d39bc17195b0c064d2b46945dfde0dae18f77b120bc9f3ae'
'2b3ebf5446aa3cac279842ca00bc1f2d6b7ff1766915282c201d763dbf6ca07e'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
'abdd04bd6beecb7c961130a68d71e6332bd260462eeaa2f4f8e634de813dcc4d'
+ '03bed5b1c6ef34a917e218a46d38cd1347c5ab5693131996113c6cad275dc4e9'
'483c12e130285cbcb49648012416323a5cb8dd8a477fa064d96c2f53019f1b31'
'cf0f984ebfbb8ca8ffee1a12fd791437064b9ebe0712d6f813fd5681d4840791'
'ebeb62206999b2749ac43bb287a6a2a5db4f6b1b688a90cefa1ceb5db94aa490'
@@ -108,6 +110,9 @@ prepare() {
# hangs on older intel hardware
patch -Np1 -i "${srcdir}/0001-disabling-primary-plane-in-the-noatomic-case.patch"
+ # fixes #47820 CVE-2016-0728.patch
+ patch -Np1 -i "${srcdir}/CVE-2016-0728.patch"
+
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)