summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlan Orth2019-11-11 13:39:57 +0200
committerAlan Orth2019-11-11 13:39:57 +0200
commit2a18e3aab4fa682754345e527c1b2fe0bbe488d4 (patch)
tree9aaa1159ba9b0a7320d7a01c1e820cd63c53e177
parentc3e28f0845d3e78c0cbe3dd527a4ae0a6109fce8 (diff)
downloadaur-2a18e3aab4fa682754345e527c1b2fe0bbe488d4.tar.gz
PKGBUILD: Follow Arch Linux practices for pkgver
The kernel provided by Clear Linux is, for example, 5.3.9-863. The important part of that is the upstream Linux kernel version, which is followed by Clear's own patch level. It is unfortunate that the patch level uses a dash because this makes it difficult to indicate revisions to the Arch Linux package itself. I am changing this to follow Arch Linux best practices. The version seen by pacman will be the upstream version followed by the package revision. The version reported by `uname -sr` will stay the same as it is currently, ie: Linux 5.3.9-863.native.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a8be745f4c2..8025e56df499 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-clear-bin
pkgdesc = Clear Linux kernel and modules in binary
pkgver = 5.3.9
- pkgrel = 863
+ pkgrel = 1
epoch = 0
url = https://clearlinux.org/node/15538
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 2b59007d8036..da2d1f0b1569 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,11 @@ pkgdesc="Clear Linux kernel and modules in binary"
url="https://clearlinux.org/node/15538"
pkgname=linux-clear-bin
# check org.clearlinux.native.X.Y.Z in Manifest
-pkgver="5.3.9"
-pkgrel="863"
+_major=5.3
+_minor=9
+_clr=863
+pkgver=${_major}.${_minor}
+pkgrel=1
# use in case we need to update the Arch package without incrementing pkgrel
epoch=0
arch=('x86_64')
@@ -22,7 +25,7 @@ options=('!strip')
# see: https://cdn.download.clearlinux.org/current/latest
_clear_version=31530
-_kernel_version="${pkgver}-${pkgrel}.native"
+_kernel_version="${pkgver}-${_clr}.native"
source=("https://cdn.download.clearlinux.org/update/${_clear_version}/Manifest.kernel-native"
"https://cdn.download.clearlinux.org/update/${_clear_version}/pack-kernel-native-from-0.tar"