summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2024-02-03 00:10:24 -0500
committerChris Severance2024-02-03 00:10:24 -0500
commit5f4213f354451d5791c2ff230385f4d3f58a2e4d (patch)
treeb1d7ab17dcb84ebc4e1a589c10d80e4b4dd2a6ed
parent08004c0612814ab76fec63b542512a1ad9c09311 (diff)
downloadaur-linux-firewire-utils.tar.gz
autu: Update to 0.5.0-1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
2 files changed, 28 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b951c7e3f73..38732965cecf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
-# Generated by mksrcinfo v8
-# Sun May 24 23:05:23 UTC 2020
pkgbase = linux-firewire-utils
pkgdesc = list and change the configuration of connected FireWire devices. Formerly jujuutils
- pkgver = 0.4
- pkgrel = 2
- url = https://github.com/cladisch/linux-firewire-utils
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://git.kernel.org/pub/scm/utils/ieee1394/linux-firewire-utils.git
arch = i686
arch = x86_64
arch = aarch64
- license = GPL
- depends = python2
+ license = GPL-2.0-only
+ makedepends = meson
+ depends = glibc
+ depends = bash
replaces = jujuutils
- source = linux-firewire-utils-0.4.tar.gz::https://github.com/cladisch/linux-firewire-utils/archive/v0.4.tar.gz
- md5sums = c080533c401e34e67efc4499a96f57f3
- sha256sums = 5e80636dbbb90569700fc2fa6740f08e82c48237d340ea8cec4fda1e46997ef7
+ source = https://git.kernel.org/pub/scm/utils/ieee1394/linux-firewire-utils.git/snapshot/linux-firewire-utils-0.5.0.tar.gz
+ md5sums = f04e9f8033b9cc39a4d1168e11d04aeb
+ sha256sums = 8778a12a112e1845a692238f8d49d5f354988383a09473c4848f15c199f3d90a
pkgname = linux-firewire-utils
-
diff --git a/PKGBUILD b/PKGBUILD
index e87cb0bdee58..df6e14954268 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,46 +4,47 @@ set -u
_gitauth='cladisch'
_pkgname='linux-firewire-utils'
pkgname="${_pkgname}"
-pkgver='0.4'
-pkgrel='2'
+pkgver='0.5.0'
+pkgrel='1'
pkgdesc='list and change the configuration of connected FireWire devices. Formerly jujuutils'
arch=('i686' 'x86_64' 'aarch64')
#url="http://code.google.com/p/jujuutils/"
-url="https://github.com/${_gitauth}/${_pkgname}"
-license=('GPL')
-depends=('python2')
+#url="https://github.com/${_gitauth}/${_pkgname}"
+url='https://git.kernel.org/pub/scm/utils/ieee1394/linux-firewire-utils.git'
+license=('GPL-2.0-only')
+depends=('glibc' 'bash')
+makedepends=('meson')
replaces=('jujuutils')
-_verwatch=("${url}/releases" "${url#*github.com}/archive/v\(.*\)\.tar\.gz" 'l')
+#_verwatch=("${url}/releases" "${url#*github.com}/archive/v\(.*\)\.tar\.gz" 'l')
#source=("http://jujuutils.googlecode.com/files/jujuutils-${pkgver}.tar.gz")
_srcdir="${pkgname}-${pkgver}"
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-md5sums=('c080533c401e34e67efc4499a96f57f3')
-sha256sums=('5e80636dbbb90569700fc2fa6740f08e82c48237d340ea8cec4fda1e46997ef7')
+#source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+source=("https://git.kernel.org/pub/scm/utils/ieee1394/linux-firewire-utils.git/snapshot/${_srcdir}.tar.gz")
+md5sums=('f04e9f8033b9cc39a4d1168e11d04aeb')
+sha256sums=('8778a12a112e1845a692238f8d49d5f354988383a09473c4848f15c199f3d90a')
prepare() {
set -u
cd "${_srcdir}"
- sed -e 's:\bpython\b:python2:g' -i 'src/crpp'
+ #sed -e 's:\bpython\b:python2:g' -i 'src/crpp'
+ mkdir 'build'
set +u
}
build() {
set -u
cd "${_srcdir}"
- if [ ! -s 'configure' ]; then
- aclocal
- autoconf
- automake --add-missing
+ if [ ! -s 'build/build.ninja' ]; then
+ meson setup --prefix='/usr' 'build'
fi
- ./configure --prefix='/usr'
- make -s -j1 # -j "$(nproc)" # Too small for parallel make
+ meson compile -C 'build'
set +u
}
package() {
set -u
cd "${_srcdir}"
- make -j1 DESTDIR="${pkgdir}" install
+ meson install -C 'build' --destdir "${pkgdir}"
set +u
}
set +u