summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Dmitriev2020-04-07 20:06:40 +0300
committerVictor Dmitriev2020-04-07 20:06:40 +0300
commit5923ddf9d6db7197781586e99b2e8c8896da99fa (patch)
treef7e4e1cbeda2f8d8f830fd8a60694b213c853972
parent4fadeb515205cb4dc384b7a781da5967ec82fd24 (diff)
downloadaur-5923ddf9d6db7197781586e99b2e8c8896da99fa.tar.gz
upgpkg: linux-firmware-git 20200320.edf390c-1
updates from official repos
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
2 files changed, 27 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdae54a6fe5a..d7903f2e67c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,25 @@
# Generated by mksrcinfo v8
-# Tue Sep 17 11:42:10 UTC 2019
+# Tue Apr 7 17:06:41 UTC 2020
pkgbase = linux-firmware-git
pkgdesc = Firmware files for Linux
- pkgver = 20190909.6c6918a
+ pkgver = 20200320.edf390c
pkgrel = 1
- url = http://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git;a=summary
+ url = https://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git;a=summary
arch = any
license = GPL2
license = GPL3
license = custom
makedepends = git
options = !strip
- source = linux-firmware-git::git+https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
- md5sums = SKIP
+ source = linux-firmware-git::git+https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git?signed
+ sha256sums = SKIP
pkgname = linux-firmware-git
- provides = linux-firmware=20190909.6c6918a
+ provides = linux-firmware=20200320.edf390c
conflicts = linux-firmware
pkgname = amd-ucode-git
pkgdesc = Microcode update files for AMD CPUs
- provides = amd-ucode=20190909.6c6918a
+ provides = amd-ucode=20200320.edf390c
conflicts = amd-ucode
diff --git a/PKGBUILD b/PKGBUILD
index 45f719cf3ba4..fc48979075eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,18 @@
pkgbase=linux-firmware-git
pkgname=(linux-firmware-git amd-ucode-git)
-pkgver=20190909.6c6918a
+pkgver=20200320.edf390c
pkgrel=1
pkgdesc="Firmware files for Linux"
makedepends=('git')
arch=('any')
-url="http://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git;a=summary"
+url="https://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git;a=summary"
license=('GPL2' 'GPL3' 'custom')
options=(!strip)
#branch=master
-source=("${pkgbase}::git+https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git")
-md5sums=('SKIP')
+source=("${pkgbase}::git+https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git?signed")
+sha256sums=('SKIP')
+validpgpkeys=('4CDE8575E547BF835FE15807A31B6BD72486CFD6') # Josh Boyer <jwboyer@fedoraproject.org>
pkgver() {
cd "${srcdir}/${pkgbase}"
@@ -27,9 +28,16 @@ build() {
cd "${srcdir}"
mkdir -p kernel/x86/microcode
cat "${pkgbase}/amd-ucode/microcode_amd"*.bin > kernel/x86/microcode/AuthenticAMD.bin
- # Make the .bin reproducible
- [ ! -z $SOURCE_DATE_EPOCH ] && touch -d @$SOURCE_DATE_EPOCH kernel/x86/microcode/AuthenticAMD.bin
- echo kernel/x86/microcode/AuthenticAMD.bin | bsdcpio -o -H newc -R 0:0 > amd-ucode.img
+
+ # Reproducibility: set the timestamp on the bin file
+ if [[ -n $SOURCE_DATE_EPOCH ]]; then
+ touch -d @$SOURCE_DATE_EPOCH kernel/x86/microcode/AuthenticAMD.bin
+ fi
+
+ # Reproducibility: strip the inode and device numbers from the cpio archive
+ echo kernel/x86/microcode/AuthenticAMD.bin |
+ bsdtar --uid 0 --gid 0 -cnf - -T - |
+ bsdtar --null -cf - --format=newc @- > amd-ucode.img
}
package_linux-firmware-git() {
@@ -40,13 +48,11 @@ package_linux-firmware-git() {
make DESTDIR="${pkgdir}" FIRMWAREDIR=/usr/lib/firmware install
- install -d "${pkgdir}/usr/share/licenses/linux-firmware"
- install -Dm644 LICEN* WHENCE "${pkgdir}/usr/share/licenses/linux-firmware/"
+ install -Dt "${pkgdir}/usr/share/licenses/linux-firmware" -m644 LICEN* WHENCE
# Trigger a microcode reload for configurations not using early updates
- install -d "${pkgdir}/usr/lib/tmpfiles.d"
- echo 'w /sys/devices/system/cpu/microcode/reload - - - - 1' \
- >"${pkgdir}/usr/lib/tmpfiles.d/linux-firmware.conf"
+ echo 'w /sys/devices/system/cpu/microcode/reload - - - - 1' |
+ install -Dm644 /dev/stdin "${pkgdir}/usr/lib/tmpfiles.d/linux-firmware.conf"
}
package_amd-ucode-git() {
@@ -54,9 +60,8 @@ package_amd-ucode-git() {
provides=("amd-ucode=$pkgver")
pkgdesc='Microcode update files for AMD CPUs'
- cd "${srcdir}"
- install -D -m0644 amd-ucode.img "${pkgdir}/boot/amd-ucode.img"
- install -D -m0644 "${srcdir}/${pkgbase}/LICENSE.amd-ucode" "${pkgdir}/usr/share/licenses/amd-ucode/LICENSE"
+ install -Dt "${pkgdir}/boot" -m644 "${srcdir}/amd-ucode.img"
+ install -Dm644 "${srcdir}/${pkgbase}/LICENSE.amd-ucode" "${pkgdir}/usr/share/licenses/amd-ucode/LICENSE"
}
# vim:set ts=2 sw=2 et: