summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaijian2023-05-22 12:02:44 +0200
committerTaijian2023-05-22 12:02:44 +0200
commit773502f7b635cb0895d3446e74a72244f40ad184 (patch)
tree12680f582451eba3b53308149d9690b04a440d43
parentcda36d1632832ec77e7cbfd710dd7d5e1602bf3e (diff)
downloadaur-773502f7b635cb0895d3446e74a72244f40ad184.tar.gz
update 6.3.3
-rw-r--r--.SRCINFO8
-rw-r--r--0032-Bluetooth-btusb-Add-a-new-PID-VID-0489-e0f6-for-MT7922.patch14
-rw-r--r--PKGBUILD16
-rwxr-xr-xchoose-gcc-optimization.sh1
-rwxr-xr-xchroot-build.sh47
5 files changed, 52 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db5f420c4c11..eade62f3f83f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-g14
pkgdesc = Linux
- pkgver = 6.3.2.arch1
+ pkgver = 6.3.3.arch1
pkgrel = 1
url = https://gitlab.com/dragonn/linux-g14.git
arch = x86_64
@@ -16,7 +16,7 @@ pkgbase = linux-g14
makedepends = xz
makedepends = python
options = !strip
- source = archlinux-linux::git+https://github.com/archlinux/linux?signed#tag=v6.3.2-arch1
+ source = archlinux-linux::git+https://github.com/archlinux/linux?signed#tag=v6.3.3-arch1
source = config
source = choose-gcc-optimization.sh
source = sys-kernel_arch-sources-g14_files-0004-5.17+--more-uarches-for-kernel.patch::https://raw.githubusercontent.com/graysky2/kernel_compiler_patch/master/more-uarches-for-kernel-5.17+.patch
@@ -30,6 +30,7 @@ pkgbase = linux-g14
source = 0028-patch01_gu604_alc285_fixes.patch
source = 0029-patch02_gu604v_wmi_keys.patch
source = 0031-FX516PE-rgb-mode.patch
+ source = 0032-Bluetooth-btusb-Add-a-new-PID-VID-0489-e0f6-for-MT7922.patch
source = 0001-HID-asus-Add-support-for-ASUS-ROG-Z13-keyboard.patch
source = 0002-HID-asus-add-keycodes-for-0x6a-0x4b-and-0xc7.patch
source = 0003-HID-asus-reformat-the-hotkey-mapping-block.patch
@@ -46,7 +47,7 @@ pkgbase = linux-g14
validpgpkeys = C7E7849466FE2358343588377258734B41C31549
sha256sums = SKIP
sha256sums = 6b337a9d3cfdc00005589a80b8d36fa500f6a92ed21565a3aceec48d7202a7da
- sha256sums = 38dd8add41aa2dc75a3da9d51358e28c2bd4510bd9abc54b6494d61e4a317fc2
+ sha256sums = bc8b5f303e3507c01d8543fb4352ed7dcdb9ed4eb2854788d39510f88d67f454
sha256sums = 81ad663925a0aa5b5332a69bae7227393664bb81ee2e57a283e7f16e9ff75efe
sha256sums = 0a7ea482fe20c403788d290826cec42fe395e5a6eab07b88845f8b9a9829998d
sha256sums = d45e2ae1d21b1dc8e0de94a4fa58e9a53d72306843f87d3cc49f5f641399d8e3
@@ -58,6 +59,7 @@ pkgbase = linux-g14
sha256sums = 8614c92567822e38ac7a0893e93776f39bbb6d373797f4b713cef5b3c060c8f1
sha256sums = cdbcec3031878cdb7ffab32034e4ee31bbd0ec214088f95dc446a13320985631
sha256sums = ec3cced4d3d5de4827e07430a77fcba755d84b9cfded09dc0b6be46e28427f22
+ sha256sums = a8e1e11a4ab1995cc4975c9b134a43ddfe7054ef0c965e52a7d8f9223e15c3e0
sha256sums = 14f695b481e1afc4ac8c79ef48f0613267c86d1862f3293d889f6f68e1b84188
sha256sums = 93b7ad2dd6b172d487d5e37847027f5854cae0c7291bc643d890045692903bab
sha256sums = 04167065497211326a3a6f83519111e2f81273c848143d300e7e3e91062c061b
diff --git a/0032-Bluetooth-btusb-Add-a-new-PID-VID-0489-e0f6-for-MT7922.patch b/0032-Bluetooth-btusb-Add-a-new-PID-VID-0489-e0f6-for-MT7922.patch
new file mode 100644
index 000000000000..6ab08aa9cfa7
--- /dev/null
+++ b/0032-Bluetooth-btusb-Add-a-new-PID-VID-0489-e0f6-for-MT7922.patch
@@ -0,0 +1,14 @@
+diff --git a/drivers/bluetooth/btusb.c b/drivers/bluetooth/btusb.c
+index 5c536151ef83..9b675fc9cc4f 100644
+--- a/drivers/bluetooth/btusb.c
++++ b/drivers/bluetooth/btusb.c
+@@ -565,6 +565,9 @@ static const struct usb_device_id blacklist_table[] = {
+ BTUSB_VALID_LE_STATES },
+
+ /* Additional MediaTek MT7921 Bluetooth devices */
++ { USB_DEVICE(0x0489, 0xe0f6), .driver_info = BTUSB_MEDIATEK |
++ BTUSB_WIDEBAND_SPEECH |
++ BTUSB_VALID_LE_STATES },
+ { USB_DEVICE(0x0489, 0xe0c8), .driver_info = BTUSB_MEDIATEK |
+ BTUSB_WIDEBAND_SPEECH |
+ BTUSB_VALID_LE_STATES },
diff --git a/PKGBUILD b/PKGBUILD
index 0ee9a98f480a..173dd73af5e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
pkgbase=linux-g14
-pkgver=6.3.2.arch1
+pkgver=6.3.3.arch1
pkgrel=1
pkgdesc='Linux'
_srctag=v${pkgver%.*}-${pkgver##*.}
@@ -49,6 +49,7 @@ source=(
0029-patch02_gu604v_wmi_keys.patch
0031-FX516PE-rgb-mode.patch
+ 0032-Bluetooth-btusb-Add-a-new-PID-VID-0489-e0f6-for-MT7922.patch
0001-HID-asus-Add-support-for-ASUS-ROG-Z13-keyboard.patch
0002-HID-asus-add-keycodes-for-0x6a-0x4b-and-0xc7.patch
@@ -72,7 +73,7 @@ validpgpkeys=(
sha256sums=('SKIP'
'6b337a9d3cfdc00005589a80b8d36fa500f6a92ed21565a3aceec48d7202a7da'
- '38dd8add41aa2dc75a3da9d51358e28c2bd4510bd9abc54b6494d61e4a317fc2'
+ 'bc8b5f303e3507c01d8543fb4352ed7dcdb9ed4eb2854788d39510f88d67f454'
'81ad663925a0aa5b5332a69bae7227393664bb81ee2e57a283e7f16e9ff75efe'
'0a7ea482fe20c403788d290826cec42fe395e5a6eab07b88845f8b9a9829998d'
'd45e2ae1d21b1dc8e0de94a4fa58e9a53d72306843f87d3cc49f5f641399d8e3'
@@ -84,6 +85,7 @@ sha256sums=('SKIP'
'8614c92567822e38ac7a0893e93776f39bbb6d373797f4b713cef5b3c060c8f1'
'cdbcec3031878cdb7ffab32034e4ee31bbd0ec214088f95dc446a13320985631'
'ec3cced4d3d5de4827e07430a77fcba755d84b9cfded09dc0b6be46e28427f22'
+ 'a8e1e11a4ab1995cc4975c9b134a43ddfe7054ef0c965e52a7d8f9223e15c3e0'
'14f695b481e1afc4ac8c79ef48f0613267c86d1862f3293d889f6f68e1b84188'
'93b7ad2dd6b172d487d5e37847027f5854cae0c7291bc643d890045692903bab'
'04167065497211326a3a6f83519111e2f81273c848143d300e7e3e91062c061b'
@@ -145,19 +147,13 @@ prepare() {
cp ../config .config
_make olddefconfig
diff -u ../config .config || :
-
- ## let user choose microarchitecture optimization in GCC
- ## but beause the script below does NOT work in a clean chroot, set the default here, and only
- ## change through the script if it works...
- sed 's|^CONFIG_GENERIC_CPU=y|# CONFIG_GENERIC_CPU is not set|g' -i .config
- sed 's|^CONFIG_GENERIC_CPU2=y|# CONFIG_GENERIC_CPU2 is not set|g' -i .config
- sed "s|^# $Microarchitecture is not set|$Microarchitecture=y|g" -i .config
## Make use of modprobed-db, if installed
## To do this, you need to enable copy the database into this directory and enable the relevant lines
## at the top of this file!
# _make LSMOD=../modprobed.db localmodconfig
-
+
+ ## let user choose microarchitecture optimization in GCC
## this needs to run *after* `make olddefconfig` so that our newly added configuration macros exist
sh ${srcdir}/choose-gcc-optimization.sh $_microarchitecture
diff --git a/choose-gcc-optimization.sh b/choose-gcc-optimization.sh
index b7cc02abbcca..822eb804a780 100755
--- a/choose-gcc-optimization.sh
+++ b/choose-gcc-optimization.sh
@@ -135,6 +135,7 @@ sleep 5
sed 's|^CONFIG_GENERIC_CPU=y|# CONFIG_GENERIC_CPU is not set|g' -i .config
sed 's|^CONFIG_GENERIC_CPU2=y|# CONFIG_GENERIC_CPU2 is not set|g' -i .config
+sed 's|^CONFIG_GENERIC_CPU3=y|# CONFIG_GENERIC_CPU3 is not set|g' -i .config
sed "s|^# $Microarchitecture is not set|$Microarchitecture=y|g" -i .config
echo
diff --git a/chroot-build.sh b/chroot-build.sh
index c90e44035f19..4776eb8894a4 100755
--- a/chroot-build.sh
+++ b/chroot-build.sh
@@ -1,12 +1,12 @@
-#!/bin/bash
+#!|bin|bash
## builds done in a clean chroot
-## source files taken from pkgdir/src-cache if present
-## output packages placed in pkgdir/release-pkg if present
+## source files taken from pkgdir|src-cache if present
+## output packages placed in pkgdir|release-pkg if present
-# NOTE: you can send environment variables to chroot/makepkg by stuffing them on the end of the makechrootpkg command after --
+# NOTE: you can send environment variables to chroot|makepkg by stuffing them on the end of the makechrootpkg command after --
-#CHROOT="$HOME/work/arch-kernels/build-chroot"
+#CHROOT="$HOME|work|arch-kernels|build-chroot"
HOME="$HOME"
fatal() { echo "$@" >&2; exit 1; }
@@ -15,39 +15,44 @@ if ! [[ -s PKGBUILD ]]; then
fatal "no PKGBUILD in this directory!"
fi
# look for valid chroot
-if ! [[ -d "${CHROOT}/root" ]]; then
- fatal "${CHROOT}/root doesn't exist, womp womp"
+if ! [[ -d "${CHROOT}|root" ]]; then
+ fatal "${CHROOT}|root doesn't exist, womp womp"
fi
-# if SRCDEST is empty then look for pkg src-cache/ directory and use it
-if [[ -z ${SRCDEST+x} ]] && [[ -d "$(pwd)/src-cache" ]]; then
- export SRCDEST="$(pwd)/src-cache"
+# if SRCDEST is empty then look for pkg src-cache| directory and use it
+if [[ -z ${SRCDEST+x} ]] && [[ -d "$(pwd)|src-cache" ]]; then
+ export SRCDEST="$(pwd)|src-cache"
fi
-# use supplied output directory or fall back to ./release-pkg/ if present
+# use supplied output directory or fall back to .|release-pkg| if present
if [[ -d "$DEST" ]]; then
export PKGDEST="$DEST"
export LOGDEST="$DEST"
-elif [[ -d "$(pwd)/release-pkg" ]]; then
- export PKGDEST="$(pwd)/release-pkg"
- export LOGDEST="$(pwd)/release-pkg"
+elif [[ -d "$(pwd)|release-pkg" ]]; then
+ export PKGDEST="$(pwd)|release-pkg"
+ export LOGDEST="$(pwd)|release-pkg"
fi
# use modprobed-db
cp PKGBUILD .PKGBUILD
-cp $HOME/.config/modprobed.db "$(dirname "$(readlink -f -- "$0")")"
-sed 's/# modprobed-db/ modprobed-db/g' -i PKGBUILD
-sed 's/# modprobed.db/ modprobed.db/g' -i PKGBUILD
-sed 's/# _make LSMOD/_make LSMOD/' -i PKGBUILD
-sed 's/_microarchitecture=93/_microarchitecture=15/' -i PKGBUILD
-sed "s//Microarchitecture='CONFIG_GENERIC_CPU3'/Microarchitecture='CONFIG_MZEN3'/" -i PKGBUILD
+cp $HOME|.config|modprobed.db "$(dirname "$(readlink -f -- "$0")")"
+sed 's|# modprobed-db| modprobed-db|g' -i PKGBUILD
+sed 's|# modprobed.db| modprobed.db|g' -i PKGBUILD
+sed 's|# _make LSMOD|_make LSMOD|g' -i PKGBUILD
+sed 's|_microarchitecture=93|_microarchitecture=15|g' -i PKGBUILD
+sed "s||Microarchitecture='CONFIG_GENERIC_CPU3'|Microarchitecture='CONFIG_MZEN3'|g" -i PKGBUILD
+updpkgsums
#
# To send environment variable to a PKGBUILD call this script like this:
# `rbuild.sh -- {any makepkg flags} VAR=VALUE VAR2=VALUE etc..`
#
-makechrootpkg -c -r "${CHROOT}" "$@"
+# either use makechrootpkg ...
+# makechrootpkg -c -r "${CHROOT}" "$@"
+
+# or clean-chroot-manager (AUR)
+ccm s
rm PKGBUILD
mv .PKGBUILD PKGBUILD