summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Tobias2020-05-19 21:50:41 +1000
committerDaniel Tobias2020-05-19 21:50:41 +1000
commit7edc086797c70dfb826d771c0688f6fefabb8b90 (patch)
tree234bbf589c3e3d7000c828097482f84f5aeba8de
parentaf6a5dec2e9e17bdc70c2e07e16d25620d8fd18c (diff)
downloadaur-7edc086797c70dfb826d771c0688f6fefabb8b90.tar.gz
update gcc-10-x86-fix-early-boot-crash-third-try.patch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--gcc-10-x86-fix-early-boot-crash-third-try.patch14
3 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a3198be26a3..3a3d9cfcc096 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -31,7 +31,7 @@ pkgbase = linux-lts419
sha256sums = 25517134bfb5eba79cea86fcd777a4a6a1d6cbfb2ee57656d8ffc6a910a0dfc3
sha256sums = ed3d9ee9c55e0b33aa7e4b75305e2d43f94aef071a90c276957e17483334710a
sha256sums = 81193a452440cf2040266ad33d204193176d0079d4ed3f7b92eaf45e0638a976
- sha256sums = dda5848f8fbb7969c2a72ce0258b0cb5985d2b00434b09c1cbdcd16e43e15579
+ sha256sums = 59c0397a8556f518e89a3349e41b9eea983ee7d6e10afc39c9371edefd39a9ae
pkgname = linux-lts419
pkgdesc = The LTS 4.19 Linux kernel and modules
diff --git a/PKGBUILD b/PKGBUILD
index d794354f4e97..a50a87b60e2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,7 +38,7 @@ sha256sums=('0c68f5655528aed4f99dae71a5b259edc93239fa899e2df79c055275c21749a1'
'25517134bfb5eba79cea86fcd777a4a6a1d6cbfb2ee57656d8ffc6a910a0dfc3'
'ed3d9ee9c55e0b33aa7e4b75305e2d43f94aef071a90c276957e17483334710a'
'81193a452440cf2040266ad33d204193176d0079d4ed3f7b92eaf45e0638a976'
- 'dda5848f8fbb7969c2a72ce0258b0cb5985d2b00434b09c1cbdcd16e43e15579')
+ '59c0397a8556f518e89a3349e41b9eea983ee7d6e10afc39c9371edefd39a9ae')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
diff --git a/gcc-10-x86-fix-early-boot-crash-third-try.patch b/gcc-10-x86-fix-early-boot-crash-third-try.patch
index a5b75b44629c..df7fb67304c7 100644
--- a/gcc-10-x86-fix-early-boot-crash-third-try.patch
+++ b/gcc-10-x86-fix-early-boot-crash-third-try.patch
@@ -93,7 +93,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
{
--- a/arch/x86/kernel/smpboot.c
+++ b/arch/x86/kernel/smpboot.c
-@@ -262,6 +262,14 @@ static void notrace start_secondary(void
+@@ -269,6 +269,14 @@ static void notrace start_secondary(void
wmb();
cpu_startup_entry(CPUHP_AP_ONLINE_IDLE);
@@ -110,9 +110,9 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
/**
--- a/arch/x86/xen/smp_pv.c
+++ b/arch/x86/xen/smp_pv.c
-@@ -92,6 +92,7 @@ asmlinkage __visible void cpu_bringup_an
+@@ -89,6 +89,7 @@ asmlinkage __visible void cpu_bringup_an
+ {
cpu_bringup();
- boot_init_stack_canary();
cpu_startup_entry(CPUHP_AP_ONLINE_IDLE);
+ prevent_tail_call_optimization();
}
@@ -120,9 +120,9 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
void xen_smp_intr_free_pv(unsigned int cpu)
--- a/include/linux/compiler.h
+++ b/include/linux/compiler.h
-@@ -356,4 +356,10 @@ static inline void *offset_to_ptr(const
- /* &a[0] degrades to a pointer: a different type from an array */
- #define __must_be_array(a) BUILD_BUG_ON_ZERO(__same_type((a), &(a)[0]))
+@@ -351,4 +351,10 @@ static inline void *offset_to_ptr(const
+ compiletime_assert(__native_word(t), \
+ "Need native word sized stores/loads for atomicity.")
+/*
+ * This is needed in functions which generate the stack canary, see
@@ -133,7 +133,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
#endif /* __LINUX_COMPILER_H */
--- a/init/main.c
+++ b/init/main.c
-@@ -1032,6 +1032,8 @@ asmlinkage __visible void __init start_k
+@@ -735,6 +735,8 @@ asmlinkage __visible void __init start_k
/* Do the rest non-__init'ed, we're now alive */
rest_init();