summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2023-02-06 20:47:50 +0100
committerPiotr Gorski2023-02-06 20:47:50 +0100
commit1b7a4c92e9b3824876f7f82798b1631e5c7a85a5 (patch)
tree0daf2011362a3bcdbb4e3178280587543430576d
parenta0e9ae2bb61d894da339169e7f4d8b4a0e43b90b (diff)
downloadaur-1b7a4c92e9b3824876f7f82798b1631e5c7a85a5.tar.gz
Fix numa_disabled
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD23
2 files changed, 18 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fbf0120b119b..798daaf18e9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-next-git
pkgdesc = Linux NEXT
pkgver = 20230206.r0.g129af7708234
- pkgrel = 2
+ pkgrel = 3
url = http://www.kernel.org/
arch = x86_64
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index 39a16ba773d7..bf756f00b67e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -52,7 +52,7 @@ _disable_debug=y
pkgbase=linux-next-git
pkgver=20230206.r0.g129af7708234
_srcname=linux-next
-pkgrel=2
+pkgrel=3
pkgdesc='Linux NEXT'
arch=('x86_64')
url="http://www.kernel.org/"
@@ -123,17 +123,28 @@ prepare() {
### Optionally set tickrate to 1000
if [ -n "$_1k_HZ_ticks" ]; then
- echo "Setting tick rate to 1k..."
- scripts/config -d HZ_300
- scripts/config -e HZ_1000
- scripts/config --set-val HZ 1000
+ echo "Setting tick rate to 1k..."
+ scripts/config -d HZ_300 \
+ -e HZ_1000 \
+ --set-val HZ 1000
fi
### Optionally disable NUMA for 64-bit kernels only
# (x86 kernels do not support NUMA)
if [ -n "$_NUMAdisable" ]; then
echo "Disabling NUMA from kernel config..."
- scripts/config -d NUMA
+ scripts/config -d NUMA \
+ -d AMD_NUMA \
+ -d X86_64_ACPI_NUMA \
+ -d NODES_SPAN_OTHER_NODES \
+ -d NUMA_EMU \
+ -u NODES_SHIFT \
+ -d NEED_MULTIPLE_NODES \
+ -d MOVABLE_NODE \
+ -d USE_PERCPU_NUMA_NODE_ID \
+ -d ACPI_NUMA \
+ -d NUMA_BALANCING \
+ -d NUMA_BALANCING_DEFAULT_ENABLED
fi
### Disable DEBUG