summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2023-02-06 19:54:34 +0100
committerPiotr Gorski2023-02-06 19:54:34 +0100
commit2b0a0637218150028a00d1f6166f72d4face32b8 (patch)
treeaac8373fbaf28f12b80ce41f4626e8d0dc9bd639
parente6cad8da5b053808ee0d10eb35a8e4d105f496d5 (diff)
downloadaur-2b0a0637218150028a00d1f6166f72d4face32b8.tar.gz
Add debug_disable
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD30
2 files changed, 27 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e83b6049c34..a577885e4ae0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-next-git
pkgdesc = Linux NEXT
- pkgver = 20230201.r0.g66eee64b2354
+ pkgver = 20230206.r0.g129af7708234
pkgrel = 1
url = http://www.kernel.org/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 58fac80bf03d..16d99fe7e132 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -44,10 +44,13 @@ _use_current=
### Running with a 1000 HZ tick rate
_1k_HZ_ticks=
+# Disable debug to lower the size of the kernel
+_disable_debug=y
+
### Do not edit below this line unless you know what you're doing
pkgbase=linux-next-git
-pkgver=20230201.r0.g66eee64b2354
+pkgver=20230206.r0.g129af7708234
_srcname=linux-next
pkgrel=1
pkgdesc='Linux NEXT'
@@ -121,9 +124,9 @@ prepare() {
### Optionally set tickrate to 1000
if [ -n "$_1k_HZ_ticks" ]; then
echo "Setting tick rate to 1k..."
- scripts/config -d CONFIG_HZ_300
- scripts/config -e CONFIG_HZ_1000
- scripts/config --set-val CONFIG_HZ 1000
+ scripts/config -d HZ_300
+ scripts/config -e HZ_1000
+ scripts/config --set-val HZ 1000
fi
### Optionally disable NUMA for 64-bit kernels only
@@ -133,6 +136,25 @@ prepare() {
scripts/config -d CONFIG_NUMA
fi
+ ### Disable DEBUG
+ if [ -n "$_disable_debug" ]; then
+ echo "Disabling NUMA from kernel config..."
+ scripts/config -d DEBUG_INFO \
+ -d DEBUG_INFO_BTF \
+ -d DEBUG_INFO_DWARF4 \
+ -d DEBUG_INFO_DWARF5 \
+ -d PAHOLE_HAS_SPLIT_BTF \
+ -d DEBUG_INFO_BTF_MODULES \
+ -d SLUB_DEBUG \
+ -d PM_DEBUG \
+ -d PM_ADVANCED_DEBUG \
+ -d PM_SLEEP_DEBUG \
+ -d ACPI_DEBUG \
+ -d SCHED_DEBUG \
+ -d LATENCYTOP \
+ -d DEBUG_PREEMP
+ fi
+
### Optionally load needed modules for the make localmodconfig
# See https://aur.archlinux.org/packages/modprobed-db
if [ -n "$_localmodcfg" ]; then