summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2019-10-04 13:18:00 +0200
committerPiotr Gorski2019-10-04 13:18:00 +0200
commit3bbef3d82f31a8126e23239e26470b4860cb430c (patch)
treea2af5e2912651f9740b238973cf8955f380f5901
parent356b08f8cf00a32b8b5d1ffa5d926b12f4fd17ff (diff)
downloadaur-3bbef3d82f31a8126e23239e26470b4860cb430c.tar.gz
Sync with Arch
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7665dec303e..9dedf7748956 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-next-git
- pkgver = 20191003.r0.g2521ffab5375
+ pkgver = 20191004.r0.g311ef88adfa3
pkgrel = 1
url = http://www.kernel.org/
arch = x86_64
@@ -33,10 +33,10 @@ pkgname = linux-next-git
pkgdesc = The Linux-next-git kernel and modules
install = linux.install
depends = coreutils
- depends = linux-firmware
- depends = mkinitcpio>=0.7
+ depends = kmod
+ depends = initramfs
optdepends = crda: to set the correct wireless channels of your country
- optdepends = modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig
+ optdepends = linux-firmware: firmware images needed for some devices
backup = etc/mkinitcpio.d/linux-next-git.preset
pkgname = linux-next-git-headers
diff --git a/PKGBUILD b/PKGBUILD
index 51a1913aad67..71ab90f0f15e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -47,7 +47,7 @@ _1k_HZ_ticks=
### Do not edit below this line unless you know what you're doing
pkgbase=linux-next-git
-pkgver=20191003.r0.g2521ffab5375
+pkgver=20191004.r0.g311ef88adfa3
_srcname=linux-next
pkgrel=1
arch=('x86_64')
@@ -189,8 +189,9 @@ build() {
_package() {
pkgdesc="The ${pkgbase/linux/Linux} kernel and modules"
- depends=('coreutils' 'linux-firmware' 'mkinitcpio>=0.7')
- optdepends=('crda: to set the correct wireless channels of your country' 'modprobed-db: Keeps track of EVERY kernel module that has ever been probed - useful for those of us who make localmodconfig')
+ depends=('coreutils' 'kmod' 'initramfs')
+ optdepends=('crda: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices')
backup=("etc/mkinitcpio.d/$pkgbase.preset")
install=linux.install
@@ -205,6 +206,9 @@ _package() {
install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
+ # Used by mkinitcpio to name the kernel
+ echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
+
msg2 "Installing modules..."
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install