summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2020-10-20 18:23:37 +0200
committerPiotr Gorski2020-10-20 18:23:37 +0200
commit3be7286f21b98266f2d64fbb2bd6df843952d2a8 (patch)
treeec812418e7c04eb6708177c42b8715539327b89e
parent562ea1f660a7f15271c8bf08c4584c104ffd2f7f (diff)
downloadaur-3be7286f21b98266f2d64fbb2bd6df843952d2a8.tar.gz
Set script instead of sed
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD17
2 files changed, 6 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c393e41438a7..ceac7b3a9987 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-next-git
pkgdesc = Linux NEXT
- pkgver = 20201013.r0.gf2fb1afc5730
+ pkgver = 20201016.r0.gb2926c108f9f
pkgrel = 1
url = http://www.kernel.org/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index c7cfaf0e670b..871f98aeb77a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -47,7 +47,7 @@ _1k_HZ_ticks=
### Do not edit below this line unless you know what you're doing
pkgbase=linux-next-git
-pkgver=20201013.r0.gf2fb1afc5730
+pkgver=20201016.r0.gb2926c108f9f
_srcname=linux-next
pkgrel=1
pkgdesc='Linux NEXT'
@@ -121,23 +121,16 @@ prepare() {
### Optionally set tickrate to 1000
if [ -n "$_1k_HZ_ticks" ]; then
echo "Setting tick rate to 1k..."
- sed -i -e 's/^CONFIG_HZ_300=y/# CONFIG_HZ_300 is not set/' \
- -i -e 's/^# CONFIG_HZ_1000 is not set/CONFIG_HZ_1000=y/' \
- -i -e 's/^CONFIG_HZ=300/CONFIG_HZ=1000/' ./.config
+ scripts/config --disable CONFIG_HZ_300
+ scripts/config --enable CONFIG_HZ_1000
+ scripts/config --set-val CONFIG_HZ 1000
fi
### Optionally disable NUMA for 64-bit kernels only
# (x86 kernels do not support NUMA)
if [ -n "$_NUMAdisable" ]; then
echo "Disabling NUMA from kernel config..."
- sed -i -e 's/CONFIG_NUMA=y/# CONFIG_NUMA is not set/' \
- -i -e '/CONFIG_AMD_NUMA=y/d' \
- -i -e '/CONFIG_X86_64_ACPI_NUMA=y/d' \
- -i -e '/# CONFIG_NUMA_EMU is not set/d' \
- -i -e '/CONFIG_NODES_SHIFT=5/d' \
- -i -e '/CONFIG_NEED_MULTIPLE_NODES=y/d' \
- -i -e '/CONFIG_USE_PERCPU_NUMA_NODE_ID=y/d' \
- -i -e '/CONFIG_ACPI_NUMA=y/d' ./.config
+ scripts/config --disable CONFIG_NUMA
fi
### Optionally load needed modules for the make localmodconfig