summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2018-11-22 20:54:31 +0100
committerPiotr Gorski2018-11-22 20:54:31 +0100
commit94515ce722d6f4170887dc6b5074bc469cfc9ba6 (patch)
tree70fe731dbbdcfeb5aa6518072464baeacae418ab
parente18b7b011209fbe4d189a3b3e961cde533f9f317 (diff)
downloadaur-94515ce722d6f4170887dc6b5074bc469cfc9ba6.tar.gz
Add vmlinuz symlink for systemd
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd7f4375148c..1bc4be49369b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -199,13 +199,18 @@ _package() {
cd $_srcname
msg2 "Installing boot image..."
- install -Dm644 "$(make -s image_name)" "$pkgdir/boot/vmlinuz-$pkgbase"
+ local image="$pkgdir/boot/vmlinuz-$pkgbase"
+ install -Dm644 "$(make -s image_name)" "$image"
msg2 "Installing modules..."
local modulesdir="$pkgdir/usr/lib/modules/$kernver"
mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ ln -sr "$image" "$modulesdir/vmlinuz"
+
# a place for external modules,
# with version file for building modules and running depmod from hook
local extramodules="extramodules$_kernelname"