summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrod83622020-05-15 22:14:42 -0500
committerbrod83622020-05-15 22:14:42 -0500
commit2bc5f7a8f5a1477976e08c77560fbd9b3de4ad9d (patch)
tree62643ab5dc9d6136d5a187a30de0b16f44d08b93
downloadaur-linuxsync-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD42
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2108d499a499
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = linuxsync-git
+ pkgdesc = sync android notifications to linux (client)
+ pkgver = r26.8a85256
+ pkgrel = 1
+ url = https://github.com/brod8362/linuxsync-client
+ arch = x86_64
+ license = GPL
+ makedepends = rust
+ makedepends = git
+ depends = dbus
+ depends = openssl
+ depends = glibc
+ depends = gcc-libs
+ depends = systemd-libs
+ depends = xz
+ depends = lz4
+ depends = libgcrypt
+ depends = libgpg-error
+ provides = linuxsync
+ source = linuxsync::git+https://github.com/brod8362/linuxsync-client.git
+ sha256sums = SKIP
+
+pkgname = linuxsync-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c66f6846ce6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Brod8362
+
+pkgname=linuxsync-git
+_pkgname=linuxsync
+pkgver=r26.8a85256
+pkgrel=1
+pkgdesc="sync android notifications to linux (client)"
+arch=('x86_64')
+url='https://github.com/brod8362/linuxsync-client'
+license=('GPL')
+depends=('dbus'
+ 'openssl'
+ 'glibc'
+ 'gcc-libs'
+ 'systemd-libs'
+ 'xz'
+ 'lz4'
+ 'libgcrypt'
+ 'libgpg-error')
+makedepends=('rust'
+ 'git')
+provides=('linuxsync')
+source=("$_pkgname::git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+
+ make
+}
+
+package() {
+ cd "$_pkgname"
+
+ make DESTDIR="$pkgdir/usr" install
+}