summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Cuzella2023-08-13 17:36:30 -0600
committerxiota2023-08-14 06:29:36 -0700
commit6b5bff3494f4b53d8f0f83f25c8bc29882868a26 (patch)
tree4aa85c41e572a4f4bea0b7da6bbc7183c715a224
parent8ad6518d49055c8c44ccccf9b6f90833c3a7e478 (diff)
downloadaur-linuxtv-dvb-apps.tar.gz
Fix segfault on 64-bit arches - Debian bug: 779520
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d4e59c266bc..bc99fc8c32cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linuxtv-dvb-apps
pkgdesc = Linux DVB API applications and utilities
pkgver = 1505
- pkgrel = 4
+ pkgrel = 5
url = https://www.linuxtv.org
arch = x86_64
arch = i686
@@ -21,6 +21,7 @@ pkgbase = linuxtv-dvb-apps
source = 0005-perl526.patch::https://gitweb.gentoo.org/repo/gentoo.git/plain/media-tv/linuxtv-dvb-apps/files/linuxtv-dvb-apps-1.1.1.20100223-perl526.patch
source = 0006-dvbdate.patch::https://gitweb.gentoo.org/repo/gentoo.git/plain/media-tv/linuxtv-dvb-apps/files/linuxtv-dvb-apps-1.1.1.20140321-dvbdate.patch
source = 0007-gcc10.patch::https://gitweb.gentoo.org/repo/gentoo.git/plain/media-tv/linuxtv-dvb-apps/files/linuxtv-dvb-apps-1.1.1.20140321-gcc10.patch
+ source = 0008-64-bit-addr-int-bug779520.patch::https://bugs.debian.org/cgi-bin/bugreport.cgi?att=1;bug=779520;filename=bug779520.patch;msg=17
sha256sums = SKIP
sha256sums = cd26db2922605b82fdf370d1d06557b600072ba20b3900b71b3da21a79963a9f
sha256sums = 58773c592c064eb85df2cbb64aef9d03ae0ce421065f974baa22c428db2f6d78
@@ -29,5 +30,6 @@ pkgbase = linuxtv-dvb-apps
sha256sums = 4460c9c8f4474fcc776b8d02d1c527584a81dbc84b69db9ed9a8b43ca24d49c5
sha256sums = 74b3e5b1c74339decaabedac121809fcf058d7337fd3f7e1dd353a24e10b698c
sha256sums = 10d18f1ceb311a7a247548e8a942e46381a976ee089c8073549ef78ab1fe05c6
+ sha256sums = c65d70a91b437930fb2b63c83d763c3431fd4c9a0e3248c0aed4df652dd8be16
pkgname = linuxtv-dvb-apps
diff --git a/PKGBUILD b/PKGBUILD
index 050a4c642d1e..d1ce8a07cadd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer:
+# Contributor: James Cuzella <james.cuzella@lyraphase.com>
# Contributor: Tomasz Maciej Nowak <com[dot]gmail[at]tmn505>
# Contributor: Jonathan Conder <jonno.conder@gmail.com>
# Contributor: Jaroslaw Swierczynski <swiergot@aur.archlinux.org>
@@ -8,7 +9,7 @@ _gitname="dvb-apps"
_pkgname="linuxtv-dvb-apps"
pkgname="$_pkgname"
pkgver=1505
-pkgrel=4
+pkgrel=5
_hgrev=3d43b280298c39a67d1d889e01e173f52c12da35
pkgdesc='Linux DVB API applications and utilities'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -20,11 +21,15 @@ optdepends=(
'dtv-scan-tables-git: initial tuning data necessary for scanning utils'
)
-# patch sources
+## patch collections
#_patch_url_1='https://git.busybox.net/buildroot/plain/package/dvb-apps'
_patch_url_2='https://gitweb.gentoo.org/repo/gentoo.git/plain/media-tv/linuxtv-dvb-apps/files'
#_patch_url_3='https://git.openembedded.org/meta-openembedded/plain/meta-multimedia/recipes-multimedia/dvb-apps/files'
+## Debian dvb-apps bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=779520
+_patch_url_4='https://bugs.debian.org/cgi-bin/bugreport.cgi?att=1;bug=779520;filename=bug779520.patch;msg=17'
+#_patch_url_5='https://patch-diff.githubusercontent.com/raw/tufei/dvb-apps/pull/2.patch'
+
source=(
"$_gitname"::"hg+https://linuxtv.org/hg/dvb-apps/#revision=${_hgrev}"
@@ -35,6 +40,7 @@ source=(
"0005-perl526.patch"::"$_patch_url_2/linuxtv-dvb-apps-1.1.1.20100223-perl526.patch"
"0006-dvbdate.patch"::"$_patch_url_2/linuxtv-dvb-apps-1.1.1.20140321-dvbdate.patch"
"0007-gcc10.patch"::"$_patch_url_2/linuxtv-dvb-apps-1.1.1.20140321-gcc10.patch"
+ "0008-64-bit-addr-int-bug779520.patch"::"$_patch_url_4"
)
sha256sums=(
'SKIP'
@@ -46,6 +52,7 @@ sha256sums=(
'4460c9c8f4474fcc776b8d02d1c527584a81dbc84b69db9ed9a8b43ca24d49c5'
'74b3e5b1c74339decaabedac121809fcf058d7337fd3f7e1dd353a24e10b698c'
'10d18f1ceb311a7a247548e8a942e46381a976ee089c8073549ef78ab1fe05c6'
+ 'c65d70a91b437930fb2b63c83d763c3431fd4c9a0e3248c0aed4df652dd8be16'
)
_pkgsrc="$_gitname"