summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoruser.name2020-03-07 17:45:44 -0500
committeruser.name2020-03-07 17:45:44 -0500
commitc10e30f21b1558d30d234783f5d15b360db49078 (patch)
treec8685ba54ad9386e26e29cc1520f4f3499000cb6
parent5961423db347e08673bba59a48c1e36246b3a162 (diff)
downloadaur-linvst2x.tar.gz
small source fix
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15741c8d71db..b8123fb8b565 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = linvst2x
pkgdesc = enables Windows vst's to be used as Linux vst's in Linux vst capable DAW's (single wineserver instance variant)
pkgver = 2.7
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/osxmidi/LinVst
arch = x86_64
+ makedepends = git
depends = wine
depends = python>=3.8
conflicts = linvst
conflicts = linvst-stable
- source = linvst2x::git+https://github.com/osxmidi/LinVst-X.git#tag=2.7
+ source = https://github.com/osxmidi/LinVst-X/archive/2.7.tar.gz
source = git+https://github.com/usrmusicman/ArchStudioUtils.git
- sha256sums = SKIP
+ sha256sums = 319f1518f3a868d963850d7eb6d259a955284b8348035484bea030616b2fe116
sha256sums = SKIP
pkgname = linvst2x
diff --git a/PKGBUILD b/PKGBUILD
index f60d72468025..9c1698ae812c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,25 @@
pkgname=linvst2x
pkgver=2.7
-pkgrel=2
+pkgrel=3
pkgdesc="enables Windows vst's to be used as Linux vst's in Linux vst capable DAW's (single wineserver instance variant)"
arch=('x86_64')
url="https://github.com/osxmidi/LinVst"
depends=('wine' 'python>=3.8')
+makedepends=('git')
conflicts=('linvst' 'linvst-stable')
-source=("$pkgname::git+https://github.com/osxmidi/LinVst-X.git#tag=$pkgver"
+source=("https://github.com/osxmidi/LinVst-X/archive/${pkgver}.tar.gz"
"git+https://github.com/usrmusicman/ArchStudioUtils.git")
-sha256sums=('SKIP'
+sha256sums=('319f1518f3a868d963850d7eb6d259a955284b8348035484bea030616b2fe116'
'SKIP')
build() {
- cd $srcdir/$pkgname
+ cd $srcdir/LinVst-X-${pkgver}
make DESTDIR="${pkgdir}" all
}
package() {
- cd $srcdir/$pkgname
+ cd $srcdir/LinVst-X-${pkgver}
make DESTDIR="${pkgdir}" VST_DIR="${pkgdir}/usr/bin" install
install -Dm755 $srcdir/ArchStudioUtils/w2lvst2_X $pkgdir/usr/bin/w2lvst2_X
}