summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302018-04-23 00:08:51 +0200
committerM0Rf302018-04-23 00:08:51 +0200
commit0e76f77eaf60ebe1b13785c6a2915fb155c7d03e (patch)
treebf2c901423abe75beaa6b7cfdad803a80a1949cb
parent5ae0d1b0c215078675822eb0200f05447c11db81 (diff)
downloadaur-0e76f77eaf60ebe1b13785c6a2915fb155c7d03e.tar.gz
liquidsoap: now it reworks with latest ocaml 4.06
-rw-r--r--.SRCINFO12
-rw-r--r--PACKAGES6
-rw-r--r--PKGBUILD45
3 files changed, 29 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5711769ec244..685a9a0d2888 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = liquidsoap
pkgdesc = A swiss-army knife for multimedia streaming, notably used for netradios and webtvs
pkgver = 1.3.3
- pkgrel = 1
+ pkgrel = 2
url = http://savonet.sourceforge.net/
install = liquidsoap.install
arch = i686
@@ -33,7 +33,7 @@ pkgbase = liquidsoap
depends = liblo
depends = libmad
depends = libxpm
- depends = ocaml-camomile
+ depends = ocaml-ffmpeg
depends = openssl
depends = portaudio
depends = sdl_image
@@ -43,16 +43,14 @@ pkgbase = liquidsoap
conflicts = liquidsoap-git
conflicts = liquidsoap-full
options = !makeflags
- source = https://github.com/savonet/liquidsoap/releases/download/1.3.3/liquidsoap-1.3.3-full.tar.gz
+ source = liquidsoap-1.3.3-full::git+https://github.com/savonet/liquidsoap-full
source = PACKAGES
source = liquidsoap.service
source = liquidsoap.tmpfilesd
- source = ocaml-vorbis.patch
- md5sums = 9b24051b3662fb9d6cff8fcf22baf21c
- md5sums = f2e0f1966f3258f737300947e729edb6
+ md5sums = SKIP
+ md5sums = a69d72938d424cdeb88f73a32d6a78cb
md5sums = 762d6607ff0889e34b8c874970b38bc9
md5sums = f9106e5c42cabc21c4c8464d9b1ad63e
- md5sums = 970f0668541f5f67e4ddfd7cb62cad4e
pkgname = liquidsoap
diff --git a/PACKAGES b/PACKAGES
index baadfbad2aa5..b02bcb22e83c 100644
--- a/PACKAGES
+++ b/PACKAGES
@@ -25,7 +25,7 @@ ocaml-ao
ocaml-portaudio
# ALSA is only for LINUX, and is sometimes not working.
-ocaml-alsa
+#ocaml-alsa
# PulseAudio is a cross-plateform audio sound server. It is intended to
# be a single replacement for sound support under linux, windows or OSX.
@@ -60,7 +60,7 @@ ocaml-lame
#ocaml-aacplus
# OGG is for ogg/vorbis and ogg/theora encoding and decoding
-ocaml-ogg
+#ocaml-ogg
# VORBIS is for ogg/vorbis encoding and decoding.
# you need ocaml-ogg to enable ocaml-vorbis.
@@ -121,7 +121,7 @@ ocaml-gavl
# FFMPEG is currently only used to convert from
# and to many formats.
-ocaml-ffmpeg
+#ocaml-ffmpeg
# Frei0r is a minimalistic plugin API for video sources and filters.
#ocaml-frei0r
diff --git a/PKGBUILD b/PKGBUILD
index 13ed6c0398f2..27553126a8c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,51 +2,48 @@
pkgname=liquidsoap
pkgver=1.3.3
-pkgrel=1
+pkgrel=2
pkgdesc="A swiss-army knife for multimedia streaming, notably used for netradios and webtvs"
arch=('i686' 'x86_64')
url="http://savonet.sourceforge.net/"
license=('GPL')
-depends=('faad2' 'ffmpeg' 'fluidsynth' 'gavl' 'gd' 'giflib' 'gst-plugins-bad' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-ugly' 'libao' 'libfdk-aac' 'liblo' 'libmad' 'libxpm' 'ocaml-camomile' 'openssl' 'portaudio' 'sdl_image' 'sdl_ttf' 'soundtouch' 'taglib')
+depends=('faad2' 'ffmpeg' 'fluidsynth' 'gavl' 'gd' 'giflib' 'gst-plugins-bad' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-ugly' 'libao' 'libfdk-aac' 'liblo' 'libmad' 'libxpm' 'ocaml-ffmpeg' 'openssl' 'portaudio' 'sdl_image' 'sdl_ttf' 'soundtouch' 'taglib')
makedepends=('dssi' 'frei0r-plugins' 'ladspa' 'libxml-perl' 'ocaml-gd4o' 'ocaml-ocamlsdl' 'ocaml-pcre' 'ocaml-ssl' 'ocaml-xmlm' 'ocaml-yojson' 'perl-xml-dom')
-source=(https://github.com/savonet/$pkgname/releases/download/$pkgver/$pkgname-$pkgver-full.tar.gz
+source=("$pkgname-$pkgver-full::git+https://github.com/savonet/liquidsoap-full"
PACKAGES
$pkgname.service
$pkgname.tmpfilesd
- ocaml-vorbis.patch
)
-
+
install=$pkgname.install
options=(!makeflags)
conflicts=('liquidsoap-git' 'liquidsoap-full')
prepare() {
- cd $srcdir/$pkgname-$pkgver-full
- # Patches
- patch -Np1 -i ../ocaml-vorbis.patch
-
- cp $srcdir/PACKAGES PACKAGES
+ cd $srcdir/$pkgname-$pkgver-full
+ ./bootstrap
+ git submodule update --remote --merge
+ cp $srcdir/PACKAGES PACKAGES
}
build() {
- cd $srcdir/$pkgname-$pkgver-full
+ cd $srcdir/$pkgname-$pkgver-full
- ./configure --prefix=/usr --localstatedir=/var --sysconfdir=/etc --without-user --without-group
- make all && make doc
+ ./configure --prefix=/usr --localstatedir=/var --sysconfdir=/etc --without-user --without-group --disable-camomile --disable-oss
+ make all && make doc
}
package() {
- cd $srcdir/$pkgname-$pkgver-full
- make DESTDIR="$pkgdir/" datadir="$pkgdir/usr/share/" mandir="$pkgdir/usr/share/man/" localstatedir="$pkgdir/var" bindir="$pkgdir/usr/bin/" libdir="$pkgdir/usr/lib/" sysconfdir="$pkgdir/etc/" install
+ cd $srcdir/$pkgname-$pkgver-full
+ make DESTDIR="$pkgdir/" datadir="$pkgdir/usr/share/" mandir="$pkgdir/usr/share/man/" localstatedir="$pkgdir/var" bindir="$pkgdir/usr/bin/" libdir="$pkgdir/usr/lib/" sysconfdir="$pkgdir/etc/" install
-# Install systemd unit
- install -Dm0644 "$srcdir/$pkgname.service" "$pkgdir/usr/lib/systemd/system/liquidsoap@.service"
-# Install the tmpfilesd file
- install -Dm0644 $srcdir/$pkgname.tmpfilesd $pkgdir/usr/lib/tmpfiles.d/liquidsoap.conf
+ # Install systemd unit
+ install -Dm0644 "$srcdir/$pkgname.service" "$pkgdir/usr/lib/systemd/system/liquidsoap@.service"
+ # Install the tmpfilesd file
+ install -Dm0644 $srcdir/$pkgname.tmpfilesd $pkgdir/usr/lib/tmpfiles.d/liquidsoap.conf
}
-md5sums=('9b24051b3662fb9d6cff8fcf22baf21c'
- 'f2e0f1966f3258f737300947e729edb6'
- '762d6607ff0889e34b8c874970b38bc9'
- 'f9106e5c42cabc21c4c8464d9b1ad63e'
- '970f0668541f5f67e4ddfd7cb62cad4e')
+md5sums=('SKIP'
+ 'a69d72938d424cdeb88f73a32d6a78cb'
+ '762d6607ff0889e34b8c874970b38bc9'
+'f9106e5c42cabc21c4c8464d9b1ad63e')