summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonard de Ruijter2016-03-26 17:25:01 +0100
committerLeonard de Ruijter2016-03-26 17:25:01 +0100
commita960db6d4ca8f8132990c832b3bd925b2cf1436e (patch)
treebce2c0f6b3627b9eb5574c57a2bcfb6538bba578
parentce6f3756b8cf4f324b263e6fd90a575102c564eb (diff)
downloadaur-a960db6d4ca8f8132990c832b3bd925b2cf1436e.tar.gz
Try to work arround ffmpeg issue by using newer ocaml-ffmpeg code
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--ffmpeg_fixes.patch67
3 files changed, 79 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64e4c3f4bb5d..97385b5c487e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Mar 22 08:08:03 UTC 2016
+# Sat Mar 26 16:24:40 UTC 2016
pkgbase = liquidsoap
pkgdesc = a swiss-army knife for multimedia streaming, notably used for netradios and webtvs
pkgver = 1.2.0
- pkgrel = 2
+ pkgrel = 3
url = http://savonet.sourceforge.net/
install = liquidsoap.install
arch = i686
@@ -20,7 +20,7 @@ pkgbase = liquidsoap
makedepends = ocaml-yojson
makedepends = perl-xml-dom
depends = faad2
- depends = ffmpeg2.8
+ depends = ffmpeg
depends = gavl
depends = gd
depends = giflib
@@ -43,10 +43,12 @@ pkgbase = liquidsoap
source = PACKAGES
source = liquidsoap.service
source = liquidsoap.tmpfilesd
+ source = ffmpeg_fixes.patch
sha256sums = a20601a893da0716c186619afbfd848a92fbc88bca91a40665e06c7a97a92787
sha256sums = 7aada825a04a63566b57df3258525edc7d2f797300d5725c47f6920ef03a07b2
sha256sums = df6d2cec1be47a57a02ed04a1f527c0349221fad39d8d152aca13734d3808661
sha256sums = 9f286958af0c751c2a43d74614cdd1c4629c0583d619875385c09417a5383675
+ sha256sums = df4290b50504b9e6d75c0f1b3b3a2dcb41a656b5ec5cc62eab6d08d21641d94b
pkgname = liquidsoap
diff --git a/PKGBUILD b/PKGBUILD
index 2390a86030ae..edbe70142f80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,32 @@
pkgname=liquidsoap
pkgver=1.2.0
-pkgrel=2
+pkgrel=3
pkgdesc="a swiss-army knife for multimedia streaming, notably used for netradios and webtvs"
arch=('i686' 'x86_64')
url="http://savonet.sourceforge.net/"
license=('GPL')
-depends=('faad2' 'ffmpeg2.8' 'gavl' 'gd' 'giflib' 'gst-plugins-base-libs' 'libao' 'libfdk-aac' 'liblo' 'libmad' 'libxpm'
+depends=('faad2' 'ffmpeg' 'gavl' 'gd' 'giflib' 'gst-plugins-base-libs' 'libao' 'libfdk-aac' 'liblo' 'libmad' 'libxpm'
'ocaml-camomile' 'portaudio' 'sdl_image' 'sdl_ttf' 'soundtouch' 'taglib')
makedepends=('dssi' 'frei0r-plugins' 'ladspa' 'libxml-perl' 'ocaml-gd4o' 'ocaml-ocamlsdl' 'ocaml-pcre' 'ocaml-xmlm' 'ocaml-yojson' 'perl-xml-dom')
source=(https://github.com/savonet/$pkgname/releases/download/$pkgver/$pkgname-$pkgver-full.tar.bz2
PACKAGES
$pkgname.service
-$pkgname.tmpfilesd)
+$pkgname.tmpfilesd
+ffmpeg_fixes.patch)
install=$pkgname.install
options=(!makeflags)
conflicts=('liquidsoap-git' 'liquidsoap-full')
sha256sums=('a20601a893da0716c186619afbfd848a92fbc88bca91a40665e06c7a97a92787'
'7aada825a04a63566b57df3258525edc7d2f797300d5725c47f6920ef03a07b2'
'df6d2cec1be47a57a02ed04a1f527c0349221fad39d8d152aca13734d3808661'
- '9f286958af0c751c2a43d74614cdd1c4629c0583d619875385c09417a5383675')
+ '9f286958af0c751c2a43d74614cdd1c4629c0583d619875385c09417a5383675'
+ 'df4290b50504b9e6d75c0f1b3b3a2dcb41a656b5ec5cc62eab6d08d21641d94b')
prepare() {
cd $srcdir/$pkgname-$pkgver-full
cp $srcdir/PACKAGES PACKAGES
+patch -Np1 -i "${srcdir}/ffmpeg_fixes.patch"
}
build() {
diff --git a/ffmpeg_fixes.patch b/ffmpeg_fixes.patch
new file mode 100644
index 000000000000..1b3a94a99b65
--- /dev/null
+++ b/ffmpeg_fixes.patch
@@ -0,0 +1,67 @@
+--- liquidsoap-1.2.0-full/ocaml-ffmpeg-0.1.1/src/avutil_stubs.c 2015-08-03 17:47:57.000000000 +0200
++++ avutil_stubs.c 2016-03-26 17:11:26.000000000 +0100
+@@ -10,22 +10,22 @@
+ #include <libavutil/pixfmt.h>
+ #include <libavutil/pixdesc.h>
+
+-static const enum PixelFormat PIXEL_FORMATS[] = {
+- PIX_FMT_YUV420P,
+- PIX_FMT_YUYV422,
+- PIX_FMT_RGB24,
+- PIX_FMT_BGR24,
+- PIX_FMT_YUV422P,
+- PIX_FMT_YUV444P,
+- PIX_FMT_YUV410P,
+- PIX_FMT_YUV411P,
+- PIX_FMT_YUVJ422P,
+- PIX_FMT_YUVJ444P,
+- PIX_FMT_RGBA,
+- PIX_FMT_BGRA
++static const enum AVPixelFormat PIXEL_FORMATS[] = {
++ AV_PIX_FMT_YUV420P,
++ AV_PIX_FMT_YUYV422,
++ AV_PIX_FMT_RGB24,
++ AV_PIX_FMT_BGR24,
++ AV_PIX_FMT_YUV422P,
++ AV_PIX_FMT_YUV444P,
++ AV_PIX_FMT_YUV410P,
++ AV_PIX_FMT_YUV411P,
++ AV_PIX_FMT_YUVJ422P,
++ AV_PIX_FMT_YUVJ444P,
++ AV_PIX_FMT_RGBA,
++ AV_PIX_FMT_BGRA
+ };
+
+-int PixelFormat_val(value v)
++enum AVPixelFormat PixelFormat_val(value v)
+ {
+ return PIXEL_FORMATS[Int_val(v)];
+ }
+@@ -33,10 +33,10 @@
+ CAMLprim value caml_avutil_bits_per_pixel(value pixel)
+ {
+ CAMLparam1(pixel);
+- int p = Int_val(pixel);
++ enum AVPixelFormat p = PixelFormat_val(pixel);
+ int ans;
+
+- ans = av_get_bits_per_pixel(&av_pix_fmt_descriptors[p]);
++ ans = av_get_bits_per_pixel(av_pix_fmt_desc_get(p));
+
+ CAMLreturn(Val_int(ans));
+ }
+--- liquidsoap-1.2.0-full/ocaml-ffmpeg-0.1.1/src/swscale_stubs.c 2015-08-03 17:47:57.000000000 +0200
++++ ocaml-ffmpeg/src/swscale_stubs.c 2016-03-26 17:11:26.000000000 +0100
+@@ -90,10 +90,10 @@
+ CAMLlocal1(ans);
+ int src_w = Int_val(src_w_);
+ int src_h = Int_val(src_h_);
+- enum PixelFormat src_format = PixelFormat_val(src_format_);
++ enum AVPixelFormat src_format = PixelFormat_val(src_format_);
+ int dst_w = Int_val(dst_w_);
+ int dst_h = Int_val(dst_h_);
+- enum PixelFormat dst_format = PixelFormat_val(dst_format_);
++ enum AVPixelFormat dst_format = PixelFormat_val(dst_format_);
+ int flags = 0;
+ int i;
+ struct SwsContext *c;