summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrej Radović2024-05-02 11:11:26 +0200
committerAndrej Radović2024-05-02 11:11:26 +0200
commit2d683634248f43bd4c2f5a0798f1977195ce4cf1 (patch)
tree6fe83653abd41fe90221ae9563f6e4b6ca40cecb
parentd5e61f2a0d193e8435e711b2fd77731c92ceeb7e (diff)
downloadaur-2d683634248f43bd4c2f5a0798f1977195ce4cf1.tar.gz
Updated to 1.10.1, updated packaging.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
2 files changed, 16 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12caf098201d..875390a27610 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = litecli
pkgdesc = A command-line client for SQLite databases that has auto-completion and syntax highlighting.
- pkgver = 1.10.0
+ pkgver = 1.10.1
pkgrel = 1
url = https://github.com/dbcli/litecli
arch = any
license = BSD
- makedepends = python-distribute
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = python-click
depends = python-pygments
@@ -15,7 +17,7 @@ pkgbase = litecli
depends = python-cli_helpers
provides = litecli
conflicts = litecli-git
- source = litecli-1.10.0.zip::https://github.com/dbcli/litecli/archive/v1.10.0.zip
- md5sums = 749a0ab4ba215ce0c06c15fe3cc5172b
+ source = https://files.pythonhosted.org/packages/source/l/litecli/litecli-1.10.1.tar.gz
+ md5sums = bc9de3126aebcdbaca287ce2241cbff7
pkgname = litecli
diff --git a/PKGBUILD b/PKGBUILD
index 5a939f9b23f8..2b62e3275b94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrej Radović <r.andrej@gmail.com>
pkgname=litecli
-pkgver=1.10.0
+pkgver=1.10.1
pkgrel=1
pkgdesc="A command-line client for SQLite databases that has auto-completion "\
"and syntax highlighting."
@@ -17,18 +17,19 @@ depends=(
'python-configobj'
'python-cli_helpers'
)
-makedepends=('python-distribute')
-source=(
- $pkgname-$pkgver.zip::https://github.com/dbcli/litecli/archive/v$pkgver.zip
-)
+makedepends=(python-build python-installer python-wheel)
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
provides=('litecli')
conflicts=('litecli-git')
-md5sums=('749a0ab4ba215ce0c06c15fe3cc5172b')
+md5sums=('bc9de3126aebcdbaca287ce2241cbff7')
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
package() {
cd "$srcdir/${pkgname}-${pkgver}"
- sed -i "s/cli_helpers\[styles\] >= 1.0.1/cli_helpers >= 1.1.0/g" \
- setup.py
- python setup.py install --root="$pkgdir/" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -D "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}