summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Theodorou2016-07-04 13:35:54 +0100
committerAngelo Theodorou2016-07-04 13:35:54 +0100
commit3bfbcb2a1dbfcc0ecc8dbb8e158ac4d6630bcae6 (patch)
tree2e659c3a6d702b8739a74d6c4a75b3c4eeec1dde
parent172941b733cca64854dd5d2349202806ca598ae2 (diff)
downloadaur-3bfbcb2a1dbfcc0ecc8dbb8e158ac4d6630bcae6.tar.gz
Update to 2.6.3
-rw-r--r--PKGBUILD14
-rw-r--r--lives.changelog8
2 files changed, 17 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f2ca3e30c1e..f4c44c70b8a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
# Contributor: Angelo Theodorou <encelo@users.sourceforge.net>
pkgname=lives
-pkgver=2.6.0
+pkgver=2.6.3
pkgrel=1
pkgdesc="A Video Editing System"
arch=('i686' 'x86_64')
url="http://lives-video.com"
license=('GPL')
-depends=('mplayer' 'imagemagick' 'gtk3' 'sox' 'libvisual' 'liboil' 'libavc1394' 'mjpegtools' 'python' 'ffmpeg' 'jack' 'fftw')
+depends=('mplayer' 'imagemagick' 'gtk3' 'sox' 'libvisual' 'liboil' 'libavc1394' 'mjpegtools' 'python' 'ffmpeg2.8' 'jack' 'fftw')
optdepends=('xorg-utils' 'sdl' 'libogg' 'mkvtoolnix-cli' 'libmatroska' 'ogmtools' 'dvgrab' 'cdrkit' 'lame' 'youtube-dl')
options=(!libtool)
changelog=lives.changelog
source=(http://lives-video.com/releases/LiVES-$pkgver.tar.bz2)
-md5sums=('9cd5299b00f43fb321e0f132fe68bb0b')
-
+md5sums=('b5fad0838b180902f8304b1978bbac41')
build() {
cd "$srcdir"/$pkgname-$pkgver
# /bin/touch -> /usr/bin/touch
find -type f -exec sed -i 's:/bin/touch:/usr&:g' {} \;
- ./configure --prefix=/usr
+ PKG_CONFIG_PATH=/usr/lib/ffmpeg2.8/pkgconfig\
+ ./configure --prefix=/usr --enable-turbo
make
}
@@ -29,4 +29,8 @@ package() {
make DESTDIR="$pkgdir" install
rm "$pkgdir"/usr/bin/lives
ln -s /usr/bin/lives-exe "$pkgdir"/usr/bin/lives
+
+ rmdir "$pkgdir"/usr/share/doc/lives-2.6.3/html/libweed
+ rmdir "$pkgdir"/usr/share/lives/plugins/effects/compound/icons
+ rmdir "$pkgdir"/usr/lib/lives/plugins/effects/realtime/weed/icons
}
diff --git a/lives.changelog b/lives.changelog
index b0e522000a66..83cc70ef877a 100644
--- a/lives.changelog
+++ b/lives.changelog
@@ -1,3 +1,11 @@
+2016-07-04 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Added "--enable-turbo" option to the configure script
+ Added ffmpeg2.8 as a dependency instead of ffmpeg
+ Exported a pkg-config variable in order to compile with FFmpeg 2.8
+ Added commands to remove empty directories from the package
+
2015-08-22 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
* PKGBUILD :