summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmile Yvan Boutet Livoff2018-12-17 22:11:11 +0100
committerEmile Yvan Boutet Livoff2018-12-17 22:11:11 +0100
commit8203510d6ddefe15a0db44899b6406a1f13382d2 (patch)
tree319d9683573813a2b55f660af4dbe3f49a961102
parente4d89202ca140639654900bbfb3187b002ff5119 (diff)
downloadaur-lix-ereader.tar.gz
Update to 1.0.33
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD26
-rw-r--r--lix.desktop.patch10
3 files changed, 30 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b1082e07465..3830ce6c0d76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lix-ereader
pkgdesc = A proprietary e-reader
- pkgver = 1.0.21
+ pkgver = 1.0.33
pkgrel = 1
url = https://www.lix.com/
arch = x86_64
@@ -11,8 +11,7 @@ pkgbase = lix-ereader
depends = gtk2
depends = nss
depends = libxtst
- source = https://download.lix.com/linux/latest
- md5sums = 7b090d0d71edaa4cf7f09025d7caec96
+ source = https://download.lix.com/linux/Lix.AppImage
+ sha256sums = 3284104160aa56a62bf09b0f609ea306cd86c0e6d9f1c31a5052d2959297c120
pkgname = lix-ereader
-
diff --git a/PKGBUILD b/PKGBUILD
index cc461cbe7519..99c1f916b293 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Emile Boutet-Livoff <emilelivoff@gmail.com>
pkgname=lix-ereader
-pkgver=1.0.21
+pkgver=1.0.33
pkgrel=1
pkgdesc="A proprietary e-reader"
arch=('x86_64')
@@ -14,29 +14,45 @@ PKGEXT='.pkg.tar'
#Might depend on libappindicator-gtk2, gconf, libindicator-gtk2, libnotify
#It has it's own libnode.so and libffmpeg.so
depends=('alsa-lib' 'libxss' 'gconf' 'gtk2' 'nss' 'libxtst')
-source=("https://download.lix.com/linux/latest")
-md5sums=("7b090d0d71edaa4cf7f09025d7caec96")
+source=("https://download.lix.com/linux/Lix.AppImage")
+sha256sums=("3284104160aa56a62bf09b0f609ea306cd86c0e6d9f1c31a5052d2959297c120")
prepare() {
cd "${srcdir}"
+ # Start by extracting the AppImage using the built-in extracting feature
+ chmod +x ./Lix.AppImage
+ ./Lix.AppImage --appimage-extract
+ mv squashfs-root/* .
+ rmdir squashfs-root
+ # Remove AppImage, it's no longer useful
+ rm Lix.AppImage
+
# Remove libraries, they are dependencies
rm -r usr/lib
+
+ # Remove AppRun, it's unneeded
+ rm AppRun
+ # Remove lix.png it's just a symlink
+ rm lix.png
- # Desktop Entry
+ # Fix desktop Entry
patch -uN lix.desktop ../lix.desktop.patch || return 1
mkdir -p usr/share/applications
mv lix.desktop usr/share/applications/lix-ereader.desktop
# Move the main chunk of it into opt
mkdir -p opt/lix-ereader
- mv usr/bin/* opt/lix-ereader
+ # Everything except opt and usr
+ mv $(ls -A | grep -v opt | grep -v usr) opt/lix-ereader
# Add a symlink for the executable
+ mkdir -p usr/bin
ln -s /opt/lix-ereader/lix usr/bin/lix-ereader
# Make the usr/share/icons have the world executable bit set
chmod -R a+xr usr/share/icons
+ chmod a+xr usr/ usr/share opt/lix-ereader/locales opt/lix-ereader/resources
}
package() {
diff --git a/lix.desktop.patch b/lix.desktop.patch
index 38f1588b8d61..ccb5d78f9a80 100644
--- a/lix.desktop.patch
+++ b/lix.desktop.patch
@@ -1,3 +1,5 @@
+--- lix.desktop.orig 2018-12-17 22:02:00.986002246 +0100
++++ lix.desktop 2018-12-17 22:05:24.586237965 +0100
@@ -1,10 +1,10 @@
[Desktop Entry]
Name=Lix
@@ -7,7 +9,7 @@
Terminal=false
Type=Application
-Icon=lix
-+Icon=/usr/share/icons/default/48x48/apps/lix.png
- X-AppImage-Version=1.0.21
- X-AppImage-BuildId=4137aba0-ba69-11a8-395a-9f6da4565c39
- Categories=Education;
++Icon=/usr/share/icons/hicolor/64x64/apps/lix.png
+ StartupWMClass=Lix
+ X-AppImage-Version=1.0.33
+ MimeType=x-scheme-handler/lix;