summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel R. van Rossum2015-06-18 16:27:37 -0500
committerDaniel R. van Rossum2015-06-18 16:27:37 -0500
commitc8aab06219b8af5b5c51fec8c916f04cad51ede0 (patch)
tree849ff19da710388bf49b049e02b6e4462b0a78f9
downloadaur-c8aab06219b8af5b5c51fec8c916f04cad51ede0.tar.gz
initial import
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD54
-rw-r--r--llpp.install11
3 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a22c3b4a06c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = llpp
+ pkgdesc = Lightweight, fast and featureful PDF viewer based on MuPDF
+ pkgver = 21
+ pkgrel = 3
+ url = http://repo.or.cz/w/llpp.git
+ install = llpp.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = ocaml
+ makedepends = ninja
+ makedepends = ocaml-lablgl
+ depends = mupdf
+ depends = openssl
+ depends = openjpeg2
+ depends = libx11
+ depends = desktop-file-utils
+ optdepends = xsel: Text selection
+ optdepends = file: automatic file type recognition
+ optdepends = gzip: handling of MIME types 'application/x-{gzip,compress}'
+ optdepends = xz: handling of MIME type 'application/x-xz'
+ optdepends = bzip2: handling of MIME type 'application/x-bzip2'
+ optdepends = djvulibre: djvu conversion
+ optdepends = ghostscript: ps, dvi, and djvu conversion
+ optdepends = princexml: html conversion
+ optdepends = unoconv: conversion of office documents
+ optdepends = librsvg: preferred option for svg conversion
+ optdepends = inkscape: alternative option for svg conversion
+ optdepends = imagemagick: image conversion
+ optdepends = antiword: conversion of Microsoft Word (.doc) documents (option 2)
+ optdepends = zip: png and jpeg conversion
+ optdepends = texlive-core: dvi conversion
+ options = !strip
+ source = http://repo.or.cz/w/llpp.git/snapshot/f376f8000cdf01fcc0ae3aa1fed99f193d6e7909.tar.gz
+ sha256sums = SKIP
+
+pkgname = llpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21690abbb24e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Daan van Rossum <d.r.vanrossum at gmx dot de>
+# Contributor: Bartlomiej Piotrowski <nospam@bpiotrowski.pl>
+
+pkgname=llpp
+pkgver=21
+_pkgname=${pkgname}-f376f80
+pkgrel=3
+pkgdesc='Lightweight, fast and featureful PDF viewer based on MuPDF'
+arch=('i686' 'x86_64')
+url='http://repo.or.cz/w/llpp.git'
+license=('custom')
+depends=('mupdf' 'openssl' 'openjpeg2' 'libx11' 'desktop-file-utils')
+makedepends=('ocaml' 'ninja' 'ocaml-lablgl')
+source=(http://repo.or.cz/w/llpp.git/snapshot/f376f8000cdf01fcc0ae3aa1fed99f193d6e7909.tar.gz)
+install=llpp.install
+sha256sums=('SKIP')
+
+optdepends=(
+ # llpp
+ 'xsel: Text selection'
+ # llppac
+ 'file: automatic file type recognition'
+ "gzip: handling of MIME types 'application/x-{gzip,compress}'"
+ "xz: handling of MIME type 'application/x-xz'"
+ "bzip2: handling of MIME type 'application/x-bzip2'"
+ 'djvulibre: djvu conversion'
+ 'ghostscript: ps, dvi, and djvu conversion'
+ 'princexml: html conversion'
+ 'unoconv: conversion of office documents'
+ 'librsvg: preferred option for svg conversion'
+ 'inkscape: alternative option for svg conversion'
+ 'imagemagick: image conversion'
+ 'antiword: conversion of Microsoft Word (.doc) documents (option 2)'
+ 'zip: png and jpeg conversion'
+ 'texlive-core: dvi conversion'
+)
+options=('!strip')
+
+build() {
+ cd $_pkgname
+ sed -i -e 's/openjpeg/openjp2 -lX11/' configure.sh
+ sh configure.sh .
+ echo "mujs=-lmujs" >>.config
+ ninja $srcdir/$_pkgname/build/llpp.custom
+}
+
+package() {
+ cd $_pkgname
+ install -Dm755 build/llpp.custom "$pkgdir"/usr/bin/llpp
+ install -m755 misc/llppac "$pkgdir"/usr/bin/llppac
+
+ install -Dm0644 misc/llpp.desktop "$pkgdir"/usr/share/applications/llpp.desktop
+ install -Dm0644 README "$pkgdir"/usr/share/licenses/llpp/README
+}
diff --git a/llpp.install b/llpp.install
new file mode 100644
index 000000000000..b8c7ebf27b7e
--- /dev/null
+++ b/llpp.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}