summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLW-archlinux2019-08-22 23:23:18 +0200
committerLW-archlinux2019-08-22 23:23:18 +0200
commit65cebdfc333733d4cb0c7067b0116646f3aeee2e (patch)
tree9013c0f1cd17749de9c4782fb896092ef53732cf
parent920a2195205a4b452f460195a3ebca0deb5f9026 (diff)
downloadaur-65cebdfc333733d4cb0c7067b0116646f3aeee2e.tar.gz
patch added to work better with gcc 9, alos removed hardcoded version for ocaml
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD28
-rw-r--r--always-initialize-all-members-in-ABIArgInfo.patch27
3 files changed, 64 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 390508310feb..69b08773bced 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = llvm-git
- pkgver = 9.0.0_r321420.937ff6e701b
+ pkgver = 10.0.0_r325028.b43923da5bb
pkgrel = 1
url = https://llvm.org/
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = llvm-git
makedepends = ncurses
makedepends = libxml2
makedepends = python-sphinx
- makedepends = ocaml=4.07.1
+ makedepends = ocaml
makedepends = ocaml-ctypes
makedepends = ocaml-findlib
makedepends = python-sphinx
@@ -22,30 +22,32 @@ pkgbase = llvm-git
source = llvm-project::git+https://github.com/llvm/llvm-project.git
source = llvm-config.h
source = enable-SSP-and-PIE-by-default.patch
+ source = always-initialize-all-members-in-ABIArgInfo.patch
sha256sums = SKIP
sha256sums = 597dc5968c695bbdbb0eac9e8eb5117fcd2773bc91edf5ec103ecffffab8bc48
sha256sums = 58f86da25eb230ed6d423b5b61870cbf3bef88f38103ca676a2c7f34b2372171
+ sha256sums = 355553ff360002000d57fc00cd5c753a261c85aafbb9c8b328bef7b8b5a403c1
pkgname = llvm-git
pkgdesc = LLVM development version. includes clang and many other tools
- depends = llvm-libs-git=9.0.0_r321420.937ff6e701b-1
+ depends = llvm-libs-git=10.0.0_r325028.b43923da5bb-1
depends = perl
optdepends = python: for scripts
optdepends = python-setuptools: for using lit (LLVM Integrated Tester)
optdepends = ocaml: for ocaml support
provides = aur-llvm-git
- provides = compiler-rt-git=9.0.0_r321420.937ff6e701b-1
- provides = clang-git=9.0.0_r321420.937ff6e701b-1
- provides = lld-git=9.0.0_r321420.937ff6e701b-1
- provides = lldb-git=9.0.0_r321420.937ff6e701b-1
- provides = polly-git=9.0.0_r321420.937ff6e701b-1
- provides = llvm-ocaml-git=9.0.0_r321420.937ff6e701b-1
- provides = compiler-rt=9.0.0_r321420.937ff6e701b-1
- provides = clang=9.0.0_r321420.937ff6e701b-1
- provides = lld=9.0.0_r321420.937ff6e701b-1
- provides = lldb=9.0.0_r321420.937ff6e701b-1
- provides = polly=9.0.0_r321420.937ff6e701b-1
- provides = llvm-ocaml=9.0.0_r321420.937ff6e701b-1
+ provides = compiler-rt-git=10.0.0_r325028.b43923da5bb-1
+ provides = clang-git=10.0.0_r325028.b43923da5bb-1
+ provides = lld-git=10.0.0_r325028.b43923da5bb-1
+ provides = lldb-git=10.0.0_r325028.b43923da5bb-1
+ provides = polly-git=10.0.0_r325028.b43923da5bb-1
+ provides = llvm-ocaml-git=10.0.0_r325028.b43923da5bb-1
+ provides = compiler-rt=10.0.0_r325028.b43923da5bb-1
+ provides = clang=10.0.0_r325028.b43923da5bb-1
+ provides = lld=10.0.0_r325028.b43923da5bb-1
+ provides = lldb=10.0.0_r325028.b43923da5bb-1
+ provides = polly=10.0.0_r325028.b43923da5bb-1
+ provides = llvm-ocaml=10.0.0_r325028.b43923da5bb-1
conflicts = llvm
conflicts = compiler-rt
conflicts = clang
@@ -63,6 +65,6 @@ pkgname = llvm-libs-git
depends = ncurses
depends = libxml2
provides = aur-llvm-libs-git
- provides = llvm-libs=9.0.0_r321420.937ff6e701b-1
+ provides = llvm-libs=10.0.0_r325028.b43923da5bb-1
conflicts = llvm-libs
diff --git a/PKGBUILD b/PKGBUILD
index 5fd4e1ab659d..e0e61717a314 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,22 +15,23 @@
pkgname=('llvm-git' 'llvm-libs-git')
-pkgver=9.0.0_r321420.937ff6e701b
+pkgver=10.0.0_r325028.b43923da5bb
pkgrel=1
-_ocaml_ver=4.07.1
arch=('x86_64')
url="https://llvm.org/"
license=('custom:University of Illinois/NCSA Open Source License')
makedepends=( 'git' 'cmake' 'ninja' 'libffi' 'libedit' 'ncurses' 'libxml2' 'python-sphinx'
- "ocaml=$_ocaml_ver" 'ocaml-ctypes' 'ocaml-findlib'
+ 'ocaml' 'ocaml-ctypes' 'ocaml-findlib'
'python-sphinx' 'python-recommonmark' 'swig' 'python')
source=("llvm-project::git+https://github.com/llvm/llvm-project.git"
'llvm-config.h'
- 'enable-SSP-and-PIE-by-default.patch')
+ 'enable-SSP-and-PIE-by-default.patch'
+ 'always-initialize-all-members-in-ABIArgInfo.patch')
sha256sums=('SKIP'
'597dc5968c695bbdbb0eac9e8eb5117fcd2773bc91edf5ec103ecffffab8bc48'
- '58f86da25eb230ed6d423b5b61870cbf3bef88f38103ca676a2c7f34b2372171')
+ '58f86da25eb230ed6d423b5b61870cbf3bef88f38103ca676a2c7f34b2372171'
+ '355553ff360002000d57fc00cd5c753a261c85aafbb9c8b328bef7b8b5a403c1')
# NINJAFLAGS is an env var used to pass commandline options to ninja
# NOTE: It's your responbility to validate the value of $NINJAFLAGS. If unsure, don't set it.
@@ -60,12 +61,19 @@ prepare() {
rm -rf _build
fi
mkdir _build
+
cd llvm-project
- pushd clang
- patch -Np1 -i "$srcdir"/enable-SSP-and-PIE-by-default.patch
- popd
# llvm-project contains a lot of stuff, remove parts that aren't used by this package
rm -rf debuginfo-tests libclc libcxx libcxxabi libunwind llgo openmp parallel-libs pstl
+
+ # The following patch was reverted upstream because it triggered an ICE with
+ # GCC 7; however, we need it to pass the test suite when building with GCC 9
+ # https://bugs.llvm.org/show_bug.cgi?id=40547
+ # manually adapted to apply cleanly with latest master
+ patch --forward --strip=1 --input="$srcdir"/always-initialize-all-members-in-ABIArgInfo.patch
+
+ cd clang
+ patch --forward --strip=1 --input="$srcdir"/enable-SSP-and-PIE-by-default.patch
}
build() {
@@ -106,8 +114,10 @@ check() {
ninja $NINJAFLAGS check
ninja $NINJAFLAGS check-polly
ninja $NINJAFLAGS check-lld
- ninja $NINJAFLAGS check-lldb
+ # check-lldb causes ninja to hang at 99%, disabled those tests for now
+# ninja $NINJAFLAGS check-lldb
ninja $NINJAFLAGS check-clang
+ ninja $NINJAFLAGS check-clang-tools
}
package_llvm-git() {
diff --git a/always-initialize-all-members-in-ABIArgInfo.patch b/always-initialize-all-members-in-ABIArgInfo.patch
new file mode 100644
index 000000000000..bcad2e978e56
--- /dev/null
+++ b/always-initialize-all-members-in-ABIArgInfo.patch
@@ -0,0 +1,27 @@
+diff --unified --recursive --text llvm-project.orig/clang/include/clang/CodeGen/CGFunctionInfo.h llvm-project.new/clang/include/clang/CodeGen/CGFunctionInfo.h
+--- llvm-project.orig/clang/include/clang/CodeGen/CGFunctionInfo.h 2019-08-15 21:40:05.816836459 +0200
++++ llvm-project.new/clang/include/clang/CodeGen/CGFunctionInfo.h 2019-08-15 21:46:13.650020726 +0200
+@@ -110,14 +110,16 @@
+ }
+
+ ABIArgInfo(Kind K)
+- : TheKind(K), PaddingInReg(false), InReg(false) {
+- }
+-
+-public:
+- ABIArgInfo()
+- : TypeData(nullptr), PaddingType(nullptr), DirectOffset(0),
+- TheKind(Direct), PaddingInReg(false), InReg(false) {}
++ : TypeData(nullptr), PaddingType(nullptr), DirectOffset(0), TheKind(K),
++ PaddingInReg(false), InAllocaSRet(false), IndirectByVal(false),
++ IndirectRealign(false), SRetAfterThis(false), InReg(false),
++ CanBeFlattened(false), SignExt(false) {}
+
++public:
++ ABIArgInfo()
++ : TypeData(nullptr), PaddingType(nullptr), DirectOffset(0),
++ TheKind(Direct), PaddingInReg(false), InReg(false) {}
++
+ static ABIArgInfo getDirect(llvm::Type *T = nullptr, unsigned Offset = 0,
+ llvm::Type *Padding = nullptr,
+ bool CanBeFlattened = true) {