summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2021-06-24 16:11:22 +0200
committerLone_Wolf2021-06-24 16:11:22 +0200
commitbb75719494a29110a0e1802e5b9cdef928f3d267 (patch)
tree76ad9b1556c7e57ddecec16717e2590b3f2b4e63
parent9e8892f61879ee5ee46e3178f407184bab422a02 (diff)
downloadaur-bb75719494a29110a0e1802e5b9cdef928f3d267.tar.gz
move more files from usr/libexec to usr/lib/clang
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b361fd907684..3bd2edbd64a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = llvm-minimal-git
- pkgver = 13.0.0_r384831.c22b09debddb
+ pkgver = 13.0.0_r391942.833bdbe93cd6
pkgrel = 1
url = https://llvm.org/
arch = x86_64
@@ -24,7 +24,7 @@ pkgbase = llvm-minimal-git
pkgname = llvm-minimal-git
pkgdesc = Collection of modular and reusable compiler and toolchain technologies
- depends = llvm-libs-minimal-git=13.0.0_r384831.c22b09debddb-1
+ depends = llvm-libs-minimal-git=13.0.0_r391942.833bdbe93cd6-1
depends = perl
optdepends = python: for using lit (LLVM Integrated Tester)
optdepends = python-setuptools: for using lit
@@ -45,4 +45,3 @@ pkgname = llvm-libs-minimal-git
depends = libxml2
optdepends = llvm-libs: for LLVMgold linker
provides = llvm-libs
-
diff --git a/PKGBUILD b/PKGBUILD
index d5d7b49d819c..7bb57fdc384f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@
pkgbase=llvm-minimal-git
pkgname=('llvm-minimal-git' 'llvm-libs-minimal-git')
-pkgver=13.0.0_r384831.c22b09debddb
+pkgver=13.0.0_r391942.833bdbe93cd6
pkgrel=1
arch=('x86_64')
url="https://llvm.org/"
@@ -114,8 +114,12 @@ package_llvm-minimal-git() {
rm "$pkgdir"/usr/lib/{LLVMgold,lib{LLVM,LTO}}.so
rm "$pkgdir"/usr/lib/libRemarks.so
- # Move analyzer scripts out of /usr/libexec
- mv "$pkgdir"/usr/libexec/{ccc,c++}-analyzer "$pkgdir"/usr/lib/clang/
+ # llvm project doesn't honor CMAKE_INSTALL_LIBEXECDIR
+ # to comply with archlinux packaging standards we have to move some files manually
+ for libexec_file in "analyze-c++" "analyze-cc" "c++-analyzer" "ccc-analyzer" "intercept-c++" "intercept-cc"
+ do
+ mv "$pkgdir"/usr/libexec/$libexec_file "$pkgdir"/usr/lib/clang/$libexec_file
+ done
rmdir "$pkgdir"/usr/libexec
sed -i 's|libexec|lib/clang|' "$pkgdir"/usr/bin/scan-build