summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrommer2023-06-09 01:33:46 +0300
committerDrommer2023-06-09 01:33:46 +0300
commite2cc31ca6781ed79ae40360a63ffcee615199d08 (patch)
tree13efefc38a6049963d1852d89c206b0e223cbb6a
parent2b0c1d1e845414679b01abba85c579c8a7a28e45 (diff)
downloadaur-llvm10.tar.gz
New patch added
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--llvm-gcc13-issue55711.patch30
3 files changed, 39 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3063672f6fc3..54582ecaee4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = llvm10
pkgver = 10.0.1
- pkgrel = 2
+ pkgrel = 3
url = https://llvm.org/
arch = x86_64
license = custom:Apache 2.0 with LLVM Exception
@@ -17,11 +17,13 @@ pkgbase = llvm10
source = https://github.com/llvm/llvm-project/releases/download/llvmorg-10.0.1/llvm-10.0.1.src.tar.xz
source = llvm-config.h
source = benchmark-register-fix.patch
+ source = llvm-gcc13-issue55711.patch
validpgpkeys = B6C8F98282B944E3B0D5C2530FC3042E345AD05D
validpgpkeys = 474E22316ABF4785A88C6E8EA2C794A986419D8A
sha256sums = c5d8e30b57cbded7128d78e5e8dad811bff97a8d471896812f57fa99ee82cdf3
sha256sums = 597dc5968c695bbdbb0eac9e8eb5117fcd2773bc91edf5ec103ecffffab8bc48
sha256sums = 6ea7fec524215f021bf4507da67247707c87640c9ec2b3314a71d1aa9c043158
+ sha256sums = bba0c07266ef175ac950246c95232d3d69c7c24a8d0b92ae632f67be7c0ba2c7
pkgname = llvm10
pkgdesc = Collection of modular and reusable compiler and toolchain technologies
diff --git a/PKGBUILD b/PKGBUILD
index 73d959b7145f..ae7e00f991e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=('llvm10' 'llvm10-libs')
pkgver=10.0.1
-pkgrel=2
+pkgrel=3
arch=('x86_64')
url="https://llvm.org/"
license=('custom:Apache 2.0 with LLVM Exception')
@@ -12,16 +12,19 @@ makedepends=('cmake' 'ninja' 'libffi' 'libedit' 'ncurses' 'libxml2'
options=('staticlibs')
source=("https://github.com/llvm/llvm-project/releases/download/llvmorg-$pkgver/llvm-$pkgver.src.tar.xz"
"llvm-config.h"
- "benchmark-register-fix.patch")
+ "benchmark-register-fix.patch"
+ "llvm-gcc13-issue55711.patch")
sha256sums=('c5d8e30b57cbded7128d78e5e8dad811bff97a8d471896812f57fa99ee82cdf3'
'597dc5968c695bbdbb0eac9e8eb5117fcd2773bc91edf5ec103ecffffab8bc48'
- '6ea7fec524215f021bf4507da67247707c87640c9ec2b3314a71d1aa9c043158')
+ '6ea7fec524215f021bf4507da67247707c87640c9ec2b3314a71d1aa9c043158'
+ 'bba0c07266ef175ac950246c95232d3d69c7c24a8d0b92ae632f67be7c0ba2c7')
validpgpkeys+=('B6C8F98282B944E3B0D5C2530FC3042E345AD05D') # Hans Wennborg <hans@chromium.org>
validpgpkeys+=('474E22316ABF4785A88C6E8EA2C794A986419D8A') # Tom Stellard <tstellar@redhat.com>
prepare() {
cd "$srcdir/llvm-$pkgver.src"
patch -Np1 -i ../benchmark-register-fix.patch
+ patch -Np1 -i ../llvm-gcc13-issue55711.patch
mkdir build
}
diff --git a/llvm-gcc13-issue55711.patch b/llvm-gcc13-issue55711.patch
new file mode 100644
index 000000000000..8c4786f2a784
--- /dev/null
+++ b/llvm-gcc13-issue55711.patch
@@ -0,0 +1,30 @@
+From 94ed2247df587f6890345afb4da9330eb8cee4ca Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyich@gmail.com>
+Date: Mon, 23 May 2022 08:03:23 +0100
+Subject: [PATCH 1/2] [Support] Add missing <cstdint> header to Signals.h
+
+Without the change llvm build fails on this week's gcc-13 snapshot as:
+
+ [ 0%] Building CXX object lib/Support/CMakeFiles/LLVMSupport.dir/Signals.cpp.o
+ In file included from llvm/lib/Support/Signals.cpp:14:
+ include/llvm/Support/Signals.h:119:8: error: variable or field 'CleanupOnSignal' declared void
+ 119 | void CleanupOnSignal(uintptr_t Context);
+ | ^~~~~~~~~~~~~~~
+
+(cherry picked from commit ff1681ddb303223973653f7f5f3f3435b48a1983)
+---
+ include/llvm/Support/Signals.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/llvm/Support/Signals.h b/include/llvm/Support/Signals.h
+index 44f5a750ff5c..937e0572d4a7 100644
+--- a/include/llvm/Support/Signals.h
++++ b/include/llvm/Support/Signals.h
+@@ -14,6 +14,7 @@
+ #ifndef LLVM_SUPPORT_SIGNALS_H
+ #define LLVM_SUPPORT_SIGNALS_H
+
++#include <cstdint>
+ #include <string>
+
+ namespace llvm {