summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Parrish2019-10-19 20:55:56 -0400
committerDavid Parrish2019-10-19 20:55:56 -0400
commit59766127703d63bba3b9a9f0ef5c33fec186e20e (patch)
treed6cc5446f33d84832bd9f4b6f6173376b834c2e4
parent2450ca6be03524824dc9ed7e03c1eddd901de3fd (diff)
downloadaur-59766127703d63bba3b9a9f0ef5c33fec186e20e.tar.gz
Update to version v0.8.0-beta
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9127da9fc39..30cba7e099a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lnd
pkgdesc = The Lightning Network Daemon, for secure off-chain bitcoin transactions.
- pkgver = 0.7.1_beta
+ pkgver = 0.8.0_beta
pkgrel = 1
url = https://github.com/lightningnetwork/lnd
arch = i686
@@ -12,8 +12,8 @@ pkgbase = lnd
provides = lnd
provides = lncli
conflicts = lnd-git
- source = lnd::git+https://github.com/lightningnetwork/lnd.git#tag=v0.7.1-beta
- md5sums = SKIP
+ source_x86_64 = lnd::git+https://github.com/lightningnetwork/lnd.git#tag=v0.8.0-beta
+ sha512sums_x86_64 = SKIP
pkgname = lnd
diff --git a/PKGBUILD b/PKGBUILD
index 47c1c3af587d..f4e0dff5bdde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Upstream: https://github.com/lightningnetwork/lnd
pkgname=('lnd')
-pkgver=0.7.1_beta
+pkgver=0.8.0_beta
_pkgver="${pkgver//_/-}"
pkgrel=1
pkgdesc='The Lightning Network Daemon, for secure off-chain bitcoin transactions.'
@@ -14,8 +14,8 @@ depends=('glibc')
makedepends=('git' 'go')
provides=('lnd' 'lncli')
conflicts=('lnd-git')
-source=("$pkgname::git+https://github.com/lightningnetwork/lnd.git#tag=v${_pkgver}")
-md5sums=('SKIP')
+source_x86_64=("$pkgname::git+https://github.com/lightningnetwork/lnd.git#tag=v${_pkgver}")
+sha512sums_x86_64=('SKIP')
# create a fake go path directory and pushd into it
# $1 real directory
@@ -37,6 +37,7 @@ prepare() {
}
build() {
+ pwd && ls
export GOPATH="$srcdir/GOPATH"
_fake_gopath_pushd "$pkgname" github.com/lightningnetwork/lnd
make && make install