summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLoic Coyle2023-01-30 20:08:05 +0100
committerLoic Coyle2023-01-30 20:08:05 +0100
commit861418c39a70686776501a1b804d885a7a744c1b (patch)
treee9b28ee39518c129cdd6524c9d832687208251aa
downloadaur-localleaf-git.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..014ac9f9d1ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = localleaf-git
+ pkgdesc = Easy breezy latex, monitor .tex files & build on change.
+ pkgver = r53.ea4cb81
+ pkgrel = 1
+ url = https://github.com/loiccoyle/localleaf
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = docker
+ source = localleaf::git+https://github.com/loiccoyle/localleaf.git
+ md5sums = SKIP
+
+pkgname = localleaf-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ad9cecd3807
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Loic Coyle <loic.coyle@hotmail.fr>
+
+_pkgname=localleaf
+pkgname="${_pkgname}-git"
+pkgver=r53.ea4cb81
+pkgrel=1
+pkgdesc='Easy breezy latex, monitor .tex files & build on change.'
+arch=('any')
+url='https://github.com/loiccoyle/localleaf'
+license=('MIT')
+depends=('docker')
+makedepends=('git')
+source=("${_pkgname}::git+https://github.com/loiccoyle/localleaf.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${_pkgname}"
+ install -D -m 755 localleaf "${pkgdir}/usr/bin/localleaf"
+ install -D -m 644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}